Indigo Renderer 4 public beta

General News and accouncements regarding the Indigo render engine
User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 4 public beta

Post by OnoSendai » Sat May 28, 2016 5:11 am

Voytech wrote:Ono,

Any chance to troubleshoot/fix the issue with older Macbooks and iMacs? Myself and a few others were unable to get the GPU going on those. Hardware supports OpenCL (NVIDIA GTX 775M).

It crashes on kernel builds.
I think these GPUs should work with the next build, we'll see.

Voytech
Posts: 236
Joined: Thu Oct 06, 2011 8:57 am

Re: Indigo Renderer 4 public beta

Post by Voytech » Sat May 28, 2016 6:06 am

OnoSendai wrote:
Voytech wrote:Ono,

Any chance to troubleshoot/fix the issue with older Macbooks and iMacs? Myself and a few others were unable to get the GPU going on those. Hardware supports OpenCL (NVIDIA GTX 775M).

It crashes on kernel builds.
I think these GPUs should work with the next build, we'll see.
Much appreciated!

User avatar
pixie
Indigo 100
Posts: 2215
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4 public beta

Post by pixie » Sat May 28, 2016 10:24 am

Fast SSS seems to be fixed on GPU

User avatar
Originalplan®
Posts: 737
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo Renderer 4 public beta

Post by Originalplan® » Wed Jun 01, 2016 5:15 am

Can we expect BiDir on GPU in the future?

Windmill
Posts: 1
Joined: Wed Jun 01, 2016 8:05 am

Re: Indigo Renderer 4 public beta

Post by Windmill » Wed Jun 01, 2016 8:11 am

Ono sent me here, so...
Here's a few numbers from my tests:

v4.0.30 & GTX 770 2GB:

McLaren: 1.66M smp/s
Bedroom: Building OpenCL kernels..... forever...

V4.0.37 & GTX 1080 8GB:

McLaren: 12M smp/s
Bedroom: 3.65M smp/s

Fast fast fast :)

User avatar
Zom-B
1st Place 100
Posts: 4655
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4 public beta

Post by Zom-B » Wed Jun 01, 2016 8:33 am

Windmill wrote:Bedroom: Building OpenCL kernels..... forever...
This is because the GPU went out of RAM, there should be a message in the Render Log :)

Happy rendering with your beast!

zio
Posts: 33
Joined: Mon Feb 24, 2014 1:48 pm

Re: Indigo Renderer 4 public beta

Post by zio » Thu Jun 02, 2016 5:41 am

Hi there :-)

How about vertex merging or indigo similar?
What are the plans?

http://www.iliyan.com/publications/Vert ... omparison/
http://cgg.mff.cuni.cz/~jaroslav/papers/2012-vcm/

User avatar
pixie
Indigo 100
Posts: 2215
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4 public beta

Post by pixie » Thu Jun 02, 2016 8:07 am

Amazing how indigo behaves differently in Linux! It's faster samples/s wise and completely responsive! With the added bonus that it doesn't bring my computer down, whereas on windows after roughly 3 minutes it would. There's only one catch, the mac that it uses for the license it's different of that of windows....

My R9 380 results:
Oscar
2.9M
Arthur's Bedroom
1.2M
Erotica test
9.0M



Windows
Oscar
2.0M
Arthur's Bedroom
Hanged
Erotica Test
6.0M

He checks my wireless pen mac address,, I thought it would be a simple case of removing it, but if I do it give "Error: License verification failed: mac_addr_sys failed."
Last edited by pixie on Thu Jun 02, 2016 9:35 am, edited 1 time in total.

User avatar
Zom-B
1st Place 100
Posts: 4655
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4 public beta

Post by Zom-B » Thu Jun 02, 2016 11:45 am

So on Linux we have a 30% Speedup??! O_o

User avatar
pixie
Indigo 100
Posts: 2215
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4 public beta

Post by pixie » Thu Jun 02, 2016 12:12 pm

Zom-B wrote:So on Linux we have a 30% Speedup??! O_o
My Radeon never worked that well on Windows (you can see just by the bedroom scene, where left my computer hang to dry for about 5 minutes, and afterwards it didn't behave much better), I'm trying to get my Nvidia card to work on linux to see if it is indeed so.

User avatar
pixie
Indigo 100
Posts: 2215
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4 public beta

Post by pixie » Sat Jun 04, 2016 10:47 pm

Any linux wiz out there? I've bumped my head the last two days trying to make my Mint Linux to eat my NVidia GTX560ti anda my Radeon R9 380. and the very best I've got was having my Radeon with OpenCL running along with Nvidia proprietary. It was quite a fight, between dead and injured almost no one got from there alive. Also my OpenGl viewport got lost in translation, and indigo uses my mac wlan as id where on windows it used my ethernet, result it is in demo mode, if i try to take it off it senses that is lacking and doesn't work either. Otherwise it runs like a charm! :)

User avatar
pixie
Indigo 100
Posts: 2215
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4 public beta

Post by pixie » Sun Jun 05, 2016 6:25 am

Messing with B.Y.O.B.' School Corridor Scene.
render time: 13'
sample rate: 2.1M
my R9 380 reaches 5x my i7-2600K CPU clocked@ 3.40GHz, altough truth be said, I think the bidir might get there around the same time.


http://www.luxrender.net/forum/viewtopi ... =14&t=6052

P.S the very same scen that once worked fine now gives me this worning:
A problem occurred with the scene:
OpenCL rendering enabled, but no devices selected.
Indigo version: Indigo Renderer v4.0.37, Linux 64-bit build.
Exporter: Blendigo 3.8.25.0
Attachments
school corridor.blend.zip
blender 'gutted' scene, check link for original
(208.78 KiB) Downloaded 79 times
corridor013_018_bidir.jpg
i7-2600K CPU@ 3.40GHz
bidir
13'30''
0.18M
corridor002.pigs
Sun
A:-121,01675°
Z:41,02983°
(113.42 KiB) Downloaded 85 times
corridor019_021_bidir.jpg
i7-2600K CPU@ 3.40GHz
bidir
19'
0.25M
corridor013_21.jpg
R9 380
13'
2.1M

Xaon
Posts: 25
Joined: Wed Jun 02, 2010 12:05 am

Re: Indigo Renderer 4 public beta

Post by Xaon » Wed Jun 08, 2016 12:50 am

Indigo crash immediately after opening on Windows 7 x64 and AMD Crimson Edition 16.6.1 Hotfix (HD 7850).

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Indigo Renderer 4 public beta

Post by thesquirell » Wed Jun 08, 2016 2:13 am

It seems that resuming the render from IGI just starts the render process from the start. Is resuming *currently broken, or I am missing something?

*correction: still broken.

User avatar
Originalplan®
Posts: 737
Joined: Sat Sep 26, 2015 8:58 pm
3D Software: Cinema 4D
Contact:

Re: Indigo Renderer 4 public beta

Post by Originalplan® » Wed Jun 08, 2016 4:12 am

thesquirell wrote:It seems that resuming the render from IGI just starts the render process from the start. Is resuming *currently broken, or I am missing something?

*correction: still broken.
Nope, broken here too. On OSX. :((((((((((((((

Post Reply
560 posts

Who is online

Users browsing this forum: No registered users and 1 guest