[BUG] Blend emit & NULL Material

Feature requests, bug reports and related discussion
Post Reply
4 posts • Page 1 of 1
Sebastian
Posts: 156
Joined: Wed Feb 28, 2007 9:16 am

[BUG] Blend emit & NULL Material

Post by Sebastian » Fri Jan 18, 2008 10:19 am

I can't Blend these two Materials to "Fake" a CandleLight.
Attachments
im1200607605.png
im1200607605.png (1.25 MiB) Viewed 1087 times

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Fri Jan 18, 2008 10:28 am

...because an emitter isn't a material...
Ono wanted to change that, I think... Somewhen xD
Emitters automatically overwrite the rest of the material and just behave like solid black diffuse materials, which simply kill every single ray. Then, Indigo starts a routine to find out, how the original pixel, where the ray was shot from, actually is coloured... Or something like this ;)

Short: It's a known limitation. Emitters aren't Emitter-materials. :)

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Post by dougal2 » Fri Jan 18, 2008 10:37 am

blendigo, right?
This isn't a bug in Indigo, but perhaps a result of mis-leading GUI arrangement in blendigo. IMO emitters shouldn't be part of the material editor ;)

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Fri Jan 18, 2008 10:40 am

Well... Blendigo *only* has this material editor, as the conversion works over converting Blender materials with an emit value, higher than zero...
So, I think, it's placed fine...
Maybe, there could be a warning. But else....

Post Reply
4 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest