Sphere light problem

Come here for help & support.
Post Reply
8 posts • Page 1 of 1
4u2ges
Posts: 13
Joined: Sat Jun 30, 2018 11:52 am

Sphere light problem

Post by 4u2ges » Fri Oct 12, 2018 1:54 pm

I wonder why is this working in ALL render modes except OpenCL? Thanks.

Code: Select all

	<sphere>
		<uid>6</uid>
		<name>Sphere</name>
		<keyframe>
			<time>0</time>
			<pos>1.7118651866912842 -0.8031731843948364 1.0611016750335693</pos>
			<rotation_quaternion>
				<axis>0 0 1</axis>
				<angle>0</angle>
			</rotation_quaternion>
		</keyframe>
		<radius>0.07999999821186066</radius>
		<material_uid>7</material_uid>
	</sphere>

	<material>
		<uid>7</uid>
		<name>Spot Light</name>
		<diffuse>
			<base_emission>
				<constant>
					<rgb>
						<rgb>180000 180000 180000</rgb>
						<gamma>2.200000047683716</gamma>
					</rgb>
				</constant>
			</base_emission>
			<emission>
				<constant>
					<rgb>
						<rgb>0.75 0.75 0.75</rgb>
						<gamma>2.200000047683716</gamma>
					</rgb>
				</constant>
			</emission>
			<random_triangle_colours>false</random_triangle_colours>
			<layer>0</layer>
		</diffuse>
	</material>

User avatar
Zom-B
1st Place 100
Posts: 4664
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Sphere light problem

Post by Zom-B » Fri Oct 12, 2018 3:05 pm

In GPU Mode model primitives aren't supported atm. your sphere gets exported as such one and therefor gets skipped. Use a polygon sphere instead :)
polygonmanufaktur.de

4u2ges
Posts: 13
Joined: Sat Jun 30, 2018 11:52 am

Re: Sphere light problem

Post by 4u2ges » Fri Oct 12, 2018 3:54 pm

Thanks, I'd be glad lol, but it's coming from iClone as a Spot Light and obviously not coming through. You said atm, is it going to be in upcoming releases (if you know)?

I got a few more problem (RT 4.2.20):

Specular nk shaders like gold, chrome.. rendered black under specific light conditions. Same scene with other tracer engine is rendering correctly.

I also have really huge problem with emitters, which I post later in this thread as my samples are still rendering...

4u2ges
Posts: 13
Joined: Sat Jun 30, 2018 11:52 am

Re: Sphere light problem

Post by 4u2ges » Fri Oct 12, 2018 4:37 pm

OK, here are 2 renders from half-finished scene. Settings are exactly the same. One is rendered with GPU support, another is not.
2 emitters from wall lamps and torchere produce a puny light with GPU rendering. I suspect it has something to do with small area of the emitting mesh. But without GPU support it does very well.

Also that torchere stand is shaded with gold nk. But it is coming out black. At least the bottom part, which is in the direct path of the light from bed lamp should be shining.


bedroom_Indigo_path_tracing.jpg
Path Tracing without GPU support



bedroom_Indigo_path_tracing_GPU.jpg
Path Tracing with GPU support

PS I have a packed .pigs file available for this scene is someone wants to test it.

Thanks!

User avatar
Zom-B
1st Place 100
Posts: 4664
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Sphere light problem

Post by Zom-B » Mon Oct 15, 2018 10:36 am

4u2ges wrote:
Fri Oct 12, 2018 3:54 pm
Thanks, I'd be glad lol, but it's coming from iClone as a Spot Light and obviously not coming through.
If you doblecheck the code you posted, you'll see that there is a sphere beeing used as emitter :!:
4u2ges wrote:
Fri Oct 12, 2018 3:54 pm
OK, here are 2 renders from half-finished scene. Settings are exactly the same. One is rendered with GPU support, another is not.
2 emitters from wall lamps and torchere produce a puny light with GPU rendering. I suspect it has something to do with small area of the emitting mesh. But without GPU support it does very well.
GPU rendering has a raydepth set to 8, raise that number and see if the light finally "reaches the scene". IF your lamps are modeled complex with glass and mirror reflectors this 8 rays could be not enough to exit the lamp at all. Keep it simple unless your realy need that details :)

If you still have issues feel free to PM me a link with the pigs
polygonmanufaktur.de

4u2ges
Posts: 13
Joined: Sat Jun 30, 2018 11:52 am

Re: Sphere light problem

Post by 4u2ges » Mon Oct 15, 2018 12:40 pm

Zom-B wrote:
Mon Oct 15, 2018 10:36 am
If you doblecheck the code you posted, you'll see that there is a sphere beeing used as emitter :!:
I know, that is the iClone Spotlight, which is not emitting by the reason you explained :)
For the time being I am substituting that with poly sphere. I was just hopping for support for primitives in the future, so I retain my convenience to use built-in iClone lights.
Zom-B wrote:
Mon Oct 15, 2018 10:36 am
GPU rendering has a raydepth set to 8, raise that number and see if the light finally "reaches the scene". IF your lamps are modeled complex with glass and mirror reflectors this 8 rays could be not enough to exit the lamp at all. Keep it simple unless your realy need that details :)

If you still have issues feel free to PM me a link with the pigs
Yes, I already tried that. And the mesh has nothing really fancy. I know what kills it now. I 'll send you PM with pigs link

User avatar
Zom-B
1st Place 100
Posts: 4664
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Sphere light problem

Post by Zom-B » Mon Oct 15, 2018 7:04 pm

Hey 4u2ges,

I checked the scene, here are a few tweaks to help in your scene:

1) Light strength
Is very unbalanced in your scene! The "Directional Light" material on the spot lighting the rights side of your room is so bright (but very far away) that it eats up close to all computation time of your GPUs!
Set the "Em. Sampling Mult" of it down to 0,00001, and you'll end up with better weighting.
Indigo has a simple but usually very functional algo to weight computation time over all the emitters in the scene:
The brighter the lightsource, the more important it is and the more it does contribute to the scene.
This does work well in most cases, but can be way off in some like yours too. You have a very bright emitter very far away. This emitter is by far so much stronger then all the other emitters in the scene, that Indigo dedicates close to all computation time to it, causing the other emitters to be so slow that they are super noisy...

The best way to avoid such traps is to work with LightLayers during scene creation. By that you can check every Emitter for itself and adjust for example the "Em. Sampling Mult" to boost its priority if its causing more noise then the other lightsources. For the final rendering you can put all emitters back to the same LightLayer....

2) Prevent Fireflies
Try to combine Clamp Contribution of 5 with some Super Sampling that can help eliminating FFs very well to as long as you don't work with untonemapped EXR output in your pipeline. The bigger your emitter meshes are the less noise they will cause since they'll get easier to find by the Path Tracing algo.

Your Floor has a Fresnel scale of ~0,062, by that you'll tune it way done killing about all reflectivity it had from the IOR of 2,0


Here a result after raising SuperSampling to 3, Clamping to 5 and adjusting the one emitter to lower multi, 2,24min on my 1080Ti:
bedroom_test.jpg

For denoising animations I highly suggest a temporal denoiser that compares multiple frames to each other and by that defines what is noise and what is scene detail, I use Neat Video for that.
polygonmanufaktur.de

4u2ges
Posts: 13
Joined: Sat Jun 30, 2018 11:52 am

Re: Sphere light problem

Post by 4u2ges » Tue Oct 16, 2018 2:08 am

Zom-B!

You don't know how much I appreciate your comment and lesson about the light priority, super-sampling and clamp! I would go though it again when I have a chance to get to my project. This would indeed benefit to everyone learning a technique illuminating a complex dark scenes. If I have more questions I'll post them here.

Thanks again!

Post Reply
8 posts • Page 1 of 1

Who is online

Users browsing this forum: Ahrefs [Bot] and 1 guest