Indigo Renderer 3.2.5

General News and accouncements regarding the Indigo render engine
User avatar
fused
Developer
Posts: 3479
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Indigo Renderer 3.2.5

Post by fused » Wed Dec 14, 2011 1:40 am

This is a Beta release.
If you spot any bugs or problems, please make a post about them in this thread.
Thanks!

Indigo for Windows 32-bit:
IndigoRenderer_3.2.5_Setup.exe

Indigo for Windows 64-bit:
IndigoRenderer_x64_3.2.5_Setup.exe

Indigo for Mac OSX (10.5 - 10.7):
IndigoRenderer3.2.5.dmg


Indigo RT for Windows 32-bit:
IndigoRT_3.2.5_Setup.exe

Indigo RT for Windows 64-bit:
IndigoRT_x64_3.2.5_Setup.exe

Indigo RT for Mac OSX (10.5 - 10.7):
IndigoRT3.2.5.dmg

Changelog:
3.2.5
* Alpha tracer now traces through partial null blends.
* Fixed darkening of the image when alpha or material id tracer are used with a generated aperture.
* Added reporting of CUDA and OpenCL driver version(s)
* Options dialog now warns when using "localhost" as the hostname for the Network Manager.
* When opening a material that has displacement, subdivision is added the the preview mesh.
* Fixed: When rendering with GPU acceleration and stopping, render times and SPS stats still keep updating.
* Fixed obstacle map loading for aperture diffraction.
* Fixed disappearing Render Settings widget.
* Greatly improved message handling overhead in realtime mode.
* Resolved minor GPU acceleration performance regression.

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Indigo Renderer 3.2.5

Post by Pibuz » Wed Dec 14, 2011 10:40 pm

I get the attached message.

It shows since 3.2.4 release.
3.2.3 works allright :)
Attachments
Senza titolo-1.jpg

User avatar
lycium
Developer
Posts: 1187
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Indigo Renderer 3.2.5

Post by lycium » Thu Dec 15, 2011 1:28 am

Hi Pibuz, I'm afraid you'll have to update your drivers again: http://www.nvidia.com/drivers

The 285.62 certified drivers from October work great :)

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Indigo Renderer 3.2.5

Post by Pibuz » Thu Dec 15, 2011 1:55 am

Hi Thom.
I was quite sure I had a quite updated drivers configuration, but you were right (as always): I had 276.14, and the current is 276.28 (I'm referring to nVidia QUADRO 4000 drivers).

Once updated, the error still appears.

User avatar
lycium
Developer
Posts: 1187
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Indigo Renderer 3.2.5

Post by lycium » Thu Dec 15, 2011 2:52 am

Interestingly the latest Quadro drivers don't support CUDA 4.1, even though they are of the correct version number and very recent etc.

Sorry for this inconvenience and thanks for reporting, we'll revert to 4.0 for now.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Indigo Renderer 3.2.5

Post by dougal2 » Sat Dec 17, 2011 3:41 am

BiDir + MLT is broken ?
I tried to render a simple test scene and it said 0 s/s despite using all cores.

EDIT: appears to be related to using an SSS material.

User avatar
lycium
Developer
Posts: 1187
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Indigo Renderer 3.2.5

Post by lycium » Sat Dec 17, 2011 5:05 am

SSS materials can induce a very high number of scatters, which makes the MLT warmup take a loooong time. There's also a case where it can become essentially stuck, this is known and will be fixed relatively soon (it's on our TODO towards the top!).

User avatar
Zom-B
1st Place 100
Posts: 4547
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.2.5

Post by Zom-B » Mon Dec 19, 2011 9:58 pm

If you trigger image overlay options during rendertime, the "Time elapse" counter resets to Zero...

There is a very ugly bug regarding EP and Glass material (rendertime varies!):

EP activated in BiDirPT:
test - EP on - PTBiDir.jpg
No EP in BiDirPT:
test - EP off - PTBiDir.jpg
EP activated in BiDirMLT:
test - EP on - MLTBiDir.jpg
No EP in BiDirMLT:
test - EP off - MLTBiDir.jpg
For me it looks liuke behind the glass you only see sky light but not direct Sunlight in PT mode, same as the Bug reported before GPU + EP.
Any thoughts here guys? I used the old Sky Model and no, Glass Acel. doesn't help here :(


** EDIT **
Attached Szenefile
EP Bug.pigs
(2.79 KiB) Downloaded 127 times
Last edited by Zom-B on Mon Dec 19, 2011 10:12 pm, edited 1 time in total.

User avatar
Zom-B
1st Place 100
Posts: 4547
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.2.5

Post by Zom-B » Mon Dec 19, 2011 10:09 pm

I also did a quick test with that scene using a EnvMap,

here you have a small shift ind the EnvMap, but no actual rendering issues:


EP active:
test - EP on - PTBiDir EnvMap.jpg
Ep off:
test - EP off - PTBiDir EnvMap.jpg

User avatar
dcm
Posts: 663
Joined: Sun Jan 03, 2010 1:55 am

Re: Indigo Renderer 3.2.5

Post by dcm » Mon Dec 19, 2011 10:19 pm

Arthur, you are great reminder. Thanks, i posted this few months back and i hope this will be fixed soon.

User avatar
OnoSendai
Developer
Posts: 6083
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo Renderer 3.2.5

Post by OnoSendai » Mon Dec 19, 2011 11:03 pm

Hi Zom-B,
Thanks for the report.
It's not actually a bug, just the same old slow-to-converge behaviour with some kind of paths.
I do have some plans to fix this.

User avatar
pixie
Indigo 100
Posts: 2057
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 3.2.5

Post by pixie » Mon Dec 19, 2011 11:17 pm

What's an EP?

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Indigo Renderer 3.2.5

Post by Pibuz » Mon Dec 19, 2011 11:26 pm

Exit Portal I guess.
Took me some time to figure it out too :D

User avatar
dcm
Posts: 663
Joined: Sun Jan 03, 2010 1:55 am

Re: Indigo Renderer 3.2.5

Post by dcm » Wed Dec 21, 2011 12:13 am

OnoSendai wrote:Hi Zom-B,
Thanks for the report.
It's not actually a bug, just the same old slow-to-converge behaviour with some kind of paths.
I do have some plans to fix this.
I found this "bug" at begninning of summer as far as i remember and i did some tests. One of them was rendertime. 48hours on 2 computers and sun wasnt visible behind the glass. Without EP, sun is visible immediately.

User avatar
Zom-B
1st Place 100
Posts: 4547
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 3.2.5

Post by Zom-B » Wed Dec 21, 2011 10:01 pm

It seems that GPU rendering has a general darker phong material then CPU based rendering:

CPU:
cpu.jpg
GPU:
gpu.jpg
Something that can be fixed?

Post Reply
43 posts

Who is online

Users browsing this forum: No registered users and 1 guest