Exporter for Max2009

Announcements, requests and support regarding the 3DS MAX exporter
User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Exporter for Max2009

Post by Pibuz » Mon Jan 12, 2009 10:08 pm

Hi Suvakas, sorry to bother you..
I'm trying to get a little closer to Maxigo, just to test a few things.
Now, i'm using 3dsMax2009. I tried to install the stable version of Maxigo present in the main download page, but i found some problems: the mat preview is not working, basically. I get a VERY FAST DOS message saying that it is impossible to run indigo console application (i tried to make a screenshot, but it didn't work..) or something. The mats work all, but i can't get the preview.

Then, i tried to render a scene with the famous greeble modifier applied to a simple object: the render didn't start because the object used a mat "wire" (...?) which i never applied..

I'm not a total noob of 3dMax, but i am of Maxigo: am i doing something wrong or doesn't your script work properly with the 2009 version?

thank you so much

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Post by suvakas » Mon Jan 12, 2009 11:35 pm

Hey,

A die hard SU user on Max? What's up? :P

Well, I'm still on Max v9 and I haven't tested Maxigo on newer versions myself. It should work though.

The material preview is a dirty hack. It may not work with the new Indigo versions cause the Mat_Prev folder is missing some required *.dll's.
Try to copy everything from Indigo root directory to your_indigo_dir\Exported_From_Max\Mat_Prev
Maybe it helps. I have to rewrite it, but I haven't had enough time so far.

About the "wire" thing. Did you assign an Indigo material to all your models? WireMat is a script generated material with a random number plus word "wire" for exporting models that have no material assigned. Maybe that's the case?

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Tue Jan 13, 2009 9:48 pm

suvakas wrote: A die hard SU user on Max? What's up? :P
Nothing :wink: , it's just that i wanted to test a more flexible hi-poly management, that's all!

Thanks for your answer Suvakas, pretty fast! :D
You know, the exporter runs fine, the only bug is just that mat preview..
suvakas wrote:The material preview is a dirty hack. It may not work with the new Indigo versions cause the Mat_Prev folder is missing some required *.dll's
You mean: it may not work with the new ...MAX versions? because i actually used both Indigo and Maxigo stable versions, and i actually tried them with Max8 and they did work fine..

Concerning the wire issue, my model only had a greebled box, which i applied a simple (but not previewed :wink: ) diffuse material with a wood texture in the albedo channel, and then i UVWmapped the object..

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Post by suvakas » Wed Jan 14, 2009 1:07 am

Pibuz wrote: You mean: it may not work with the new ...MAX versions? because i actually used both Indigo and Maxigo stable versions, and i actually tried them with Max8 and they did work fine..
I meant Indigo versions. New Indigo releases have some different support dll's that were not there in the past. The material preview copies the indigo_console.exe + some dll's into its own folder and starts the rendering from there. The script is outdated and does not know about the new dll's required for indigo_console to run. That's why it may not work cause those new dll's (+whatever new files it needs) are not copied over. Confusing?
... but if it works in Max 8 and not working in latest Max, then it's related to Max version too somehow. I will try to download a trial of Max 2009 at some point to check that out. I'm planning to rewrite it anyway.
Pibuz wrote: Concerning the wire issue, my model only had a greebled box, which i applied a simple (but not previewed :wink: ) diffuse material with a wood texture in the albedo channel, and then i UVWmapped the object..
Gotcha. Well in that case it may be a bug.

[edit]
You could also try the latest update from here and see if it makes any difference:
http://www.indigorenderer.com/joomla/fo ... php?t=4542

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Wed Jan 14, 2009 1:23 am

Sure i will! Thank you!

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Thu Jan 15, 2009 7:54 pm

Ok, Suvakas: bad news..
The 1.1.15 maxigo exporter doesn't work either: i don't even get the DOS message, when i launch the material preview.. :(
Now I'm gonna try to copy from the indigo root to exported_from_max folder: any specifics about the files to be copied, or do I have to just...COPY EVERYTHING?

Btw, I want you to know that there's absolutely no hurry: I'm writing you so frequently just because I recently had some spare time in the last nights, that is really weird and absolutely unpredictable :wink: So, take your time man. And thank you so much!

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Post by suvakas » Thu Jan 15, 2009 9:02 pm

Hey,
Well, if there is no dos message, then things are bad. There should be at least a dos window pop-up.
Don't copy the files to exported_from_max root, but into exported_from_max/Mat_prev cause that's from where the material previews are launched.
Also I think there was a log file bug in version 1.1.15 of Indigo. Material preview reads the log file too so if there is no content in log file, then mat. preview is also not working.

[edit]
What files to copy? Well..i'm not sure about that. Copy everything that is not *.exe and *.pdf. They are all relatively small, so no harm will be done even if you copy everything :wink:

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Fri Jan 16, 2009 8:48 pm

Thank you: gonna try!

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Sun Jan 18, 2009 10:44 am

I downloaded 3ds max 2009 also. felt like trying it out. ill try it out when im done figuring things out.
benn hired a mercenary to kill my sig...

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Sat Jan 31, 2009 11:49 pm

So, Suvakas: any news?

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Post by suvakas » Sun Feb 01, 2009 12:44 am

I'm currently doing a total re-write of Maxigo. From ground up. It will export to Indigo binary format only and will use dot net for better integration. So expect no updates for current Maxigo versions. It will be a brand new exporter when i'm done.

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Sun Feb 01, 2009 4:16 am

Sounds exciting :)
benn hired a mercenary to kill my sig...

User avatar
Kosmokrator
Posts: 1141
Joined: Sat Jul 29, 2006 11:52 am
Location: Greece-Athens

Post by Kosmokrator » Sun Feb 01, 2009 4:22 am

:) oohhh good news suv!!
im all most got-off the indigo becouse of no exporter update since long time......

thnx in advance....
1)Core i7 965XE stock CLOCK ,PSU:CHIEFTEC 850W
M/B ASUS P6T DELUXE,WATERCOOLING ZALMAN RESERATOR 2
MEMORY:6GB CORRSAIR @1600,Ati HD 4870x2,
MONITOR:LG 1950SQ,CASE:THERMALTAKE SOPRANO

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Post by Pibuz » Sun Feb 01, 2009 1:15 pm

suvakas wrote:I'm currently doing a total re-write of Maxigo. From ground up. It will export to Indigo binary format only and will use dot net for better integration. So expect no updates for current Maxigo versions. It will be a brand new exporter when i'm done.
OH MY GOD! That IS a great work!
Thank you suv! So much!
I really think next time I'd better bite my tongue.. :oops:

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Sun Feb 01, 2009 1:28 pm

Great, it's official now ;)

Congrats suv !
obsolete asset

Post Reply
20 posts

Who is online

Users browsing this forum: Google [Bot] and 2 guests