IndigoMax 0.50 error message

Announcements, requests and support regarding the 3DS MAX exporter
Post Reply
3 posts • Page 1 of 1
tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

IndigoMax 0.50 error message

Post by tar_gniK » Mon Apr 24, 2017 5:41 am

Rendering a glass material with IndigoMax 0.50.

If one renders inside the Max frame buffer, no problems.

However, if one decides to export the scene instead to Indigo standalone (which I prefer), the following message appears:

Code: Select all

Scene parsing error: Node with UID 8 was not a medium node.
I have tried all the different settings for a glass material; switching to single face, arch glass, changing the precedence - nothing seems to work.

Strangely, applying a glass material the first time to an object, and then rendering - it works. But if you stop the render, and then try again, then the above error message comes up. Looking at the .igs file, the first instance when it works, the following appears (which is correct):

Code: Select all

<material>
		<uid>7</uid>
		<name>Material #27</name>
		<specular>
			<internal_medium_uid>8</internal_medium_uid>
			<transparent>true</transparent>
			<arch_glass>false</arch_glass>
			<single_face>false</single_face>
		</specular>
	</material>

	<medium>
		<uid>8</uid>
		<name>Material #27_Medium</name>
			<precedence>5</precedence>
			<basic>
				<ior>1.5</ior>
				<cauchy_b_coeff>0</cauchy_b_coeff>
				<max_extinction_coeff>1</max_extinction_coeff>
				<absorption_coefficient>
					<constant>
						<rgb>
							<rgb>0 0 0</rgb>
							<gamma>1</gamma>
						</rgb>
					</constant>
				</absorption_coefficient>
			</basic>
	</medium>
But then stopping the render, and then trying again, the igs file is incomplete:

Code: Select all

<material>
		<uid>7</uid>
		<name>Material #27</name>
		<specular>
			<internal_medium_uid>8</internal_medium_uid>
			<transparent>true</transparent>
			<arch_glass>false</arch_glass>
			<single_face>false</single_face>
		</specular>
	</material>
So something is not right in the way IndigoMax is exporting the materials. It seems to be stripping away the data referring to the internal medium. Constantly modifying the .igs file manually, is just too time-consuming with a complex scene. Will this be fixed? Can this be fixed?

Pretty miffed also (as a paid user of Indigo) that four emails explaining this problem to support@indigorenderer.com, have not been answered. As a Max user, is it worth actually my valuable time supporting a renderer of which the Max exporter always has been sub-par?

User avatar
OnoSendai
Developer
Posts: 6174
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: IndigoMax 0.50 error message

Post by OnoSendai » Mon Apr 24, 2017 7:38 am

Sorry, will take a look at this problem tonight.

User avatar
OnoSendai
Developer
Posts: 6174
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: IndigoMax 0.50 error message

Post by OnoSendai » Mon Apr 24, 2017 1:56 pm


Post Reply
3 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest