Blendigo 2.4.x Releases

Announcements, requests and support regarding the Blender Indigo export script
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Blendigo 2.4.x Releases

Post by dougal2 » Tue May 25, 2010 5:21 am

UPDATED TO 2.4.3

KNOWN ISSUES

- No OSX installer still :(

- Not 100% backwards-compatible with scenes set up with previous versions of Blendigo (2.2 stable); especially with regards to material settings. This won't be fixed, you'll need to migrate your old scenes to the new Blendigo if you wish to re-render them with Indigo.

WARNING
Although reasonably well tested, this release may still contain bugs.

DOWNLOADS

WINDOWS: [See 2.4.5]

LINUX: http://www.indigorenderer.com/dist/expo ... 4.3.tar.gz

OSX: [See 2.4.4]

Fixed in this release:

* Dropped matdb integration on win64 due to missing required libraries
* Added basic support for GROUP type particle visualization. NOTE, that only particles that are displayed can be exported at the current time due to limitations in blender. eg. 10,000 particles with Disp=1 results in 100 particles being exported.

YOUR FEEDBACK IS ALWAYS APPRECIATED

As with the current efforts to get Indigo 2.4 as complete and user-friendly as possible, please please keep reporting any issues you find with Blendigo - it is your feedback as users and artists alone that push Blendigo forward into being the software that works for you.

User avatar
dakiru
Indigo 100
Posts: 746
Joined: Mon Jun 22, 2009 6:51 am

Re: Blendigo 2.4.x Releases

Post by dakiru » Tue May 25, 2010 5:51 am

dougal2 wrote: * Dropped matdb integration on win64 due to missing required libraries
* Added basic support for GROUP type particle visualization. NOTE, that only particles that are displayed can be exported at the current time due to limitations in blender. eg. 10,000 particles with Disp=1 results in 100 particles being exported.
Great stuff, thanks!
I see no annoying warning :)

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Fri Jun 04, 2010 4:17 am

UPDATED TO 2.4.4

This release contains changes only applicable to OSX.

I've changed the installer to not care about where Indigo is installed; This should make the installer more reliable.
Under the System tab, you should set the path to Indigo.app in order to launch rendering from Blendigo. Note that in blender, Indigo.app appears as a directory, you should take care to select the directory and not any files. The selection should look something like: [ /Applications/Indigo.app ]

DOWNLOADS

OSX: http://www.indigorenderer.com/dist/expo ... -2.4.4.zip

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo 2.4.x Releases

Post by FakeShamus » Fri Jun 04, 2010 4:51 am

awesome, thanks for the mac version.
can't wait to try it out.

User avatar
Godzilla
Indigo 100
Posts: 985
Joined: Sat Jun 06, 2009 11:33 am

Re: Blendigo 2.4.x Releases

Post by Godzilla » Fri Jun 04, 2010 6:36 am

dougal2 wrote: only particles that are displayed can be exported at the current time due to limitations in blender. eg. 10,000 particles with Disp=1 results in 100 particles being exported.
:(

Well, I suppose there is always the bounding box draw-type available...
dakiru wrote:
Great stuff, thanks!
I see no annoying warning :)

:o Thanks dougal!


Edit-

First bug i've noticed is that when you un-click the 'autofocus' box, the script crashes... :(
samlavoie.xyz

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo 2.4.x Releases

Post by FakeShamus » Fri Jun 04, 2010 1:00 pm

ok, so I'm getting this when I try to launch this new Blendigo and it says check console:

in readWriteSettingsreadWriteValue(d, 'aperture_pproc', IndigoUiControls.Camera.AperturePProc, write, 0)
AttributeError: class Camera has no attribute 'AperturePProc'

am I missing some requirement, or is this a bug?
Blender 2.49, Python 2.6 (I believe), OSX 10.6.3

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Thu Jun 10, 2010 11:24 pm

FakeShamus wrote:ok, so I'm getting this when I try to launch this new Blendigo and it says check console:

in readWriteSettingsreadWriteValue(d, 'aperture_pproc', IndigoUiControls.Camera.AperturePProc, write, 0)
AttributeError: class Camera has no attribute 'AperturePProc'

am I missing some requirement, or is this a bug?
Blender 2.49, Python 2.6 (I believe), OSX 10.6.3
Does this happen all the time, or just when you open specific files ?

This might also be a failed installation. If the problem persists, you should search your hard disk for blendigo* and remove all copies, and then re-install.

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo 2.4.x Releases

Post by FakeShamus » Fri Jun 11, 2010 5:01 am

it happens every time. I've dumped the blendigo files and reinstalled several times and no success.
it's definitely finding the new installation, but it doesn't seem to be importing the additional linked stuff from the blendigopkg. everything seems to be in the right place - but I don't know enough about python to tell why it's not finding what it needs.

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Blendigo 2.4.x Releases

Post by aleksandera » Mon Jun 14, 2010 6:00 am

Curious about motion blur.
I have tried to make a follow path animation,
doesn't work - no motion blur.
How was this done:
http://www.indigorenderer.com/forum/vie ... 9&start=60

Thx!

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Blendigo 2.4.x Releases

Post by aleksandera » Mon Jun 14, 2010 1:24 pm

O, and BTW, does this work for instance export:
http://www.blendercookie.com/2009/02/18 ... d-objects/
No success here :oops:

Thx for any help,
Aleksander

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Blendigo 2.4.x Releases

Post by aleksandera » Tue Jun 15, 2010 1:41 am

Blending with external materials doesn't work.
Anybody here?

StompinTom
Indigo 100
Posts: 1821
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.4.x Releases

Post by StompinTom » Tue Jun 15, 2010 1:55 am

aleksandera wrote:O, and BTW, does this work for instance export:
http://www.blendercookie.com/2009/02/18 ... d-objects/
No success here :oops:

Thx for any help,
Aleksander
Instancing a Group doesn't work, something to do with Blender, not Blendigo.

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Blendigo 2.4.x Releases

Post by aleksandera » Tue Jun 15, 2010 2:59 am

Well I tried all the same, but without groups.
Doesn't work ider :(

User avatar
_cheers_
Posts: 15
Joined: Tue Apr 14, 2009 10:03 am
Location: French France

Re: Blendigo 2.4.x Releases

Post by _cheers_ » Tue Jun 15, 2010 9:52 pm

The world scale doesn't work when i try to focus on the object after a conversion. Example: if i adjust from 1x10^0 to 1x10^-1 or 2 or +2, the focus distance stays on 10m instead of 1m for 10^-1.

blender 2.49
blendigo 2.4.3

StompinTom
Indigo 100
Posts: 1821
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.4.x Releases

Post by StompinTom » Wed Jun 23, 2010 10:27 am

Camera animation would be a God-send. Exporting a 250-frame animation of a simple greebled plane takes up 3.4Gb of harddisk space and over an hour of export time. If all that was exported was the Camera and possibly the Sun vector, while referencing the same geometry file, this could permit animations of very complex scenes!

Post Reply
76 posts

Who is online

Users browsing this forum: No registered users and 3 guests