Blendigo 3.6.17.0

Announcements, requests and support regarding the Blender Indigo export script
User avatar
OnoSendai
Developer
Posts: 6184
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Blendigo 3.6.17.0

Post by OnoSendai » Fri Jul 05, 2013 10:07 pm

Archive: http://downloads.indigorenderer.com/dis ... 6.17.0.zip

Windows Installer: http://downloads.indigorenderer.com/dis ... taller.exe

Changelog:

3.6.17.0
--------
* Showing an error message if Indigo executable is not found when exporting and rendering.
* Added shadow catcher option for diffuse material.
* Added support for invisible_to_camera object attribute.
* Added sharing of meshes for animation export.
* Fixed skip_existing_meshes
* Fixed bug: Material name is not detected correctly for external material sometimes.


Bug reports and comments welcome!

pupox
Posts: 3
Joined: Sat Jul 06, 2013 8:00 am

Re: Blendigo 3.6.17.0

Post by pupox » Sat Jul 06, 2013 8:07 am

Hi, I just tried this Blendigo release, it works fine on blender but when I export and start to render the scene indigo show this message: \Users\ppx\AppData\Local\Temp\untitled/Scene/Cube_4618cbf0bc13316135d676fffe0a74fc9b0577909246477354da9254.igmesh': Unsupported format version. (In element 'mesh', around line 111, column 5)

User avatar
OnoSendai
Developer
Posts: 6184
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Blendigo 3.6.17.0

Post by OnoSendai » Sat Jul 06, 2013 8:09 am

pupox wrote:Hi, I just tried this Blendigo release, it works fine on blender but when I export and start to render the scene indigo show this message: \Users\ppx\AppData\Local\Temp\untitled/Scene/Cube_4618cbf0bc13316135d676fffe0a74fc9b0577909246477354da9254.igmesh': Unsupported format version. (In element 'mesh', around line 111, column 5)
Hi Pupox,
Try installing the latest Indigo: http://www.indigorenderer.com/forum/vie ... =1&t=12471

pupox
Posts: 3
Joined: Sat Jul 06, 2013 8:00 am

Re: Blendigo 3.6.17.0

Post by pupox » Sat Jul 06, 2013 8:20 am

OnoSendai wrote:
pupox wrote:Hi, I just tried this Blendigo release, it works fine on blender but when I export and start to render the scene indigo show this message: \Users\ppx\AppData\Local\Temp\untitled/Scene/Cube_4618cbf0bc13316135d676fffe0a74fc9b0577909246477354da9254.igmesh': Unsupported format version. (In element 'mesh', around line 111, column 5)
Hi Pupox,
Try installing the latest Indigo: http://www.indigorenderer.com/forum/vie ... =1&t=12471
I think indigo is running well, indeed it works fine with the sketchup pluging. BTW my blender version is 2.67b, may be the way of exporting the meshes from this blender is diferent or something like that, could be any configuration to change that?

User avatar
Oscar J
1st Place Winner
Posts: 2180
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Blendigo 3.6.17.0

Post by Oscar J » Thu Jul 11, 2013 8:26 am

Will normal maps be included in the next release?

Thanks

Benzamen Vox
Posts: 29
Joined: Fri Jul 12, 2013 5:15 am
Location: Borin o'l nebraska

Re: Blendigo 3.6.17.0

Post by Benzamen Vox » Sat Jul 13, 2013 4:08 am

About blendigo, i am having trouble applying the materials in blender indigo
I just need a quick overview of materials in blender before rendering it in indigo

User avatar
Headroom
Indigo 100
Posts: 991
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo 3.6.17.0

Post by Headroom » Sat Jul 13, 2013 5:18 am

@Benzamen Vox
Please be more specific about what problems you have.
iMac 2.93 GHz Quad Core i7. 12 GB memory
ATI Radeon HD 5750M 1024 MB
OS X 10.10.3 Yosemite
Blender 2.72, Blendigo 3.8.25, Indigo 3.8.26

Trippy Lighting LLC - Colorful LED lighting systems
High Power RGB LED driver - Blog

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Blendigo 3.6.17.0

Post by CTZn » Sat Jul 13, 2013 10:23 am

The shadow catcher may not be working with the old XML scene description... invisible to camera is.
obsolete asset

User avatar
Headroom
Indigo 100
Posts: 991
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo 3.6.17.0

Post by Headroom » Fri Jul 19, 2013 2:43 pm

Ono,

When posting a new version of Blendigo, could you guys please make sure to also mention what version of Blender needs to go along with it ?

It is often a confusing thing for people new to Indigo and the Forum to figure out what version of Indigo goes with what version of Blendigo and what Blender version is required. This frequently is a source of error messages and frustration for new users.

pupox
Posts: 3
Joined: Sat Jul 06, 2013 8:00 am

Re: Blendigo 3.6.17.0

Post by pupox » Sat Jul 20, 2013 6:25 am

There's any way to say to the exporter that generate a standalone .igi and not a .igi that includes all the .imesh?

User avatar
Oscar J
1st Place Winner
Posts: 2180
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Blendigo 3.6.17.0

Post by Oscar J » Wed Jul 31, 2013 2:25 am

I can't get the depth of field option to work properly - are we limited to autofocus?

Nevermind, solved it. :oops:

User avatar
Oscar J
1st Place Winner
Posts: 2180
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Blendigo 3.6.17.0

Post by Oscar J » Wed Aug 14, 2013 7:20 am

When you select camera tonemapping in Blendigo, it sets and exports a film ISO value of 100 (and it's not possible to change until rendering in Indigo). But when you select camera tonemapping indigo, the ISO is set by default to 200. Please make Blendigo set the ISO to 200 instead of 100 upon changing to camera tonemapping, for more consistency and simplicity.

Thanks!

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo 3.6.17.0

Post by FakeShamus » Thu Aug 15, 2013 3:04 am

don't know if this was mentioned before, but when using orthographic cameras the viewport from Blender does not translate accurately to the render view in Indigo. Blender's "orthographic scale" value is exported correctly, but the numbers must translate differently from Blender to Indigo.

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo 3.6.17.0

Post by FakeShamus » Tue Sep 17, 2013 4:42 am

so, this is plain old user error, but I accidentally set up a blend material in blendigo using itself as the B material. when I tried to export my scene the .igs file came up completely empty, with the error message from Blender mentioning something about exceeding the recursive limit of the python script, but lacking a clear explanation. this baffled me for several hours until I finally realized the mistake, after much wasted time.

is there a way to check for these kind of "loops" in blend materials before export, or at least give a coherent error message about it?

thanks!

User avatar
ENSLAVER
Posts: 399
Joined: Tue Feb 20, 2007 1:49 am

Re: Blendigo 3.6.17.0

Post by ENSLAVER » Fri Sep 20, 2013 3:55 pm

Hi, not sure if this is because I am a Blender noob or if it's a recent change to Indigo that hasn't been picked up.

Rendering with an environment (given I am doing it the right way via Hemi Lamp) ends up rendering relatively black in Indigo because there is no "measure" set.

It's not absolutely black but such an extremely low value it's only visible via Reinhard colour mapping, or by setting the camera values to 20/10000 (max). Some bright HDR images may render correctly without setting measure but 99% of mine are black.

Just makes it hard to render an animation via Blender :)


Edit: This would probably be solved for all exporters (maxigo has the same issue) if luminance was selected by default in Indigo. Also effects backgrounds set as colours rather than HDR images.
Attachments
indigo_measure.jpg

Post Reply
38 posts

Who is online

Users browsing this forum: No registered users and 1 guest