Blendigo (for Blender 2.5x) 3.0.10

Announcements, requests and support regarding the Blender Indigo export script
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Blendigo (for Blender 2.5x) 3.0.10

Post by dougal2 » Sat Jun 11, 2011 1:26 am

3.0.10

Now updated to 3.0.10.1 - see here: http://www.indigorenderer.com/forum/vie ... =8&t=10927

INSTALLATION

Unzip the archive. Move the indigo folder from blendigo-2.5-3.0.10/sources into your Blender addons folder.
You should end up with <blender scripts>/addons/indigo/

Run Blender 2.5, go into User Preferences/Addons, and find the Render section. Locate the Blendigo entry
and enable the addon by clicking the little checkbox on the right.

Save your User Settings now to make Blendigo activate every time you start Blender 2.5.

Non-windows users will have to also fill in the "Path to Indigo" setting in the "Indigo Render Engine Settings"
panel. (Windows does this automatically from the information provided by the installer). Note that you should
specify the actual Indigo binary file for this setting.

YOUR FEEDBACK IS ALWAYS APPRECIATED

As with the current efforts to get Indigo 3.0 as complete and user-friendly as possible,
please please keep reporting any issues you find with Blendigo - it is your feedback as
users and artists alone that push Blendigo forward into being the software that works for you.

Please note that I fully expect some teething problems with this initial release. The more detailed
the feedback you can give us now, the quicker we can get these issues resolved.

Specifically, this exporter has not yet had extensive testing on Linux or OSX.

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by StompinTom » Sat Jun 11, 2011 1:34 am

Can't help you with Linux or OSX, but I'll give it a whirl on Windows in the next bit.

Thanks!

Any updates for 2.5 on the way?

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by dougal2 » Sat Jun 11, 2011 1:38 am

StompinTom wrote:Any updates for 2.5 on the way?
I think 2.58 is due later this month, but I'm not sure. TBH, now that Blender is stable, I'm not following the development quite as closely as before - and that gives me more time to focus on Blendigo features ;)

PS. I added region rendering support in this release :)

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by StompinTom » Sat Jun 11, 2011 2:17 am

dougal2 wrote:
StompinTom wrote:Any updates for 2.5 on the way?
I think 2.58 is due later this month, but I'm not sure. TBH, now that Blender is stable, I'm not following the development quite as closely as before - and that gives me more time to focus on Blendigo features ;)

PS. I added region rendering support in this release :)
Sweet! I meant Blendigo 2.5 :) I'm using 2.57 and it works great, for the most part, so I'm not really concerned with 2.58 just yet! I'm just finishing up a larger project where I really got to put Blendigo through the grinder.

WHOOPS. I thought this was still the 2.4x thread. My bad.

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Silmä » Sat Jun 11, 2011 8:57 am

What button you are supposed to hit to actually launch Indigo? The "render"-button simply opens the Blender render window and does nothing.

I do have all indigo bells and whistles in Blender UI, the "path to Indigo" is correct, I have "autostart" checked, and there is no error message anywhere (and Blender doesn't open the console anymore, so no help from there, either).

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by StompinTom » Sat Jun 11, 2011 9:06 am

Silmä wrote:What button you are supposed to hit to actually launch Indigo? The "render"-button simply opens the Blender render window and does nothing.

I do have all indigo bells and whistles in Blender UI, the "path to Indigo" is correct, I have "autostart" checked, and there is no error message anywhere (and Blender doesn't open the console anymore, so no help from there, either).
You can enable the console in Blender: Help -> Toggle System Console. Check to see what errors show up there.

I haven't tried this one yet, so I don't know if it's been fixed, but make sure all your objects have a material, or else it may not want to export.

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Silmä » Sat Jun 11, 2011 9:13 am

Thanks for the tip.

The console just says "INFO: export finished; took 0.017000 seconds" (yes, the test scene is that simple). No errors anywhere.

And all my objects have materials.

edit: Now it's working. It was the indigo location after all: the file browser had made relative path to Indigo, and it didn't work until I typed it again myself (guess I messed it up before finding the auto start setting).
Last edited by Silmä on Sat Jun 11, 2011 9:36 am, edited 1 time in total.

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Silmä » Sat Jun 11, 2011 9:30 am

Btw, isn't the "Display int" -setting obsolete since don't remember how long ago?

User avatar
Doug Armand
Indigo 100
Posts: 1037
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Doug Armand » Sat Jun 11, 2011 6:31 pm

Silmä wrote:What button you are supposed to hit to actually launch Indigo? The "render"-button simply opens the Blender render window and does nothing.

I do have all indigo bells and whistles in Blender UI, the "path to Indigo" is correct, I have "autostart" checked, and there is no error message anywhere (and Blender doesn't open the console anymore, so no help from there, either).

same issue here - my setup is correct I think but pressing the 'Image' button bring up a black window - not Indigo- and does nothing
Doug

Doug Armand

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Silmä » Sat Jun 11, 2011 6:55 pm

Phong material settings are not working properly. The "exponent" value doesn't have any effect unless you check "Specular reflectivity", so basically you can't have any meaningful materials right now...

Another bug I found was that if you have launched Indigo with Blendigo, indigo saves output images to blender output folder (which is nice and dandy), but it also overwrites old images of same scene with new ones, which is not something you would necessarily want (at least I like to look at the Indigo output folder and see progress I've made during a project). This goes as far as saving pictures from other scenes opened during same session of Indigo with same name (which could cause disaster if it's so also when using the new "render queue" feature).

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Silmä » Sat Jun 11, 2011 6:57 pm

Doug Armand wrote:
Silmä wrote:What button you are supposed to hit to actually launch Indigo? The "render"-button simply opens the Blender render window and does nothing.

I do have all indigo bells and whistles in Blender UI, the "path to Indigo" is correct, I have "autostart" checked, and there is no error message anywhere (and Blender doesn't open the console anymore, so no help from there, either).

same issue here - my setup is correct I think but pressing the 'Image' button bring up a black window - not Indigo- and does nothing
Did you double check the "Indigo path", and type it in manually? The Blender file browser seems to like relative, not absolute files paths, and those won't work well with blendigo.

portgas
Posts: 6
Joined: Sat Jun 11, 2011 10:51 pm

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by portgas » Sat Jun 11, 2011 10:53 pm

doesn't seems to be working for me...installed it, user prefs and all. But in scene settings in blender there is no "export" button, and if i try render image it gives me black picture. Also, if i try export indigo scene it gives me a lot of error messages...

User avatar
Doug Armand
Indigo 100
Posts: 1037
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Doug Armand » Sat Jun 11, 2011 11:40 pm

Silmä wrote:
Doug Armand wrote:
Silmä wrote:What button you are supposed to hit to actually launch Indigo? The "render"-button simply opens the Blender render window and does nothing.

I do have all indigo bells and whistles in Blender UI, the "path to Indigo" is correct, I have "autostart" checked, and there is no error message anywhere (and Blender doesn't open the console anymore, so no help from there, either).

same issue here - my setup is correct I think but pressing the 'Image' button bring up a black window - not Indigo- and does nothing
Did you double check the "Indigo path", and type it in manually? The Blender file browser seems to like relative, not absolute files paths, and those won't work well with blendigo.
Good idea - OK I just tried that but still nothing. Would help if we got a simple 'how-to' with pretty pictures please? :D
Doug

Doug Armand

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by dougal2 » Sat Jun 11, 2011 11:40 pm

portgas wrote:doesn't seems to be working for me...installed it, user prefs and all. But in scene settings in blender there is no "export" button, and if i try render image it gives me black picture. Also, if i try export indigo scene it gives me a lot of error messages...
It would be nice to know what those error messages are. Thanks :)

User avatar
Headroom
Indigo 100
Posts: 989
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo (for Blender 2.5x) 3.0.10

Post by Headroom » Sun Jun 12, 2011 12:26 am

Phong materials work here on my iMac (at least for the simple scene I made). GPU works as well. Nice!
iMac 2.93 GHz Quad Core i7. 12 GB memory
ATI Radeon HD 5750M 1024 MB
OS X 10.10.3 Yosemite
Blender 2.72, Blendigo 3.8.25, Indigo 3.8.26

Trippy Lighting LLC - Colorful LED lighting systems
High Power RGB LED driver - Blog

Post Reply
87 posts

Who is online

Users browsing this forum: No registered users and 1 guest