Resume render from IGI : invalid image_data_size

Feature requests, bug reports and related discussion
SzLaszlo
Posts: 123
Joined: Sun Aug 03, 2008 1:04 am
Location: Budapest / Hungary

Resume render from IGI : invalid image_data_size

Post by SzLaszlo » Wed Sep 23, 2009 9:25 pm

Hi ,

I try open igi file ( Resume render from IGI ) , but don't work ( IGI > ~ 2 , 2.5 Gb. ) .
Smaller igi file size is work , is igi file size limit ?

Error :

"
IndigoDriverExcep: Error while trying to resume with image buffer '/../../Indigo1.1.18/renders/im1253679876.igi': Invalid Image File: invalid image_data_size
"

( ubuntu linux 64bit )

László

User avatar
psor
1st Place Winner
Posts: 1295
Joined: Sun Jun 25, 2006 1:25 am
Location: Berlin
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by psor » Thu Sep 24, 2009 12:11 pm

I'm just wondering cause nobody is posting here. :roll:

Are you trying to resume a .igi file from Indigo 1.1.18 with Indigo 2.x ?
If so, I would take an educated guess, that it's impossible to do so. ;)




take care
psor
"The sleeper must awaken"

SzLaszlo
Posts: 123
Joined: Sun Aug 03, 2008 1:04 am
Location: Budapest / Hungary

Re: Resume render from IGI : invalid image_data_size

Post by SzLaszlo » Sat Sep 26, 2009 12:25 am

psor wrote:I'm just wondering cause nobody is posting here. :roll:

Are you trying to resume a .igi file from Indigo 1.1.18 with Indigo 2.x ?
If so, I would take an educated guess, that it's impossible to do so. ;)




take care
psor
Hi ,

I don't try 2.x ( 0.7 MPixel limit )

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Resume render from IGI : invalid image_data_size

Post by CTZn » Sat Sep 26, 2009 12:59 am

Try editing the igs <width> and <height> tags so they match the actual igi resolution.
obsolete asset

User avatar
psor
1st Place Winner
Posts: 1295
Joined: Sun Jun 25, 2006 1:25 am
Location: Berlin
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by psor » Sat Sep 26, 2009 1:01 am

That's what I thought too, but I'm wondering how to find out the resolution of the .igi file? :roll:




take care
psor
"The sleeper must awaken"

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Resume render from IGI : invalid image_data_size

Post by CTZn » Sat Sep 26, 2009 1:04 am

hmm, apart from your neurons I can't tell :lol:

Perhaps violet could tell if using older igi format.
obsolete asset

User avatar
psor
1st Place Winner
Posts: 1295
Joined: Sun Jun 25, 2006 1:25 am
Location: Berlin
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by psor » Sat Sep 26, 2009 1:07 am

You see, now everything comes together ... :lol: :lol: :wink:



take care
psor
"The sleeper must awaken"

FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Resume render from IGI : invalid image_data_size

Post by FakeShamus » Wed Aug 04, 2010 11:12 pm

I am getting the same message trying to resume from an .igi that is about 2.5 GB. I'm using Indigo 2.2.12 and trying to resume using IndigoConsole from command line.
is there a limit to the .igi file size for resuming? everything being 64 bit, I would find that unlikely (unfortunate). this is on my Mac Pro, OSX 10.6

User avatar
lycium
Developer
Posts: 1199
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by lycium » Thu Aug 05, 2010 12:27 pm

This was fixed in a 2.4.x release, now extremely large IGI files are supported.

FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Resume render from IGI : invalid image_data_size

Post by FakeShamus » Thu Aug 05, 2010 1:38 pm

ah, that works - switched to 2.4.4 and it resumes now. but it seems to run way slower than 2.2.12 on this scene, I'm wondering if this is a known issue? I thought some things were changed in regards to sampling to speed things up in the newer versions, but I'm not seeing it here. this scene happens to have lots and lots of instancing, could something have changed in the efficiency of rendering large scenes like this?

User avatar
lycium
Developer
Posts: 1199
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by lycium » Thu Aug 05, 2010 1:55 pm

Ah, that issue again :?

We haven't been able to pin down exactly what's causing this issue, if you could provide us with a scene exhibiting this behaviour I'd greatly appreciate it! If possible please mail the scene to thomas@indigorenderer.com :)

FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Resume render from IGI : invalid image_data_size

Post by FakeShamus » Fri Aug 06, 2010 1:25 am

I don't think I can mail it cause the scene is quite massive, but let me see if I can isolate it in a simpler situation. in the tests I've made 2.4.4 is getting only about 30% the spp of 2.2.12

cholme
Posts: 16
Joined: Fri Mar 19, 2010 1:05 pm

Re: Resume render from IGI : invalid image_data_size

Post by cholme » Fri Aug 13, 2010 11:25 am

Mine was working fine with 2.2 but when I upgraded to 2.4.4, I get the following message:
A problem occurred with the scene:
Resuming buffer width does not match: 1028 vs 1284
Indigo version: Indigo Renderer v2.4.4, OS X 64-bit

How I got there was:
1. Create a file and render
2. Stop the render
3. Save the IGI file
4. Save the IGS file
5. Exit renderer
6. Open and try to resume from IGI - Error.

Any ideas?

User avatar
lycium
Developer
Posts: 1199
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: Resume render from IGI : invalid image_data_size

Post by lycium » Fri Aug 13, 2010 1:00 pm

The IGI format was updated when support for very large images was implemented, so the 2.2 IGI won't work - you'll have to restart the render with a newer version of Indigo.

User avatar
mily
Posts: 27
Joined: Sat Jan 30, 2010 7:27 am
Location: Warsaw, Poland

Re: Resume render from IGI : invalid image_data_size

Post by mily » Fri Aug 13, 2010 6:13 pm

lycium wrote:The IGI format was updated when support for very large images was implemented, so the 2.2 IGI won't work - you'll have to restart the render with a newer version of Indigo.
Ok, I've managed to resume the renderings in 2.4.4. :D

Please consider this bug in next releases. My scene is still available to download in the mail I've sent you, Lycium.

Post Reply
18 posts

Who is online

Users browsing this forum: Majestic-12 [Bot] and 2 guests