Foscarini lamp material

General discussion about Indigo Materials - material requests, material developement, feedback, etc..
User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Foscarini lamp material

Post by Pibuz » Sun Dec 10, 2017 6:50 am

Hi guys!

Today I'm here asking a question about materials: I'm trying to reproduce the attached material, which is often used in Foscarini Lamps such as the "Parentesi" and the "Luminator", both by Castiglioni.

I set up a blend mat with the attached map. The black part takes a simple metallic material; the white part is linked to an emissive material.

BTW, when I try to render, the result is somewhat uncontrollable, and waaay distant from the result I'd like!
Can you help me out?

Thanks a lot!!
Attachments
foscarini lamp render bleah.jpg
render puah
foscarini lamp sketchup set-up.jpg
scketchup
BLENDMAP2.jpg
the blendmap I prepared
lamp.jpeg
reference

User avatar
Oscar J
1st Place Winner
Posts: 2148
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Foscarini lamp material

Post by Oscar J » Sun Dec 10, 2017 8:09 am

Seems to work fine here, I did it exactly the way you described it with your map. Maybe your emission is way to strong? Also, make sure that the gradient only happens around the middle of the bulb, and that the bottom has 100% black texture values. Check that you're using the right UV channel maybe? :)
Attachments
test.jpg

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Sun Dec 10, 2017 11:53 pm

...I don't know.... what exporter are you using?

I thought about having the light too strong too, but I have the same results with a very low emitter...

I get a somewhat different result unchecking the "clamp contributions" option (which from SkIndigo is exported set to 10 by default, even if UNCHECKED in the setting panel, I think it's a small bug..).

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Foscarini lamp material

Post by thesquirell » Mon Dec 11, 2017 3:30 am

Are you using Reinhard tone mapping?

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Mon Dec 11, 2017 3:38 am

No, since I was 5 :lol:

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Foscarini lamp material

Post by thesquirell » Mon Dec 11, 2017 5:16 am

Haha, that's a good one! xD
Well, had to eliminate it, just to be sure, sorry.

What do you mean by "uncontrollable", could you describe it a little bit more? I'm using Cindigo, and had no problems whatsoever.

+

So, after testing it out for a while, I can confirm that "clamp contributions" messes up the effect we are trying to achieve here. Below is the link to testing pics, they are all renders baked under 1 minute.

https://mega.nz/#!NQogGCxa!-eyOpQjy7Kaj ... Xmup6yHxQc

Conclusion:
Not using "contributions" totally recommended.
If using "contributions" Path tracing mode is hit the hardest. BiDir recommended.
Since I'm an MTL animal, I would def. use this mode, and if I need to use CC, would def. use higher values, around the middle of the slider, or towards the end.

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 3:20 am

TheSquirrell, you've been of great help.
I'm attaching all of your tests as a reference, because they can be of direct use to enyone in this forum
Attachments
PathTracing_OpenCL_CC_off.jpg
PathTracing_CC_on_middle.jpg
PathTracing_CC_on_low.jpg
PathTracing_CC_off.jpg
BiDirMTL_CC_On_middle.jpg
BiDirMTL_CC_On_low.jpg
BiDirMTL_CC_Off.jpg

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 3:28 am

And then my two tests
Attachments
emitter off.jpg
emitter 0.01.jpg
emitter 1.jpg

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 3:42 am

My problem is that IN ANY CASE I don't get the smooth blend between metal and emissive material, but instead a very neat border, which is not real at all... :evil:

User avatar
Oscar J
1st Place Winner
Posts: 2148
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Foscarini lamp material

Post by Oscar J » Tue Dec 12, 2017 5:11 am

I thought you did manage to get gradient with clamping turned off? :)

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 5:17 am

Sorry Oscar I didn't get you :idea: :?:

User avatar
Oscar J
1st Place Winner
Posts: 2148
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Foscarini lamp material

Post by Oscar J » Tue Dec 12, 2017 5:29 am

I see a gradient transition in some of your earlier test renders. :)

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 5:41 am

..not really.. Those were reference photos (or other renders, not done by me).
I actually never managed to get such a great transition... :?

User avatar
thesquirell
Posts: 380
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Foscarini lamp material

Post by thesquirell » Tue Dec 12, 2017 6:24 am

You're welcome, Pibuz, and I thank you for upping those renders, I couldn't get them small enough to put them on the forum(500kb restriction).

Just a crazy idea, but did you uncheck "step blend" in the blend material options? Maybe it's on by default?

User avatar
Pibuz
1st Place 100
Posts: 2641
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Foscarini lamp material

Post by Pibuz » Tue Dec 12, 2017 6:32 am

I DID uncheck that. I also tried turning it on just to see, but obviously I got a very sharp dividing line between emitter and metal...

Post Reply
21 posts

Who is online

Users browsing this forum: No registered users and 1 guest