Newbie's lights not emitting

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
9 posts • Page 1 of 1
Whiskeykid
Posts: 4
Joined: Sun Apr 03, 2011 4:38 am

Newbie's lights not emitting

Post by Whiskeykid » Thu Apr 07, 2011 5:08 am

I'm new to Indigo, but the bit of work I've done with it has been impressive. I purchased it this past winter and have been playing around to become familiar with it. I'm an architecture student and I'm trying to utilize Indigo to render some presentation boards. I'm using Skindigo, but have been having grief with materials & lights. I've been searching through the forum & various tutorials and while I've definitely learned a lot, there's still a number of unanswered questions. Any help you folks can give would be greatly appreciated.

I've been through the Skindigo tutorial numerous times without much success, it seems it was written for an earlier version, as the material editor is significantly different.

Anyways, here's my first question:

I'm trying to add some lights, or rather, I'm trying to make some surfaces emit light. I've tried both editing the material by applying a downloaded emitter, as well as assigning the material an emitting preset. Neither work, the surface renders black. My faces are all oriented properly, BTW. In the model window of the material editor the surface doesn't emit either, regardless of the settings under Emission Attributes.

I'll start with that, if I can get some help getting that going I'll keep the questions coming.

Thanks!

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Newbie's lights not emitting

Post by Pibuz » Fri Apr 08, 2011 5:07 am

Hi Whiskey!
Light emitters are really easy to use, it's odd that you find problems with them..

basically:
1. create the emitting geometry
2. create a NEW material (using skindigo, make sure you click on the "create material" button with the DEFAULT SU MATERIAL as a base: if not, you're copying the current SU mat, with all its attached SkIndigo properties); basic colour will do the job
3. in the "emitter" panel (skindigo material editor) choose an active light layer (not OFF); make sure you select a layer different from the one of the sun and the sky, because their efficacy discrepancy could make your emitter too weak, if compared)
4. Set a temperature and a value. These settings can be later adjusted while the render is computing.
5. LAUNCH THE RENDER IN CAMERA TONEMAPPING, not reinhard!

Hope I helped

Whiskeykid
Posts: 4
Joined: Sun Apr 03, 2011 4:38 am

Re: Newbie's lights not emitting

Post by Whiskeykid » Sun Apr 10, 2011 6:01 am

AH-HA!

Thanks for the tips, turns out that my emission power had to be much much higher. Seems to be working now.

Incidentally though, your answer raises some questions. You mention a 'Create Material' button, and so does the tutorial. I can't find such a button anywhere! Instead I keep selecting a texture, right clicking it, and choosing 'Edit ___' in the right click menu. Am I missing something?

Thanks!

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Newbie's lights not emitting

Post by Pibuz » Mon Apr 11, 2011 8:32 pm

...again: you guys have to know at least the BASICS of your modeling application before starting to fiddle with plugins and stuff! :roll:
Attachments
create new mat.jpg

Whiskeykid
Posts: 4
Joined: Sun Apr 03, 2011 4:38 am

Re: Newbie's lights not emitting

Post by Whiskeykid » Tue Apr 12, 2011 2:46 am

Alright.

I thought you meant the option to create a new material was in the skindigo material editor, not SU.

Also, I DON'T have that button because I'm using SU on OSX, which has a completely different materials (textures) palette.

Thanks for the help

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Newbie's lights not emitting

Post by Pibuz » Tue Apr 12, 2011 2:50 am

I'm sorry, I overreacted..
I misread your answer and I thought you didn't even know what you were talking about.

Sorry mate.

Also, I don't know anything about SkIndigo for Mac, so I couldn't completely understand the question.

User avatar
Headroom
Indigo 100
Posts: 992
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Newbie's lights not emitting

Post by Headroom » Tue Apr 12, 2011 4:31 am

Yup. Some UI panels in Sketchup are laid out different than on a PC. I work on both platforms with Sketchup (only occasionally) and it tends to throw me for a loop :lol:

User avatar
fractal.design
Posts: 51
Joined: Wed Sep 08, 2010 4:38 pm

Re: Newbie's lights not emitting

Post by fractal.design » Tue Apr 12, 2011 9:18 am

Yes the materials in SU OSX are laid out for the insane. (which is doubly frustrating as OSX usually has such a tight UI.)

Spacedementia87
Posts: 1
Joined: Sat Jul 16, 2011 2:35 am

Re: Newbie's lights not emitting

Post by Spacedementia87 » Sat Jul 16, 2011 2:40 am

When you say create the material with the default emitter as a base how do you do that?

Post Reply
9 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 5 guests