MtI 3.2.5

Announcements, requests and support regarding the MAYA exporter
User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

MtI 3.2.5

Post by CTZn » Fri Jan 27, 2012 12:38 am

Hi, this is the Maya exporter to Indigo 3.2.5.

Current MtI version is 3.2.5.2.

change log since 3.2.5.1:

INSTALL:

+ added option not to initialize MtI on install
+ strengthened init on install a tad


UI:

+ fixed cutout option not showing for blend textures edited alone (aka transparency textures of layered materials)
+ added more options for nurbs

the primitive switch is available for nurbsSphere with history
+ removed some more junk output

EXPORT:

+ fixed emission scale missing
+ fixed erroneous frozen texture definition (XML tag error)
+ better nurbs support


change log since 3.2.5.0:
+ base emission is not forced anymore to 1.0 when black and if scale emission is not default (W/m²).
in this case no emission is exported. Note that Indigo will throw an error if there are no lights in scene however.

+ cursor remains busy after an unhandled error on export
click a shelf button to restore the normal cursor

change log since 3.2.2.2 (errors described below were fixed):

+ added "open" and "new" scene events management.
This was an earlier addition wich I removed inmediately because it was crashing Maya reportedly.
I think that I have fixed the crashing issue, let me know if doesn't work for you (it always did for me).

+ explicit error if the indigoPlugin is in use on install
- autoload is NOT recommended for the indigoPlugin (it will be loaded on MtI init)

Export:

+ export is now interruptable

+ fixed camera matching

+ Fixed keyframes

+ fixed frames updating during animation export

+ fixed texture index issues with layeredShader (blend)

+ fixed nasty bug in blend that would declare a specular before its medium

+ Improved exporting performances for duplicate instances to normal

+ fixed bug with displaced objects of a wrong scale
wich therefore were either not showing or occluding the scene, most likely.

+ experimental nurbs support
not satisfying currently, manual conversion to poly is still recommended

+ instancer: added support for nParticles systems

+ hidden instanced are not writting OBJ files
files missing fix


UI:

+ frozen UI slightly borked 2009

+ fixed texture as bump does not detect the material it is applied to to (2009)

+ fixed mti_Path UI
Esthetical fix, while it was unlocked the project type should not be modified atm

+ changed default TM to camera

+ The indigoText editor now retain its previous size

+ Added ability to graph from spectrum UI existing tabulated data as provided by an indigoText node
currently for display purposes only, editing the graph will not modify the values back
mti_error on tabulated bump is unclear

+ changed default emission layer for materials from 2 to 0.

+ added support for place2dTexture (translateFrame, repeat, offset)

+ changed "save IGI" default to 0.
IGI files are heavy and can now be saved from the Indigo GUI.

+ fixed displacement slot not showing for blended materials
those stacked into a layeredShader

+ fixed plausible crash on attempting to freeze/unfreeze an indigoText UI

+ The editor in error report mode will retrieve the preeceding freezing state when aknowledged

+ indigoText content does not require anymore the user to press a key to be saved
Attachments
mti_3.2.5.2.zip
(184.19 KiB) Downloaded 894 times
Last edited by CTZn on Wed Apr 25, 2012 9:08 am, edited 1 time in total.
Reason: From Announce to Normal topic type
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Fri Jan 27, 2012 8:34 am

Glad MtI is growing but:

I got this error after trying to export a single frame of the previous scene:

// Error: Cannot find procedure "mti_GEN_warning".

Export fails, I cancel it and the mouse turns to a circle (thinking) and I have to close and restart maya.

It was the first thing I did with the new MtI.

Ill try to do other things.

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Fri Jan 27, 2012 11:09 am

bummer, I really need to make a mandatory test scene :oops:

fixed in 3.2.5.1, change log up the first post.

Note that you can now export a black base emission, it will simply be discarded for Indigo. If the emission scale is not W/m² then a non-black (arbitrary) base emission will suffice for emission purposes.

Keying the emission type (none, spectrum, profile) is possible from the extra attributes of the material currently.
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Sat Jan 28, 2012 1:39 pm

Emission value is not working, I am controlling several lights intensity in the animation and I set to near 0 the emission value and the light continues to emit the same intensity. In version 3.2.2.2 it worked fine in single frame render.

But I also do not understand how it works, I looked to the material xml in the igs of the working file generated by MtI 3.2.2.2 and I did not find anything controlling the emission scale or emission value. In the material xml only appears the rgb of emission and base emission of the material. Were does it set these parameters?

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Sat Jan 28, 2012 7:29 pm

You are definitely right ior, emission scale was commented out while I was enhancing model writing. I then rushed into bugfixing and forgot about the comment. Another lesson for me.

It results that the performance increase in writing models is not 5000% as proudly announced but 1000%, in exporting one thousand duplicates (done 1000 models in 28.7s (34.84320557/s)).

That you will see with the update coming next. I'll make those test scenes progressively as I can't rely on myself to make good releases it seems.

Emission scale is defined in model tags as this parameter can be sensible to the square surface emitting.
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Mon Jan 30, 2012 9:01 am

CTZn wrote:You are definitely right ior, emission scale was commented out while I was enhancing model writing.
Can you say were it was commented (file and lines)? I tried to search for it but I am still a nob in
programing so I did not find it.

I would like to put the animation to render to see if the result is what I want, asap.

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Mon Jan 30, 2012 9:50 am

I found it!

In mti_GEN_.mel uncomment:

Code: Select all

//						string $mats[] = `mti_DG_shape2mats $shape`;
//						string $layeredMats[];
//						
//						//	emission scale of blended materials is unsupported by Indigo
//						//for($mat in $mats)
//						//{
//							//if(`nodeType $mat`=="layeredShader")
//							//{
//								//string $theInputs[] = mti_DG_matsBlendedIn($mat);
//								//$layeredMats = stringArrayCatenate ($theInputs, $layeredMats);
//							//}
//						//}
//						//$mats = stringArrayRemoveDuplicates(stringArrayCatenate ($mats, $layeredMats));
//						
////							global int $dbg;
//					//	test for this one level above, by shape not parent
//						for($mat in $mats)	$writeBuffer += mti_GEN_emissionScale($mat);

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Mon Jan 30, 2012 10:13 am

Just uncomment the first and last lines from the code above (two lines), you need:

Code: Select all

                  string $mats[] = `mti_DG_shape2mats $shape`;
                  for($mat in $mats)   $writeBuffer += mti_GEN_emissionScale($mat);
While you are at it you can also find the code below, in mti_EM.mel, into the procedure mti_EM_texture (around line 300):

Code: Select all

			if ($frz||$alreadyBaked)
			{
				if(	!`attributeExists "mti_storedPath" $tx`	)
					return mti_unfreezeAndBakeOnPathError($tx,  $mesh,  $mat,  $attr);
				
				$txPth = `getAttr ($tx+".mti_storedPath")`;
					
				if(	$txPth == ""	||	! `filetest -f $txPth`	)
					return mti_unfreezeAndBakeOnPathError($tx,  $mesh,  $mat,  $attr);
				
				float $txRanges[2] = mti_getTextureRanges($tx, $mat, $attr);
				float $gamma =  `getAttr ($tx+".txg")`;
				
				$textureXML += mti_GEN_customTexture($txPth, 0, $gamma, $txRanges, $smoothString);
				$textureXML += mti_GEN_texCoords ($mat, $attr, $tx);
				$textureXML = "\t\t</texture>\r\n";
			}
The last line should read

Code: Select all

				$textureXML += "\t\t</texture>\r\n";
This will fix the Indigo texture error with frozen procedural textures. I'm not responsible for further modifications you would make... I thought you would try something like that some day ;) To me that was one probable consequence of a: looking into the IGS then b: wondering how things should be there.

I am not encouraging you though. The second probable option for you was to stop right there. I went that hard way myself with MtI, figures.

Updating MtI tomorrow +/- 12h, apologies about all these little big errors...
obsolete asset

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Fri Feb 03, 2012 2:47 am

updated to mti 3.2.5.2.

change log since 3.2.5.1:

INSTALL:

+ added option not to initialize MtI on install
+ strengthened init on install a tad


UI:

+ fixed cutout option not showing for blend textures edited alone
aka transparency textures of layered materials
+ added more options for nurbs
the primitive switch is available for nurbsSphere with history
+ removed some more junk output

EXPORT:

+ fixed emission scale missing
+ fixed erroneous frozen texture definition
(XML tag error)
+ better nurbs support
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Tue Feb 21, 2012 4:12 am

Post-process lens diffraction is not working.

Scale of a group objects is not working, the objects stay with the original sizes.

Would be nice that instances can work with groups of objects, it gives an indigo render error when you instance a group. By the way, is there other ways to create instances in maya besides in Edit->Duplicate especial?

Grate to have nurbs support! What do you mean by "better nurbs support", is it working? I have made a nurbs sphere and the indigo editor does not appear, I might change previous objects to nurbs in order to have more accuracy. If the nurbs are going to be translated to obj what benefit do I get in therms of accuracy? Export will be more slow?

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Tue Feb 21, 2012 6:52 am

Fixed ppad for the next update.
Scale of a group objects is not working, the objects stay with the original sizes.
That's the hierarchy limitation I mentioned earlier, I am working on it currently.
Would be nice that instances can work with groups of objects, it gives an indigo render error when you instance a group. By the way, is there other ways to create instances in maya besides in Edit->Duplicate especial?
There is a objExport bug, instanced groups can not be saved as obj files. While they do create the file it always depicts an empty mesh. I'll see how the current works can affect this issue.

The other instancing system is particle instancing, however objects will be standing up with optional randomisation of the vertical orientation and/or scale. Particles orientation support is for a later time.

There was an old instancing system based on locators but I scraped it for it was obsolete.
Grate to have nurbs support! What do you mean by "better nurbs support", is it working? I have made a nurbs sphere and the indigo editor does not appear, I might change previous objects to nurbs in order to have more accuracy. If the nurbs are going to be translated to obj what benefit do I get in therms of accuracy? Export will be more slow?
Better nurbs support means that the rendering tesselation displayed is actually used for export, instead of the default tesselation options of Maya previously.

The editor should appear with any nurbs, may it be a sphere with history or another surface. Works for me... any kind of error showing ?

The benefit of using nurbs is that the tesselation can be changed aftermath, in addition to the proper differences in modeling with polygons. Indigo can only render polygons, save for the sphere primitive.
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Sat Feb 25, 2012 6:10 am

CTZn wrote:The editor should appear with any nurbs, may it be a sphere with history or another surface. Works for me... any kind of error showing ?
Yes, it gives this error when I click in indigo editor with a nurbs sphere primitive selected:

mti_CHK_self; mti_EDI;
// Error: No object matches name: nurbsSphereShape1.pri //

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Thu Mar 01, 2012 12:29 am

I was not able to find how it happened for you ior.

Perhaps try to redownload mti 3.2.5.2 if you happened to get it in the hour following the release.

I don't remember for sure but it is plausible that the zip file was replaced within that hour, possibly shipping with the working code as I'm finding it currently within. Check against the creation date.
obsolete asset

ior
Posts: 166
Joined: Tue Aug 24, 2010 11:47 am

Re: MtI 3.2.5

Post by ior » Sat Mar 03, 2012 6:20 am

I reinstalled MtI and it still gives the same error.

Maybe in the next update I may try the new features.

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: MtI 3.2.5

Post by CTZn » Sat Mar 03, 2012 7:31 am

It is unfortunate that the error is persisting, I would almost suspect a file conflict on your PC. I tried many ways to introduce nurbs in a scene and never got an error. Eventually a third user could tell us his or her experience with nurbs and MtI...

Could there be that a duplicate file was created somewhere after you hand edited its copy ?

Please make sure that all mti MEL files are unique in the folders that Maya is hashing at startup.

MtI MEL files are installed in (enter command):

Code: Select all

string $initPath = `internalVar -userAppDir`+"scripts/";
Please make sure that no mti_*mel file resides into one of the following folders:

Code: Select all

getenv MAYA_SCRIPT_PATH
I'll add this checking to the installer. MtI is undergoing revisions for an undeterminated period.
obsolete asset

Post Reply
27 posts

Who is online

Users browsing this forum: No registered users and 1 guest