Mesh export problems

Announcements, requests and support regarding the MAYA exporter
Post Reply
9 posts • Page 1 of 1
SreckoM
Posts: 124
Joined: Tue Jan 30, 2007 7:33 pm
Location: home/Serbia/Novi Sad

Mesh export problems

Post by SreckoM » Wed Jul 06, 2011 1:30 am

I am having problems with geometry when imported in Indigo. I guess objExporter does not export as it should. Geometry itself is not perfect, exported from Sketchup as obj and imported into Maya. Other render engines are rendering it as it is in viewport.

Here is screenshot of viewport and what I get in render.
http://screencast.com/t/LKZzYJXwlSV

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Mesh export problems

Post by CTZn » Wed Jul 06, 2011 2:19 am

Could you please send me an excerpt of your scene showing artifacts (ma/mb) ? Like two of these steps from the stairs, one right the other wrong for comparison.

Thanks for the report.
obsolete asset

SreckoM
Posts: 124
Joined: Tue Jan 30, 2007 7:33 pm
Location: home/Serbia/Novi Sad

Re: Mesh export problems

Post by SreckoM » Wed Jul 06, 2011 3:05 am

Here is part of scene.
Attachments
ArtifactsMesh.rar
(416.75 KiB) Downloaded 244 times

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Mesh export problems

Post by CTZn » Wed Jul 06, 2011 3:20 am

Thanks SreckoM.

The problem here is coplanarity, as it can be said from the OpenGL preview in renderer. Indigo doesn't cope as well with coplanarity.

In Maya save as a copy and try:

normals > unlock
edit mesh > merge
normals > conform
edit: mesh > cleanup non-manifold

Then activate backface culling to check for eventual inverted normals.

Ideally you would separate the whole mesh and identify the duplicate parts, that's what a cleaning takes. ouch.
obsolete asset

SreckoM
Posts: 124
Joined: Tue Jan 30, 2007 7:33 pm
Location: home/Serbia/Novi Sad

Re: Mesh export problems

Post by SreckoM » Wed Jul 06, 2011 3:25 am

OK, I will try that, thank you!

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Mesh export problems

Post by CTZn » Wed Jul 06, 2011 3:36 am

Not to mention that if we are talking about a mesh directly from SU backfaces should have a separate material assigned, start there rather.

Identify the backface shader, Select Objects In [shading group] (right click on swatch) then delete faces (then the backface shader).
obsolete asset

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Mesh export problems

Post by CTZn » Wed Jul 06, 2011 4:37 am

I'm posting as I'm tinkering with this... I think the grid unit length should be 0.254 (ten inches). Makes stairs steps of 16.4cm.

Also there's some wrong things going on with grouped transforms, I had part of the site scaled so to be found at 41Km from the center of the city... ehr, the world.

Currently you should try to keep transforms hierarchy flat (no transforms at the shape level). That's my traversal code involved, not objExport this time. There will be at least one minor release before that one gets enhanced (fixed hopefully).

Thanks for the headsup SreckoM.
obsolete asset

SreckoM
Posts: 124
Joined: Tue Jan 30, 2007 7:33 pm
Location: home/Serbia/Novi Sad

Re: Mesh export problems

Post by SreckoM » Thu Jul 07, 2011 2:15 am

Cleanup fixed most of the problems. For stairs helps only if I triangulate them.

Also I am getting these errors for almost every object in scene:

Code: Select all

// Error: No object matches name: .ambientColor // 
// Error: No object matches name: .normalCamera // 
// Error: No object matches name: .color // 

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Mesh export problems

Post by CTZn » Thu Jul 07, 2011 3:19 am

SU models are essentially nonmanifold, that's indeed a job for cleanup.

As for those errors they have no effect, please ignore them for now. I am not yet sure why they come back and forth.
obsolete asset

Post Reply
9 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest