GPU mode bug - Invisible objects shade themselves

Feature requests, bug reports and related discussion
Post Reply
3 posts • Page 1 of 1
easyarchitect
Posts: 38
Joined: Fri Jan 12, 2007 1:49 am

GPU mode bug - Invisible objects shade themselves

Post by easyarchitect » Sun May 10, 2020 8:49 pm

I would like to point out this problem that is only present in GPU mode.

In the second image below the not-visible wall contains an open window that is marked as "invisible to the camera" too.

As you can see, the windows (and the wall) are correctly invisible, but the windows shadows on itself (black lines). This is not correct in my opinion.

The CPU version (Pathtrace) instead does the correct things (see first image)

The problem is present in the 4.2.27 version, but also in the 4.4.6 beta

No exit portals used in both cases

Greetings

AD
Attachments
CPU is working.png
CPU version (OK)
GPU is broken.png
GPU version (KO)

User avatar
Zalevskiy
Posts: 197
Joined: Thu Jul 16, 2015 12:36 am
Location: Russian Federation

Re: GPU mode bug - Invisible objects shade themselves

Post by Zalevskiy » Mon May 11, 2020 12:12 am

if you change the max patch depth (render settings tab) value to 32 the problem disappears?

easyarchitect
Posts: 38
Joined: Fri Jan 12, 2007 1:49 am

Re: GPU mode bug - Invisible objects shade themselves

Post by easyarchitect » Mon May 11, 2020 1:16 am

I've done some test, the problem is still present with MaxPathDepth=9 and disappear (in my case) with MaxPathDepth=10, if I go higher the rendering speed decreases too much, 10 seem to be a good compromize

Thank you

AD

Post Reply
3 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 6 guests