Windows

Come here for help & support.
Post Reply
14 posts • Page 1 of 1
Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Windows

Post by Alcaide » Mon Sep 23, 2019 11:41 pm

Hi.

I use the free Indigo Renderer v3.8.37, Windows 64-bit build on Sketchup, and when I do the rendering the windows appears in black.
Can someone helpo me?
Best regards.

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Windows

Post by thesquirell » Tue Sep 24, 2019 8:46 pm

Greets!

Not really using Sketchup here, but couple of things cross my mind. For example, are you using closed volume object for the glass, or are you using plane objects? If you are using plane objects, make sure you are using the correct material - architectural glass. It's the option available for the specular material type. If you are using closed volume objects, make sure your normals are pointing outwards, not inwards. And lastly, check your model scale. Maybe you are translating your scene to kilometers when rendering in Indigo, which causes the medium inside the object to absorb all the light.

Give it a go with these advice, and let us know how it all went.

User avatar
pavoda
Posts: 122
Joined: Tue Dec 20, 2016 10:05 am

Re: Windows

Post by pavoda » Tue Sep 24, 2019 9:15 pm

I guess the error is in the exposure settings. Set up camera to Reinhard. If will the window still black, save the scene as an pigs file (in indigo) and share it here on the forum.

Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Re: Windows

Post by Alcaide » Tue Sep 24, 2019 10:17 pm

Hi. Thanks everyone for the tips, but still not working. :(
Here some files

https://drive.google.com/open?id=1QHQCK ... S3q_Mab-Bh


Thanks again

User avatar
Zom-B
1st Place 100
Posts: 4655
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Windows

Post by Zom-B » Tue Sep 24, 2019 10:47 pm

Hey Alcaide,

please make sure to use "Single Sided Arch Glass" for your Window glass as long as it has no thickness and is made out of a simple plane.

You uploaded only the igs, make sure to save out a pigs that packs all meshes and textures into the file :)

If you have issues always double-check to use the latest version since issues could be already fixed. Up to date ist Indigo 4.4.1:
viewtopic.php?f=1&t=15253
polygonmanufaktur.de

Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Re: Windows

Post by Alcaide » Wed Sep 25, 2019 1:04 am

Thanks for the tips. There's a new file in the drive.
Even with no thickness the result it's the same.

Image

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Windows

Post by thesquirell » Wed Sep 25, 2019 9:43 am

Ok, so here is your fix. You should tick the arch glass and Single face option in the material option. After you do that, change the rendering mode to MLT or anything else, it will "update" the scene and it will render it out correctly. The reason why your window material renders black is because of your model, that has no physical thickness. In future, just model your windows like you would make them in real life, or use the above mentioned option.

I've attached an image to make it easier for you to find it.
fix.jpg
fix.jpg (7.33 KiB) Viewed 267 times
P.S

You can also use absorption in the medium with that option turned on, but be aware that it might act differently when you model your glass surfaces correctly, and you should use it with care, and caution, for a more subtle effect.

Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Re: Windows

Post by Alcaide » Wed Sep 25, 2019 9:40 pm

I give up...

I tried all your tips and I can't change it...

Thank you all

Image

User avatar
Zom-B
1st Place 100
Posts: 4655
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Windows

Post by Zom-B » Wed Sep 25, 2019 9:52 pm

You should try harder mate:
default.jpg
Again:

A) Set Material to single Sided Arch Glass

B) You have some massive absorbtion on your Glass that turns it opaque, turn off the absorption
polygonmanufaktur.de

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Windows

Post by thesquirell » Wed Sep 25, 2019 10:26 pm

I don't understand, how can you just quit with all these fine advices hanging around...

Just for the demonstration purposes and maybe an inspiration, it can be done, don't give up:
3.png
2.png
1.png
And you can take the .pigs files to dissect it.

https://files.fm/u/htz4r6r3

Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Re: Windows

Post by Alcaide » Thu Sep 26, 2019 3:57 am

When I do the test it works, but then when I render it doesn't work. :(

Image

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Windows

Post by thesquirell » Thu Sep 26, 2019 6:15 am

That's the spirit, never give up! :D


At least, we are getting somewhere, it started working when you did the tests.

Now, as for the material.
Since I don't use SketchUp, I can't help you with that, but try searching for the option Single face. Maybe it's in the object properties, dunno. In the end, you could bypass the material creation inside SketchUp, and just use an external material that you created, and know it works. I guess that Import button does the trick for that.
Last edited by thesquirell on Thu Sep 26, 2019 8:51 pm, edited 1 time in total.

Alcaide
Posts: 6
Joined: Mon Sep 23, 2019 11:39 pm

Re: Windows

Post by Alcaide » Thu Sep 26, 2019 8:47 pm

Thank you all.

I guess the problem it's in sketchup material settings. I downloaded some glass material from the warehouse and it works :)

Image


Thank you all for your advices.

User avatar
thesquirell
Posts: 391
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: Windows

Post by thesquirell » Thu Sep 26, 2019 9:01 pm

Don't mention it!

Best of luck!

Post Reply
14 posts • Page 1 of 1

Who is online

Users browsing this forum: Ahrefs [Bot] and 0 guests