OpenCL Glass Problem

Come here for help & support.
Post Reply
11 posts • Page 1 of 1
User avatar
Lal-O
2nd Place Winner
Posts: 270
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

OpenCL Glass Problem

Post by Lal-O » Sat Sep 01, 2018 1:29 pm

Hi there guys . :D

Please .This time i need your help to solve a problem with some glass panels of a project for a client that i am working on.

I've already checked my model and is fine ,i mean ...it's been modeled as always since i started to use indigo for rendering some years ago and this is the first time i face an issue with glass and Indigo. :cry:

The rendering process is fine if i keep OpenCl off, but once i enable it then this strange triangles appears.

I attach the .pigs and some screen caps just in case someone wants to take a look. :D

Thank you in advance.

Cheers! :D
Attachments
Beach apartments.pigs
(3.6 MiB) Downloaded 3 times
Problem.jpg
No Problem.jpg

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Sun Sep 02, 2018 9:48 pm

can you share the mesh as obj? also the windows only as pigs pl.
polygonmanufaktur.de

User avatar
Lal-O
2nd Place Winner
Posts: 270
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: OpenCL Glass Problem

Post by Lal-O » Thu Sep 13, 2018 8:12 am

Hi Zom-B !

Sorry for my soooo late reply. I was really busy working in this project :D

About the model...well, i solved the problem by copying other glass panels from other projects and everything got fixed :D

I am not able to replicate the issue anymore :roll: . But i am facing some other similar problems with other scene (A terrace). Lights seem to be "blocked" with other geometry (you can see it in the spot ligths at stair and the pool) , but they are well modeled.

I attach some screencaps and the .pigs if you want to take a look :D

Pigs Link
https://drive.google.com/open?id=1KVbkl ... _xWf_OAVow

( I've also try OpenCL with CPU Unchecked and no change).
Attachments
OpenCL.jpg
No OpenCL.jpg

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Thu Sep 13, 2018 10:06 pm

I'll check this one tonight, thanks for the upload!
polygonmanufaktur.de

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Sat Sep 15, 2018 7:08 pm

Hey Lal-O, I finally got some time to take a look into your scene.

First of all please please with sugar on top disable the CPU in OpenCL render mode, this is slowly killing me!!1!
On my GPU the image does render different then in your GPU+CPU mode, I got expected results, noisy for the candle light because PT without BiDir hates such tiny emitter sizes:

Terrace_GPU.jpg

Regarding your uploaded I file I ask myself why do you keep rendering Sun + Sky for a night scene and disable the layers then?
This still does all the calculations for Sun+Sky and slows the convergance of the whole image down.

Your scene is also very big, 3 full houses with 3 terraces and a lot of architectural stuff below it. Try to organize your scenes in a way, that you only export and render relevant areas, disable unneeded areas for export.

Your Pool Water seems to be made out of ArchGlass, this is a bad choice if you want some realistic look for that pool.
polygonmanufaktur.de

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Sun Sep 16, 2018 2:18 am

I also tested this scene of yours: https://www.indigorenderer.com/forum/vi ... 74#p141951
Having no issue with the glass at all...
Again, have you even tried rendering that without your CPU in OCL?!
polygonmanufaktur.de

User avatar
Lal-O
2nd Place Winner
Posts: 270
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: OpenCL Glass Problem

Post by Lal-O » Sun Sep 16, 2018 12:16 pm

Zom-B wrote:
Sat Sep 15, 2018 7:08 pm
Hey Lal-O, I finally got some time to take a look into your scene.

First of all please please with sugar on top disable the CPU in OpenCL render mode, this is slowly killing me!!1!
On my GPU the image does render different then in your GPU+CPU mode, I got expected results, noisy for the candle light because PT without BiDir hates such tiny emitter sizes:


Terrace_GPU.jpg


Regarding your uploaded I file I ask myself why do you keep rendering Sun + Sky for a night scene and disable the layers then?
This still does all the calculations for Sun+Sky and slows the convergance of the whole image down.

Your scene is also very big, 3 full houses with 3 terraces and a lot of architectural stuff below it. Try to organize your scenes in a way, that you only export and render relevant areas, disable unneeded areas for export.

Your Pool Water seems to be made out of ArchGlass, this is a bad choice if you want some realistic look for that pool.
1) My CPU is Disabled everytime i use OpenCL :roll: ( i got it since the very first time you advice me to do it ).
The .pigs i've uploaded is like is because i wanted you to see if there could be any other resason of failure beside to have enabled the CPU...That's it ( a model ,bad modeling skills, etc etc).But it is always disabled (all my drivers are updated :D ).


2)The light layers was to create 3 different ambiet ( morning, afternoon and night ) at same time( that is their purpose, right ?).If light layers may cause any problem then i will stop using them.

Maybe you did not noticed,but this time i was not complaining about rendering times (like in the bathroom project) :D

3)Yeah, you're right. I always render only the stuff i need to be seen in the imagenes :wink:

4) I thought that the Archglass needed to be used in all transparent materials for saving rendering time.

Thank you for taking the time to look at my scene...If works for you then there must be something wrong with my computer.

User avatar
Lal-O
2nd Place Winner
Posts: 270
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: OpenCL Glass Problem

Post by Lal-O » Sun Sep 16, 2018 12:21 pm

Zom-B wrote:
Sun Sep 16, 2018 2:18 am
I also tested this scene of yours: https://www.indigorenderer.com/forum/vi ... 74#p141951
Having no issue with the glass at all...
Thank you.
I am glad it worked for you. :D
I've solved the problem by changing the glass panel for other ones (different models done by myself). :D

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Sun Sep 16, 2018 6:48 pm

Hey Lal-O,

1) In all your two examples above the CPU is clearly activated! It is the checkbox above your Titan X :lol:

2) rendering multiple night and day themes at the same time sounds smart at the first place but in my experience it is hard to adjust all lights in a way that after X rendertime the one of these is not way noisier then the other. But thats maybe just me :)

4) Arch Glass is reflectiopns only but no refractions, that is a massiv differance. Arch Glass is named that way since its used for windows most of the time, where the missing refraction for thin cubic Glass planes isn't notable most of the time. Disable it in your scene, and you'll note a gigantinc differance in the look.
polygonmanufaktur.de

User avatar
Zom-B
1st Place 100
Posts: 4592
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: OpenCL Glass Problem

Post by Zom-B » Sun Sep 16, 2018 7:21 pm

Lal-O wrote:
Sun Sep 16, 2018 12:21 pm
Zom-B wrote:
Sun Sep 16, 2018 2:18 am
I also tested this scene of yours: https://www.indigorenderer.com/forum/vi ... 74#p141951
Having no issue with the glass at all...
Thank you.
I am glad it worked for you. :D
I've solved the problem by changing the glass panel for other ones (different models done by myself). :D
This should not be the case, either you have CPU rendering enabeled as the screenshot clearly shows,
or your GPU drivers are old...
polygonmanufaktur.de

User avatar
Lal-O
2nd Place Winner
Posts: 270
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: OpenCL Glass Problem

Post by Lal-O » Mon Sep 17, 2018 5:38 am

Zom-B wrote:
Sun Sep 16, 2018 7:21 pm
Lal-O wrote:
Sun Sep 16, 2018 12:21 pm
Zom-B wrote:
Sun Sep 16, 2018 2:18 am
I also tested this scene of yours: https://www.indigorenderer.com/forum/vi ... 74#p141951
Having no issue with the glass at all...
Thank you.
I am glad it worked for you. :D
I've solved the problem by changing the glass panel for other ones (different models done by myself). :D

This should not be the case, either you have CPU rendering enabeled as the screenshot clearly shows,
or your GPU drivers are old...
Of course CPU is enabled in the screenshot...There are reasons for it :D
1) It was the first test of the project ( almost 3 weeks ago :roll: ).Right before i knew all the useful stuff i know today :wink:
2)I've always worked with both devices enabled without any problem (I USED to belive that this would increase the rendering speed.Now i know i was wrong) and this was the very first time i had a problem on exteriors using CPU+GPU...That is why i created this post :D
3)I did change the model of the glass panels,render with OpenCL (both devices enabled) and it worked! Why? Don't know...I don't have why to lie,trust me...Indigo Renderer is my main tool of work ( Arch Viz is my side business,but at this very moment,me and my family are living of this :D ) and i want contribute to indigo gets better everyday.
4)The last thing i want is to be annoying :oops:

-Here is a proof of the point 3-


My final conclusions:

OpenCL -CPU+GPU Enabled- Sometimes work, some others doesn't
OpenCL -GPU enabled- Always works so ... why take risks? :D
Attachments
CPU+GPU Glass Panels.jpg
Pool View 02.png

Post Reply
11 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 0 guests