Clipmap small issue

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
14 posts • Page 1 of 1
User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Clipmap small issue

Post by Pibuz » Fri Apr 09, 2010 5:47 am

Hi Whaat, hi all.

I see something is happening when working with clipmaps. Here's the reference image:
Image

In the scene there are 2 trees behind the camera, both of them are simple b/w images mapped onto a plane; same texture used as albedo and clip map. If you have a look to the borders of the shadows you'll see that there are a lot of fireflies, and that's a thing which I noticed in the past also. Since it's not one of my rendering priorities, I simply waited for someone to fix it. 8)

It has not been fixed, so I am here. :lol:

Is there a way to adjust some settings or something? Thank you!

User avatar
Whaat
Developer
Posts: 1824
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: Clipmap small issue

Post by Whaat » Fri Apr 09, 2010 6:46 am

Pibuz wrote: In the scene there are 2 trees behind the camera, both of them are simple b/w images mapped onto a plane; same texture used as albedo and clip map. If you have a look to the borders of the shadows you'll see that there are a lot of fireflies, and that's a thing which I noticed in the past also. Since it's not one of my rendering priorities, I simply waited for someone to fix it. 8)

It has not been fixed, so I am here. :lol:

Is there a way to adjust some settings or something? Thank you!
I think the fireflies would be be reduced or eliminated by enabling 'step blend'. Sorry but this feature has not yet been added to SkIndigo but I may add it for the next version.

As a workaround, you could create a blend material using the Indigo Material editor (blend of diffuse and null) and then enable 'step blend'. Then, create a 'linked IGM' material in SkIndigo that links to this material. Make sense?

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Fri Apr 09, 2010 7:39 pm

Sounds like a tricky workaround to me.. :?
I have no hurry for this so I can wait for the step blend option with no problem at all. 8)

I did another test rendering with hybrid mode and it all came fine.
I suggest you add the option anyway. :wink:

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Clipmap small issue

Post by OnoSendai » Sat Apr 10, 2010 10:11 pm

Yup, you definitely want to enable 'step blend'

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Sun Apr 11, 2010 3:41 am

This is the test calculated in Hybrid mode.
I added a second model of weed just to test that out.

Image

User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Clipmap small issue

Post by Bosseye » Fri Apr 23, 2010 12:18 am

Man, I'm loving that grass pibuz! Looks awesome - any chance of sharing the model/source for sketchup? :wink:

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Fri Apr 23, 2010 4:25 am

No problem at all. Once I've found the skp file again! :mrgreen:
My aim was to make a little tut out of this, and THEN share the skp as a base for the tut...but I can share the model first anyway. Give me a couple days!

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Fri Apr 23, 2010 6:14 am

Done. Visit my blog and go to the download section. If you don't speak italian, you'll tell the right topic from the image :mrgreen:

User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Clipmap small issue

Post by Bosseye » Wed May 12, 2010 12:08 am

Heh, cheers pibuz :D

I'll have to download at home - for some reason my work is blocking access to your downloads link 'category gambling'..... :lol:

User avatar
wojtek-w
Posts: 106
Joined: Fri Nov 06, 2009 5:21 am
Location: Poland
Contact:

Re: Clipmap small issue

Post by wojtek-w » Wed May 12, 2010 5:39 am

Pibuz wrote:Done. Visit my blog and go to the download section. If you don't speak italian, you'll tell the right topic from the image :mrgreen:
thanks Pibuz! You are great!
BTW I have a question for You (maybe it is a little bit off topic - sorry) how do you replace complex weed model with those boxes (dummies)? I thought i know sketchup pretty well, but i can't figure this out...

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Wed May 12, 2010 5:49 am

That's a very simple procedure to make very heavy scenes to be easily handleable.
1. You have a heavy component named for example "grassweed"
2. ENABLE INSTANCING over the heavy component
3. MAKE A SIMPLE COMPONENT (its dimensions should be similar to the "grassweed" component bounding box)
4. Name it "grassweed_dummy"
5. ENABLE INSTANCING over "grassweed_dummy"
6. (MAKE THE SCENE NAVIGATION LIGHTER, HIDING THE HEAVY COMPONENT)
7. SPREAD AROUND "GRASSWEED_DUMMY".

User avatar
wojtek-w
Posts: 106
Joined: Fri Nov 06, 2009 5:21 am
Location: Poland
Contact:

Re: Clipmap small issue

Post by wojtek-w » Wed May 12, 2010 6:11 am

Thank You.
You are useful as always.
I knew that there was something like "instancing enable/disable" in skindigo options, but I missunderstood all idea. Now thanks to You it's all clear. I belive that the rule for naming instaces is always "component-name_dummy", right?

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Clipmap small issue

Post by Pibuz » Fri May 14, 2010 12:13 am

Exactly

User avatar
Bosseye
Posts: 312
Joined: Fri Jan 01, 2010 10:52 pm
Location: Bristol, UK

Re: Clipmap small issue

Post by Bosseye » Fri May 14, 2010 12:15 am

wojtek-w wrote:Thank You.
You are useful as always.
I knew that there was something like "instancing enable/disable" in skindigo options, but I missunderstood all idea. Now thanks to You it's all clear. I belive that the rule for naming instaces is always "component-name_dummy", right?
Correct.

Perhaps not important for organic stuf like this, but don't forget if you want your dummys to appear in a specific position, you might need to alter the component axis to match a reference point on the original component.

For example, I've been using dummys to render multiple cars in a car park and I want them all to appear within the parking spaces, so I have to set the source component axis on the corner of the parking space and then set the dummy axis on the corner of the dummy box - this means I know that putting the origin of the dummy component on the corner of the space results in a dummy car rendering in the correct position within the parking space.

If that makes any sense!

Post Reply
14 posts • Page 1 of 1

Who is online

Users browsing this forum: Ahrefs [Bot] and 0 guests