Noise

Feature requests, bug reports and related discussion
Post Reply
14 posts • Page 1 of 1
kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Noise

Post by kaneyeo » Fri Oct 23, 2009 2:04 pm

Hi

I am new in Indigo Renderer and I am evaluating this software for my company now.

Indigo Renderer generates very good photorealistic rendering from my SketchUp Model however I still cannot figure out reduce noise level after rendering for 13 hours. Have I missed any setting? or?

kaneyeo
Attachments
default7.jpg
default7.jpg (77.78 KiB) Viewed 3813 times

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Noise

Post by benn » Fri Oct 23, 2009 4:43 pm

Hi kaneyeo,

Try setting your glass to 'Thin glass' using the Material Type chooser in SkIndigo materials. That will reduce fireflies.

Regards,
Ben

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Noise

Post by CTZn » Fri Oct 23, 2009 4:57 pm

Also you want to make sure that you are using exit portals for interior scenes, lit by (any type of) environment lighting.

Set colours to 80% value maximum, never 100% ! The same thing applies for colours saturation, it is better low.

Welcome !
obsolete asset

kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Re: Noise

Post by kaneyeo » Fri Oct 23, 2009 5:57 pm

Thanks Ben, I have removed all glass objects and I still gets same amount of fireflies
benn wrote:Hi kaneyeo,

Try setting your glass to 'Thin glass' using the Material Type chooser in SkIndigo materials. That will reduce fireflies.

Regards,
Ben

kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Re: Noise

Post by kaneyeo » Fri Oct 23, 2009 6:00 pm

Thanks CTZn, Any clues for exit portals? Like a print screen image to show me how or where to set?
CTZn wrote:Also you want to make sure that you are using exit portals for interior scenes, lit by (any type of) environment lighting.

Set colours to 80% value maximum, never 100% ! The same thing applies for colours saturation, it is better low.

Welcome !

User avatar
Pibuz
1st Place 100
Posts: 2646
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Noise

Post by Pibuz » Fri Oct 23, 2009 8:35 pm

"Exit portal" is just another kind of shader, you find it in the shader type drop-down list in the SkIndigo mat editor. Just apply a simple colour to a surface (make sure that is the white SU face), place it to cover the holes in the walls (your windows :wink: ) facing inside your room and choose "exit portal" as the shader. Done.

That won't reduce your fireflies, I fear. I often see similar effect when using metals: make sure your metallic objects are detached from the base surface by 1mm. That should help reducing your fireflies.

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Noise

Post by benn » Sat Oct 24, 2009 5:16 pm

Hmm strange scene bug - could you send us the .skp file? ben@indigorenderer.com. You can also try using metroplis light transport (MLT) to reduce fireflies - or decrease the MNCR number (in skindigo advanced settings).

kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Re: Noise

Post by kaneyeo » Mon Oct 26, 2009 2:59 pm

Thanks Pibuz, for your "Exit portal" information. As for my rendering, I have just left all windows empty for daylight comes into interior without "Exit portal" shader. I did another test on my model by rendered over weekend with and without ceiling. The one without ceiling has very litte fireflies while the one with ceiling still have them after 65 hours of rendering...

Pibuz wrote:"Exit portal" is just another kind of shader, you find it in the shader type drop-down list in the SkIndigo mat editor. Just apply a simple colour to a surface (make sure that is the white SU face), place it to cover the holes in the walls (your windows :wink: ) facing inside your room and choose "exit portal" as the shader. Done.

That won't reduce your fireflies, I fear. I often see similar effect when using metals: make sure your metallic objects are detached from the base surface by 1mm. That should help reducing your fireflies.
Attachments
default16 65h.jpg
default16 65h.jpg (74.64 KiB) Viewed 3573 times
default18 65h.jpg
default18 65h.jpg (54.25 KiB) Viewed 3570 times

kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Re: Noise

Post by kaneyeo » Mon Oct 26, 2009 3:03 pm

Thanks Benn, I will send you skp file thru your email
benn wrote:Hmm strange scene bug - could you send us the .skp file? ben@indigorenderer.com. You can also try using metroplis light transport (MLT) to reduce fireflies - or decrease the MNCR number (in skindigo advanced settings).

User avatar
Zom-B
1st Place 100
Posts: 4688
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Noise

Post by Zom-B » Mon Oct 26, 2009 4:36 pm

Hey Kaneyo, please fololw CTZn's guidelines about color!!!1!

Your white color is some real pain for every raytracer.. use max of 200,200,200 for RGB
polygonmanufaktur.de

kaneyeo
Posts: 6
Joined: Fri Oct 23, 2009 1:55 pm

Re: Noise

Post by kaneyeo » Mon Oct 26, 2009 6:59 pm

Thanks ZomB, I will give a try on setting my white to 200,200,200.
ZomB wrote:Hey Kaneyo, please fololw CTZn's guidelines about color!!!1!

Your white color is some real pain for every raytracer.. use max of 200,200,200 for RGB

User avatar
Meelis
Posts: 383
Joined: Sat Mar 14, 2009 11:29 pm
Location: Estonia

Re: Noise

Post by Meelis » Mon Oct 26, 2009 7:19 pm

Hey

I'm interested about the pure white. What happens with that, because there is only 20% between 1-1-1 and 0.8-0.8-0.8 or ~50% less colour tones.

User avatar
psor
1st Place Winner
Posts: 1295
Joined: Sun Jun 25, 2006 1:25 am
Location: Berlin
Contact:

Re: Noise

Post by psor » Tue Oct 27, 2009 12:41 am

There is no 100% reflectance in the real world. The maximum measured reflectance is 88% and
that is a white glossy sheet of paper. If you set reflectance to 100% then the pathtracing will go
mad cause the rays will bounce like crazy will cause unexpected results as bad looking materials,
fireflies, washed out images and speed decreasing. So using pure white aka 255/1.0 should be on
top of the list of nono's. If you want things look real start to use real material settings. ;)

btw. this is the case for all render engines.


Here a graph that shows the decreasing speed of the engine.

Image






take care
psor
"The sleeper must awaken"

User avatar
Meelis
Posts: 383
Joined: Sat Mar 14, 2009 11:29 pm
Location: Estonia

Re: Noise

Post by Meelis » Tue Oct 27, 2009 2:29 am

Very interesting. And that's really big speed difference.
:)

Post Reply
14 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests