Can't Install 2.2.1 on Ubuntu 9.04

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
11 posts • Page 1 of 1
Dreamlens
Posts: 3
Joined: Sat Oct 17, 2009 5:18 am
Location: Eugene, Oregon
Contact:

Can't Install 2.2.1 on Ubuntu 9.04

Post by Dreamlens » Sat Oct 17, 2009 5:23 am

I am trying to install Blendigo 2.2.1 on Ubuntu 9.04 64, but when I run the install.sh I get this:

---------

Blendigo Installer for Linux.


Sorry, we have a problem, we could not find the "/root/.blender/scripts" directory on your system. Create
this directory and then re-run this installer.

Installation terminated.

-----------

What I really want is for the script to look in my home directory, not the root home directory. I have a .blender directory in my home folder.

What should I do?

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by benn » Sat Oct 17, 2009 2:36 pm

You should run it as your current user - not with sudo. We don't require sudo to install Blendigo. :)

I hope the script works for you - I enjoyed writing that. Go go bash-fu!

Will you buy a licence if it works for you?

Dreamlens
Posts: 3
Joined: Sat Oct 17, 2009 5:18 am
Location: Eugene, Oregon
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by Dreamlens » Sat Oct 17, 2009 4:53 pm

That did the trick, so it is installed now. However, I am getting the following message now after I click the "Render" button, and the Indigo window opens:

Error: SceneLoaderExcep: CSModelLoaderExcep: ModelFormatDecoderExcep for model '/tmp/Plane_001_0.igmesh': Invalid format version. (In element 'mesh', around line 141, column 5)

After that I see a status message that says, "Rendering | Building Scene...", but after 10 minutes or so I see nothing but black. I have an emitting material, and I have a very simple scene in Blender that I am trying out. Preview renders are working fine.

Hmm.

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by benn » Sat Oct 17, 2009 10:09 pm

Hey Dreamlens,

You should install http://www.indigorenderer.com/dist/beta ... 2.4.tar.gz on your system - that should take care of the igmesh incompatibility. :)

Ben

Dreamlens
Posts: 3
Joined: Sat Oct 17, 2009 5:18 am
Location: Eugene, Oregon
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by Dreamlens » Sun Oct 18, 2009 7:18 am

I installed the newer version of Indigo (2.2.4) and ran the Blendigo installer (2.2.1) shell script again, updating the path to Indigo. Indigo works by itself with the included test scenes, but I am getting the same error message I was before when I try to render a scene from Blender.

Error: SceneLoaderExcep: CSModelLoaderExcep: ModelFormatDecoderExcep for model '/tmp/Plane_001_0.igmesh': Invalid format version. (In element 'mesh', around line 151, column 5)

This is with Blender 2.49b 64-bit version.

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by benn » Sun Oct 18, 2009 8:40 am

Okay - I'll look into this next week and update this thread. Sorry for the problems.

User avatar
kikeonline
3rd Place Winner
Posts: 160
Joined: Wed May 21, 2008 2:47 am
Location: Nicaragua

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by kikeonline » Mon Nov 16, 2009 7:19 am

Same problem here, can get it to work on linux ubuntu 9.04

namco
Posts: 15
Joined: Wed Sep 16, 2009 1:03 am

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by namco » Thu Nov 26, 2009 6:23 am

Was this ever fixed, or just ignored? I still get an error very much like the one Dreamlens gets

User avatar
eman7613
Posts: 597
Joined: Sat Sep 16, 2006 2:52 pm

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by eman7613 » Fri Dec 04, 2009 4:38 am

Code: Select all

if [ "$(id -u)" == "0" ]; then
   echo "This script should not be run as root, please install as a normal user"
   exit 1
fi
Yes i know, my spelling sucks

User avatar
benn
Posts: 1046
Joined: Mon Dec 08, 2008 12:47 pm
Location: Wellington, New Zealand
Contact:

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by benn » Fri Dec 04, 2009 10:50 am

You should install the latest blendigo and the latest indigo, we'll be releasing 2.2 stable next week - thus the download links will point to the latest versions that work well.

The mesh problem is when you have Indigo 2.0 and Blendigo 2.2 :)

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Can't Install 2.2.1 on Ubuntu 9.04

Post by dougal2 » Fri Dec 04, 2009 11:41 am

benn wrote:The mesh problem is when you have Indigo 2.0 and Blendigo 2.2 :)
Actually, I think the mesh problem reported above was due to blendigo exporting 64bit 'longs' instead of 'ints' in the binary mesh data - I fixed the bug recently anyway and it will work in the next stable release.

Post Reply
11 posts • Page 1 of 1

Who is online

Users browsing this forum: BLEXBot [Crawler], Semrush [Bot] and 1 guest