Blendigo for v1.1.13

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
131 posts
User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Sat Nov 08, 2008 12:14 am

try it now
Check normals, dude!

Image
Image

enricocerica
Indigo 100
Posts: 155
Joined: Wed Jul 12, 2006 5:26 pm

Post by enricocerica » Sat Nov 08, 2008 12:53 am

enricocerica wrote:I may be wrong but it seems that bump and exponent maps are inverted, I mean bump index is used for exponent and vice/versa.

Code: Select all

	<material>
		<name>plateau table</name>
		<phong>
			<exponent>
				<constant>250</constant>
			</exponent>
			<ior>1.2</ior>
			<texture>
				<path>..\3D\Images et textures\Metal\metalbase0061_L.jpg</path>
				<uv_set>UVTex</uv_set>
				<exponent>2.200000</exponent>
				<a>0</a>
				<b>1</b>
				<c>0</c>
			</texture>
			<texture>
				<path>..\3D\Images et textures\Metal\metalbase0061_L_S.jpg</path>
				<uv_set>UVTex</uv_set>
				<exponent>2.200000</exponent>
				<a>0</a>
				<b>1</b>
				<c>0</c>
			</texture>
			<texture>
				<path>..\3D\Images et textures\Metal\metalbase0061_L_B.jpg</path>
				<uv_set>UVTex</uv_set>
				<exponent>2.200000</exponent>
				<a>0.005</a>
				<b>0.005</b>
				<c>0.005</c>
			</texture>
			<diffuse_albedo>
				<texture>
					<texture_index>0</texture_index>
				</texture>
			</diffuse_albedo>
			<bump>
				<texture>
>>>					<texture_index>1</texture_index>
				</texture>
			</bump>
			<exponent>
				<texture>
>>>					<texture_index>2</texture_index>
				</texture>
			</exponent>
		</phong>
	</material>
Thanks SmartDen, the bump in blend problem is solved. By the way the other mentioned problem reagarding the exponent and bump maps (see quoted) is still there.

Gog
Posts: 77
Joined: Thu Jan 25, 2007 10:35 pm

Post by Gog » Sat Nov 08, 2008 1:22 am

Fantastic - what a come back!

marcbartels
Posts: 7
Joined: Wed Aug 23, 2006 10:28 pm
Location: Hannover, Germany

Post by marcbartels » Sat Nov 08, 2008 1:55 am

If you add an exponent map the exponent constant from the top should be removed.

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Sat Nov 08, 2008 2:06 am

fixed. i guess...
Check normals, dude!

Image
Image

enricocerica
Indigo 100
Posts: 155
Joined: Wed Jul 12, 2006 5:26 pm

Post by enricocerica » Sat Nov 08, 2008 4:40 am

Ok SmartDen, it seems to work fine now, I mean "bump in blend" and exponent/bump maps . Thanks.

Here is something I forgot to mention, instances ( Copy with ALT D) are not well managed and it seems that, at least the rotations are not applied during the export process, don't know if other transformations are concerned. This was the case in the release I used yesturday, don't know if you fixed it in the recent releases.

One great thing which I think existed previously is the ability to limit the material menu to the materials linked to the selected objects, when the amout of materials is huge, you must rename them to be able to select them in the menu :?

Thanks again for your job

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Sun Nov 09, 2008 11:32 pm

Small bugreport:

Blendigo v1.1.13 wont start if no object is selected.

Code: Select all

Traceback (most recent call last):
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 3547, in event
    materialEvent(evt, val) # zuegs: added material editor
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 1553, in materialEvent
    if (activeObject != obj) or (activeObjectMat0 != mat0):
NameError: global name 'activeObjectMat0' is not defined
thanks for your work SmartDen :wink:

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Sun Nov 09, 2008 11:39 pm

Small bugreport the second:

Blendigo writes the thread option in the wrapper file even if "auto threads" in blendigo is activated.

Code: Select all

nice -n 20 wine indigo.exe "../../Desktop/icecubes.igs"-t 1
happy rendering :wink:

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Mon Nov 10, 2008 12:41 am

manitwo wrote:Small bugreport the second:

Blendigo writes the thread option in the wrapper file even if "auto threads" in blendigo is activated.

Code: Select all

nice -n 20 wine indigo.exe "../../Desktop/icecubes.igs"-t 1
happy rendering :wink:
i guess you have not the latest version. i updated pretty often last time. download the py file and try it again, please.
Check normals, dude!

Image
Image

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Mon Nov 10, 2008 12:50 am

SmartDen wrote:
manitwo wrote:Small bugreport the second:

Blendigo writes the thread option in the wrapper file even if "auto threads" in blendigo is activated.

Code: Select all

nice -n 20 wine indigo.exe "../../Desktop/icecubes.igs"-t 1
happy rendering :wink:
i guess you have not the latest version. i updated pretty often last time. download the py file and try it again, please.
You're right SmartDen, my fault :oops:
works great!

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Mon Nov 10, 2008 1:04 am

still you get this error?

Code: Select all

Traceback (most recent call last):
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 3547, in event
    materialEvent(evt, val) # zuegs: added material editor
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 1553, in materialEvent
    if (activeObject != obj) or (activeObjectMat0 != mat0):
NameError: global name 'activeObjectMat0' is not defined
i cann't reproduce it
Check normals, dude!

Image
Image

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Mon Nov 10, 2008 1:12 am

SmartDen wrote:still you get this error?

Code: Select all

Traceback (most recent call last):
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 3547, in event
    materialEvent(evt, val) # zuegs: added material editor
  File "/home/blabla/.blender/scripts/blendigo_v1113.py", line 1553, in materialEvent
    if (activeObject != obj) or (activeObjectMat0 != mat0):
NameError: global name 'activeObjectMat0' is not defined
i cann't reproduce it
yes, try this to reproduce:
- make a new object (a plane or something)
- delete that object so nothing is seleced (also make sure nothing is highlighted in the outliner)
- try to start blendigo

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Mon Nov 10, 2008 1:50 am

it looks like blackbody support of the emitters has been dropped?

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Mon Nov 10, 2008 3:24 am

manitwo wrote:it looks like blackbody support of the emitters has been dropped?
not realy, i just overseen it in the documentation :oops: will add it tomorrow
Check normals, dude!

Image
Image

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Mon Nov 10, 2008 3:56 am

SmartDen wrote:not realy, i just overseen it in the documentation :oops: will add it tomorrow
hehe, no rush 8)

Post Reply
131 posts

Who is online

Users browsing this forum: DotBot [Bot] and 3 guests