Indigo Renderer 4.2.23 Stable Release Candidate

General News and accouncements regarding the Indigo render engine
User avatar
pixie
Indigo 100
Posts: 2198
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by pixie » Wed Feb 13, 2019 5:07 am

Once it is though... it would make indigo king of interiors! :D
I had tested thea GPU and, whereas on indigo we have unbiased on gpu they have a lite version for GPU. My 2080 is about on par then my Ryzen 1800x, a bit faster, and on indigo I have values between 6 to 10 times as fast

User avatar
pixie
Indigo 100
Posts: 2198
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by pixie » Thu Feb 14, 2019 5:36 am

The latest Nvidia drivers (418.91) brought indigo to an halt in major complex scenes on my RTX 2080. It did render, but I wasn't allowed to touch the ui. it seems to be due to drivers since I reverted it seems to be working fine.

Legos2112
Posts: 10
Joined: Thu Dec 13, 2018 12:35 am
Location: Venezuela
3D Software: SketchUp
Contact:

Upgrade GPU

Post by Legos2112 » Thu Feb 14, 2019 6:36 pm

Hi! I want to upgrade my GPU
Right now I have a FirePro v5900 a professional card but an old one.

I was thinking about a Vega 56 or a Radeon Rx 580 maybe a GTX 1080.

My budget's 400$ top!

What do you suggest would be the best card for indigo? In this price range? Of if there's any other better card in this range please let me know!.

User avatar
Zom-B
1st Place 100
Posts: 4641
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Zom-B » Fri Feb 15, 2019 9:43 pm

best to check out the Benchmark page and compare by yourself:
https://www.indigorenderer.com/benchmark-results

The new 2080Ti is a beast beating the 1080Ti by +60% in performance, maybe the lower tier Nvidia 20XX cards could be nice.

Besides raw performance GPU RAM is also VERY important if you have more complex scenes...

User avatar
pixie
Indigo 100
Posts: 2198
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by pixie » Sat Feb 16, 2019 2:36 am

I bought a 2080 because in the future I may add another and through nvlink get extra ram, otherwise I would probably get a lower card

User avatar
pixie
Indigo 100
Posts: 2198
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by pixie » Sat Feb 16, 2019 3:46 am

in some scenes my computer just crashes with the lates 418.81 and hangs with 418.91, no luck for me then.

Legos2112
Posts: 10
Joined: Thu Dec 13, 2018 12:35 am
Location: Venezuela
3D Software: SketchUp
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Legos2112 » Sat Feb 16, 2019 5:15 am

Zom-B wrote:
Fri Feb 15, 2019 9:43 pm
best to check out the Benchmark page and compare by yourself:
https://www.indigorenderer.com/benchmark-results

The new 2080Ti is a beast beating the 1080Ti by +60% in performance, maybe the lower tier Nvidia 20XX cards could be nice.

Besides raw performance GPU RAM is also VERY important if you have more complex scenes...

nice, i will check it out!

burnin
Posts: 116
Joined: Tue May 04, 2010 2:53 pm

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by burnin » Sat Feb 16, 2019 10:50 am

pixie wrote:
Sat Feb 16, 2019 3:46 am
in some scenes my computer just crashes with the lates 418.81 and hangs with 418.91, no luck for me then.
Yup, seen few users reporting OCL issues with the latest (418.81) NVidia drivers. Simply roll back to the last working version.

User avatar
Lal-O
2nd Place Winner
Posts: 293
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Lal-O » Tue Feb 19, 2019 5:17 pm

Hi Guys :)

Ok, So...I've been working (a lot) with this new version and i've noticed something weird.

I don't know if this is an old and known issue but i'm getting way different results from the same scene with same settings. The result varies when using BiDir MLT or GPU Path Tracing and the problem is with tree models ( leaves with alpha maps) they look weird with GPU, they seem to be like the leaves were duplicated.

I've increased the Max Path Depth from the default 8 to 30/50 but no luck.

( The attached images are previews : P )
Attachments
GPU Path Tracing.jpg
Bidirect.jpg

User avatar
Zom-B
1st Place 100
Posts: 4641
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Zom-B » Tue Feb 19, 2019 9:12 pm

This still looks like a raydepth issue. give 99 a try (it should at least get "better")
The point with foliage like this is that there are quickly so many alpha mapped leaves behind each other, that also do reflect light between each other that such darkening can happen with "low" values of 30 or 50...

User avatar
Lal-O
2nd Place Winner
Posts: 293
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Lal-O » Wed Feb 20, 2019 2:53 pm

Zom-B wrote:
Tue Feb 19, 2019 9:12 pm
This still looks like a raydepth issue. give 99 a try (it should at least get "better")
The point with foliage like this is that there are quickly so many alpha mapped leaves behind each other, that also do reflect light between each other that such darkening can happen with "low" values of 30 or 50...
Thx for the reply Zom-B ! Problem solved!

8 is the Indigo's default value, so i thought that 50 could be more than enough...To use 99 would never cross my mind, mainly because 32 was working fine to me so far, that is why i reported this as a "bug" sorry about it :P

User avatar
Lal-O
2nd Place Winner
Posts: 293
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Lal-O » Fri Feb 22, 2019 9:15 am

Ok , so...

I think i rushed up myself a little with my last post about the transparency in foliage maps...i've made some other test with 100 value in the Max Path Depth and it does change noticeable , but still looks way better using CPU, plus the rendering times increased almost like if i were using the CPU but with" bad" results.

So i have to ask , is this an issue that will be solved later or is something we must deal with if we want to use GPU?

User avatar
Lal-O
2nd Place Winner
Posts: 293
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Lal-O » Fri Feb 22, 2019 9:29 am

Oh , by the way, i think i found a bug ( i am sure this time it is : P ).

In indigo ,in the environment section,if i switch from SUN+SKY to ENVIRONMENT MAP, the rendering screen gets divided and no fix for using the environment map , is necesary to re-export the scene or switch back to SUN+SKY (This is only in GPU mode).
Attachments
Weird Screen.jpg

User avatar
Zom-B
1st Place 100
Posts: 4641
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by Zom-B » Fri Feb 22, 2019 6:48 pm

Lal-O wrote:
Fri Feb 22, 2019 9:15 am
So i have to ask , is this an issue that will be solved later or is something we must deal with if we want to use GPU?
Yes, GPU is atm not the best choice if you have alpha mapped leaves in trees. passing through this null medium of each leave is eating up the available raydepth crazy fast...

Regarding the bug you posted this is afaik a known issue if you change scene parameters early after GPU render started and the image is still rendered in subpixel resolution.
Double check by having your render cook for a few minutes before changing the parameters, it shouldn't happen then.

User avatar
pixie
Indigo 100
Posts: 2198
Joined: Sat Dec 29, 2007 4:54 am
Location: Away from paradise
Contact:

Re: Indigo Renderer 4.2.23 Stable Release Candidate

Post by pixie » Wed Feb 27, 2019 9:48 pm

I've got some random lockups, even if I only load igis after a while the UI locks up. I've tried different drivers, they somehow work for a time when they work but eventually it locks up.

Post Reply
74 posts

Who is online

Users browsing this forum: No registered users and 0 guests