SkIndigo 3.2.2 (beta)

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Jeff Hammond
Indigo 100
Posts: 105
Joined: Sun Oct 11, 2009 11:30 am
Location: newyorkcity

Re: SkIndigo 3.2.2 (beta)

Post by Jeff Hammond » Sun Nov 27, 2011 1:04 pm

Whaat wrote: #Version 3.2.2

#Fixed: mesh errors due to float export bug introduced in version 3.2.0



Mac build coming soon...
i think i'm getting this error with an image i'm working on today..

the geometry is clean.. just rendering funny.. curious to see if the mac 3.2.2 will correct it..
weird.jpg

User avatar
Whaat
Developer
Posts: 1824
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: SkIndigo 3.2.2 (beta)

Post by Whaat » Mon Nov 28, 2011 10:03 am

I appreciate the error reports guys but I really need a SKP file for testing. I have not been able to reproduce this bug myself.

User avatar
Whaat
Developer
Posts: 1824
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: SkIndigo 3.2.2 (beta)

Post by Whaat » Mon Nov 28, 2011 10:05 am

Pibuz wrote:Hi Dale!

I fear the autosmoothing has still not been fixed.. I run the following rendering overnight and I got one smoothed surface, circled in red in the image below. No smoothing was applied to the original geometry.

I isolated the surface by hiding the rest of the geometry, and the problem was still there (see first render attached); then I thought to send the file to you, so I actually deleted all the geometry but the one causing broblems: the new file rendered correctly... :?
Does exploding the model, fix the smoothing issue?

Try to send me the SKP file with all of the unnecessary geometry deleted (but do not explode any of the groups that contain the 'bad' geometry)

Thanks!

Jeff Hammond
Indigo 100
Posts: 105
Joined: Sun Oct 11, 2009 11:30 am
Location: newyorkcity

Re: SkIndigo 3.2.2 (beta)

Post by Jeff Hammond » Mon Nov 28, 2011 10:46 am

Whaat wrote:I appreciate the error reports guys but I really need a SKP file for testing. I have not been able to reproduce this bug myself.
here's a .skp with the trouble area isolated.. render as is and you'll see the error..
thanks

skindigo_error.zip
(42.29 KiB) Downloaded 65 times

User avatar
Whaat
Developer
Posts: 1824
Joined: Fri Dec 22, 2006 6:15 am
Location: Canada
Contact:

Re: SkIndigo 3.2.2 (beta)

Post by Whaat » Tue Nov 29, 2011 2:40 am

Jeff Hammond wrote:
Whaat wrote:I appreciate the error reports guys but I really need a SKP file for testing. I have not been able to reproduce this bug myself.
here's a .skp with the trouble area isolated.. render as is and you'll see the error..
thanks

skindigo_error.zip
Thanks Jeff,

This is proving to be a difficult issue to resolve.

I found that if I made the geometry a component and made sure the axis was not at the world origin, the problem was resolved. Can anyone confirm? (at least it might be a workaround until the bug is fixed)

User avatar
snorky
Indigo 100
Posts: 313
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.2.2 (beta)

Post by snorky » Tue Nov 29, 2011 10:39 pm

Whaat wrote:This is proving to be a difficult issue to resolve.
...redraw "wrong" side of face
I have reproduced the error, this happens when one side is made ​​up of many small segments instead of one and triangle (face) is tight ad long.

sorry for my bad explanation...

Jeff Hammond
Indigo 100
Posts: 105
Joined: Sun Oct 11, 2009 11:30 am
Location: newyorkcity

Re: SkIndigo 3.2.2 (beta)

Post by Jeff Hammond » Wed Nov 30, 2011 3:17 am

Whaat wrote: This is proving to be a difficult issue to resolve.

I found that if I made the geometry a component and made sure the axis was not at the world origin, the problem was resolved. Can anyone confirm? (at least it might be a workaround until the bug is fixed)
yeah, that worked for me after a couple of tries (rotated 5º and nothing then rotated again 5º and it fixed)

i also had some luck with grouping then soften/smooth to 0 and back up to 30ish.. clicking and unclicking smooth normals/soften coplanar..

i haven't found an exact set of steps i can follow every time in order to make it go away.
it's all quite finicky.


snorky wrote: ...redraw "wrong" side of face
I have reproduced the error, this happens when one side is made ​​up of many small segments instead of one and triangle (face) is tight ad long.

sorry for my bad explanation...
dunno snorky.. that file i posted is showing the error on decent sized rectangles.. i've seen what you're talking about before but i don't think it's the problem here.

User avatar
snorky
Indigo 100
Posts: 313
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.2.2 (beta)

Post by snorky » Wed Nov 30, 2011 4:19 am

Jeff Hammond wrote:on decent sized rectangles..
...
is this the error?
2_.jpg
error
thi is my solution:
A_.jpg
corrected side

Jeff Hammond
Indigo 100
Posts: 105
Joined: Sun Oct 11, 2009 11:30 am
Location: newyorkcity

Re: SkIndigo 3.2.2 (beta)

Post by Jeff Hammond » Wed Nov 30, 2011 5:52 am

snorky wrote: ...
is this the error?

yeah, that's it.. i wonder how this can be dealt with in sketchup or skindigo because in sketchup, we don't have those triangles and all the faces appear to be coplanar.

what exactly did you do to fix the model? (did you do something in sketchup or in indigo?)

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.2.2 (beta)

Post by Pibuz » Wed Nov 30, 2011 8:14 am

Hey Dale!
I tried to link an external 3ds but I don't get the "missing material" window anymore: is that correct or it should always be displayed (so this is a small bug)?

User avatar
snorky
Indigo 100
Posts: 313
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.2.2 (beta)

Post by snorky » Wed Nov 30, 2011 8:38 am

use style's endpoints to see if model's sides are made with a sigle line-side or not... if check redraw it.
Jeff Hammond wrote:yeah, that's it.. i wonder how this can be dealt with in sketchup or skindigo because in sketchup, we don't have those triangles and all the faces appear to be coplanar.

what exactly did you do to fix the model? (did you do something in sketchup or in indigo?)

Jeff Hammond
Indigo 100
Posts: 105
Joined: Sun Oct 11, 2009 11:30 am
Location: newyorkcity

Re: SkIndigo 3.2.2 (beta)

Post by Jeff Hammond » Wed Nov 30, 2011 12:59 pm

snorky wrote:use style's endpoints to see if model's sides are made with a sigle line-side or not... if check redraw it.
yay! that does in fact fix it.. and fredo happens to have a nifty little ruby that will take care of all the lonely vertices in a model.. the example .skp i posted actually has 27(!) of them..

get the plugin here:
http://forums.sketchucation.com/viewtopic.php?t=37619

thanks snorky!

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.2.2 (beta)

Post by Pibuz » Wed Nov 30, 2011 8:08 pm

My model does not have any double line or anything, but sometimes I get black artifacts as well.. :?

User avatar
Pibuz
1st Place 100
Posts: 2607
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.2.2 (beta)

Post by Pibuz » Wed Nov 30, 2011 8:30 pm

..BTW, I tried the external mesh link error that I reported yesterday: OBJs from TreeD seem to work just fine, but I have problems with this mesh, can anyone test it? Maybe it's an export bug..
Attachments
Bokka ceiling.rar
(305.22 KiB) Downloaded 98 times

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: SkIndigo 3.2.2 (beta)

Post by CTZn » Wed Nov 30, 2011 8:42 pm

Hi Pibuz, issues are into the design probably: two halves nearly separated by two larce slices of a different density, either you accept this as the original design or you do some face level reconstruction (if possible).
obsolete asset

Post Reply
66 posts

Who is online

Users browsing this forum: No registered users and 1 guest