IndigoMax 0.3.11

Announcements, requests and support regarding the 3DS MAX exporter
Post Reply
14 posts • Page 1 of 1
User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

IndigoMax 0.3.11

Post by subpixel » Thu Feb 06, 2014 12:02 pm

Hello all,

Here's a small batch of fixes for IndigoMax. Thanks to all who have contributed.

Changes:
  • Added: initial support for ForestPack plugin
  • Added: initial support for MultiScatter plugin
  • Added: static MaxScript interface IndigoMax for mesh exports
  • Added: support for missing render passes
  • Fixed: Issue when Indigo settings property tab was blocking other tabs until it was displayed
  • Added: IM_Mesh object
  • Fixed: File selector for external material has PIGS as an option instead of PIGM
  • Added: metadata node for exported scenes
  • Done: Renderer name includes version number
  • Fixed: In some cases material editor previews are white
Download:
IndigoMax 0.3.11
IndigoMax RT 0.3.11

Notes:
Versions: max2011 / 2012 / 2013 / 2014 64bit.
This version introduced a static MaxScript Interface "IndigoMax". For more information use command:

Code: Select all

showInterface IndigoMax
Hope for some comments, suggestions and descriptive bug reports. Please post them in this thread or send PM.

Cheers,
Jake

User avatar
lycium
Posts: 1208
Joined: Wed Sep 12, 2007 7:46 am
Location: Leipzig, Germany
Contact:

Re: IndigoMax 0.3.11

Post by lycium » Thu Feb 06, 2014 2:08 pm

Awesome to see the ForestPack + MultiScatter support, looking forward to seeing what people make with it!

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: IndigoMax 0.3.11

Post by subpixel » Thu Feb 06, 2014 8:20 pm

lycium wrote:looking forward to seeing what people make with it!
Same here.

Please note that support is still a bit limited, as some features like material tinting will need specialized texture node and some ISL shaders, which will be added with ISL support.
Anyway, I'm always open to suggestions and comments.

kdarius
Posts: 108
Joined: Fri Jun 12, 2009 5:00 am

Re: IndigoMax 0.3.11

Post by kdarius » Thu Jul 24, 2014 7:36 am

any word on how this progress is coming?

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: IndigoMax 0.3.11

Post by subpixel » Thu Jul 24, 2014 8:50 pm

I was preoccupied with some other issues, sorry about that.
I have prepared a new version, where Indigo is registered as ActiveShade renderer, which makes processing mode combo deprecated, also it solved issues with MXS floater window. I have also implemented support for PFlow systems.
There are still some issues that need some more attention. Will keep you informed.

User avatar
Zom-B
1st Place 100
Posts: 4691
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: IndigoMax 0.3.11

Post by Zom-B » Wed Aug 13, 2014 10:05 pm

out of curiosity, any news here?
polygonmanufaktur.de

User avatar
thesquirell
Posts: 412
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: IndigoMax 0.3.11

Post by thesquirell » Fri Aug 29, 2014 7:02 am

I managed to use Multiscatter with success, but when using MultiPainter IndigoMax Scene Error generates this message:

"Model (UID 12, name 'MultiPainter_001') has a different number of materials assigned than the geometry references.
num materials assigned: 0, geometry num materials referenced: 1. SDK Users: make sure you call endOfModel() on IndigoMesh objects."

tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

Re: IndigoMax 0.3.11

Post by tar_gniK » Fri Sep 26, 2014 9:26 pm

Opacity maps - where is the option for this? I know already that if you have a texture that has an alpha channel, then it will use that, but I have a lot of textures that come with an opacity map, and I don't know where to place them.

Another question - any reason why sometimes when you create an object, apply a texture to it (often a flat colour), it then comes out pink, ala Blender? I usually fix this by applying a UV Map, but it is rather annoying.

There is also an error I get often that "the vertex index order is out of bounds" or similar, I then have to convert to Editable Mesh then Poly to solve it. In the meantime, I have lost all of my modifiers. This is super annoying, especially when you have a large scene, and then I have to go hunting through the model for the offending object.

Also, I am having colour issues with IndigoMax, what I specify does not seem to be what is rendered externally. For example a dark grey/black with RGB 25,25,25 comes out grey in the renderer like almost 50,50,50 - same applies to nearly all other colours. I am not sure if this a gamma issue, camera exposure setting or what.

There is also a bug where if you render a scene, then close Max, Max always crashes to desktop.

Correspondence would be appreciated, thanks.

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: IndigoMax 0.3.11

Post by subpixel » Sat Sep 27, 2014 4:45 pm

Hi tar_gnik,

Opacity maps should be set as blend texture for blend material with one of submaterials set to desired base material and other left empty (it defaults to Null material). This is a common Indigo workflow.

This pink color means that something is wrong. In your case you set a texture, but UV data is missing. Also it could mean that texture file is missing. I could add a popup window with warning, like scanline renderer does, but I find them annoying. Anyway, in new version there's a log window, with Indigo messages and these warnings, so it should be more obvious now.

There are separate implementations for Editable Mesh and Polys (as first one is exported as triangles only), however I haven't had this kind of error before. Could you please send a simple reproduction scene, or write reproduction steps, please?

Your problem with colors, indeed seems to be gamma related. Did you enable gamma correction in Max? Did you enable it for color sliders?

I haven't had report about crash on Max close yet, thank you. Could you tell me what version do you use (IndigoMax / Max)?

Thank you.

tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

Re: IndigoMax 0.3.11

Post by tar_gniK » Sat Sep 27, 2014 11:19 pm

Thanks for the reply.

I am currently using 3dsMax 2012 SP1, with IndigoMax 0.3.11 and Indigo Renderer 3.89. The crash is more prevalent on larger scenes - let's say 3/10 times a crash will occur, but I don't think it could be a RAM issue; I have 16GB, and it doesn't happen with other exporters.

That error message is quite difficult to reproduce, I don't know when it most likely to occur. As mentioned before, I either have to undertake trial and error to find the object that is causing the problem, or simply create a backup with my modifiers still active, and then create a new copy and flatten the modifiers down. Both interactive and export option make no difference. For reference, I model using Editable Poly.

I have gamma disabled, currently, but I don't get colour reproduction issues with Maxigo etc.

Regarding opacity maps, thanks for that, I was just used to a defined opacity channel in previous exporters.
Attachments
error2.png
error.png

User avatar
Jay-ko
Posts: 137
Joined: Mon Nov 12, 2012 7:28 pm
Location: Paris

Re: IndigoMax 0.3.11

Post by Jay-ko » Mon Sep 29, 2014 11:31 pm

For the first one, it's something wrong about materials ID.

Perhaps you use only the ID 2 without using the ID 1.

Indigo cannot use something with multi/sub IDs with noting in the materials* or with jump like 1 and 99.


*: in fact with 3.8 it could assign a "pink" default material but not in all the case.


I recommend you to isolate the object that create the bug, and to correct the material IDs without "jumps".
If that do not work, You could create a new object, convert in poly Edit, then attach the wrong object to the new one, then delete the new one (I often use an simply box); then go to tools and add a reset xForm.

And finaly collapse all the modifiers to transform it into a Poly Edit.

The second on is a defect of the exporter to create the igmesh I think. You convert your object to a new on with the same method that I described before (attach the wrong object to a new one ect...)

It works in all the cases.
errare humanum est

tar_gniK
Posts: 152
Joined: Wed Apr 13, 2011 7:36 pm
Location: London, UK
3D Software: 3ds Max
Contact:

Re: IndigoMax 0.3.11

Post by tar_gniK » Tue Sep 30, 2014 7:56 am

Jay-ko wrote:For the first one, it's something wrong about materials ID.

Perhaps you use only the ID 2 without using the ID 1.

Indigo cannot use something with multi/sub IDs with noting in the materials* or with jump like 1 and 99.


*: in fact with 3.8 it could assign a "pink" default material but not in all the case.


I recommend you to isolate the object that create the bug, and to correct the material IDs without "jumps".
If that do not work, You could create a new object, convert in poly Edit, then attach the wrong object to the new one, then delete the new one (I often use an simply box); then go to tools and add a reset xForm.

And finaly collapse all the modifiers to transform it into a Poly Edit.

The second on is a defect of the exporter to create the igmesh I think. You convert your object to a new on with the same method that I described before (attach the wrong object to a new one ect...)

It works in all the cases.
Thanks for the advice, I already make sure my multi-sub material order is n + 1 , 2, 3 etc, but isolating the object is a problem in itself. If I have gone to the effort of naming my objects and maintaining an organised scene, but an error can't give me the location of the problem straight away, then it is like a kick in the teeth.

User avatar
Jay-ko
Posts: 137
Joined: Mon Nov 12, 2012 7:28 pm
Location: Paris

Re: IndigoMax 0.3.11

Post by Jay-ko » Thu Dec 04, 2014 2:07 am

PLEASE, do a release for 3ds max 2015
errare humanum est

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: IndigoMax 0.3.11

Post by subpixel » Thu Dec 04, 2014 9:56 pm

Will do. Thanks.

Post Reply
14 posts • Page 1 of 1

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests