Blendigo 2.4.x Releases

Announcements, requests and support regarding the Blender Indigo export script
StompinTom
Indigo 100
Posts: 1797
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.4.x Releases

Post by StompinTom » Tue Aug 24, 2010 3:26 am

Thank you so much, Doug!!! Will test it as soon as I get the chance!

StompinTom
Indigo 100
Posts: 1797
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.4.x Releases

Post by StompinTom » Thu Aug 26, 2010 2:40 am

Small note:

When exporting particle systems with their size controlled by vertex groups/weight painting, I seem to be getting an error about the transform matrix not being invertible when there are particles with size 0. Would it be worth having Blendigo check for objects with size 0 on export and skipping them to prevent this?

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Thu Aug 26, 2010 2:56 am

StompinTom wrote:Small note:

When exporting particle systems with their size controlled by vertex groups/weight painting, I seem to be getting an error about the transform matrix not being invertible when there are particles with size 0. Would it be worth having Blendigo check for objects with size 0 on export and skipping them to prevent this?
That sounds possible, I will have a look.

User avatar
cooler_inc
2nd Place Winner
Posts: 158
Joined: Mon Aug 14, 2006 10:21 pm
Location: Ukraine, Donetsk
Contact:

Re: Blendigo 2.4.x Releases

Post by cooler_inc » Sat Aug 28, 2010 1:46 am

sorry for stupid question, maybe I do smth wrong, but after tuning up the materials with textures, saving and quiting blender - I open this blend file and see that materials where channel type should be set like "Texture" is set to "Colour". Why it happens?

User avatar
Headroom
Indigo 100
Posts: 972
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo 2.4.x Releases

Post by Headroom » Sat Aug 28, 2010 3:34 am

No stupid question at all.

However, if you render, the texture is still applied.
If you change "color" to "texture" you'll see that "filename" still still contains the path to the texture image.

It can be quite annoying this little bug :roll:

User avatar
cooler_inc
2nd Place Winner
Posts: 158
Joined: Mon Aug 14, 2006 10:21 pm
Location: Ukraine, Donetsk
Contact:

Re: Blendigo 2.4.x Releases

Post by cooler_inc » Sat Aug 28, 2010 8:38 pm

Headroom wrote:No stupid question at all.

However, if you render, the texture is still applied.
If you change "color" to "texture" you'll see that "filename" still still contains the path to the texture image.

It can be quite annoying this little bug :roll:
U r right, thx :D

|MM|
Posts: 20
Joined: Wed Mar 10, 2010 9:37 am

Re: Blendigo 2.4.x Releases

Post by |MM| » Tue Sep 07, 2010 10:05 am

How do I render hair particles (hair particle instanced objects).
Is it impossible or am I missing something?
I could render only the emitter type.

User avatar
dakiru
Indigo 100
Posts: 745
Joined: Mon Jun 22, 2009 6:51 am

Re: Blendigo 2.4.x Releases

Post by dakiru » Tue Sep 07, 2010 10:36 pm

|MM| wrote:How do I render hair particles (hair particle instanced objects).
Is it impossible or am I missing something?
I could render only the emitter type.
As far as I know it's not possible yet. But you can use emitter particle system to achieve the needed effect and particles should be meshes.

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am
Contact:

Re: Blendigo 2.4.x Releases

Post by dag » Wed Sep 15, 2010 5:28 am

Get the same runtime error when starting blendigo as with LuxBlend, but stuff works. You develop both?
Upgraded 2.4.5 > 2.4.8

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Wed Sep 15, 2010 8:15 am

dag wrote:Get the same runtime error when starting blendigo as with LuxBlend, but stuff works. You develop both?
Upgraded 2.4.5 > 2.4.8
What error exactly? I've seen quite a few different ones over the last few months :lol:

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am
Contact:

Re: Blendigo 2.4.x Releases

Post by dag » Wed Sep 15, 2010 2:03 pm

http://www.luxrender.net/forum/viewtopi ... =11&t=3205

Using 64 bit blender. Blendigo installed in C:\Program Files\Blender Foundation\Blender\.blender\scripts

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Thu Sep 16, 2010 5:59 am

dag wrote:http://www.luxrender.net/forum/viewtopi ... =11&t=3205

Using 64 bit blender. Blendigo installed in C:\Program Files\Blender Foundation\Blender\.blender\scripts
You really could try to provide some specific details of your system. However, having read through that LuxRender thread the problem was found to be the use of the socket python library with regards to materials database integration and 64-bit windows environments.

Blendigo should in fact disable that part of the code on windows 64 bit (and has done so for quite a while now), and indeed everything works for me using a 64bit windows setup. (In fact, I do most blendigo development using 64bit win, 64bit blender and 64bit python installed).

Now for the boring questions.... which version of blendigo do you have installed? Which version(s) (if any) of python do you have installed? Which release of blender are you using (official 64bit 2.49b?) ?

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.4.x Releases

Post by dougal2 » Thu Sep 16, 2010 6:13 am

New feature coming really really soon.... (right click the image, press play ;) )

(particle instance motion blur)

User avatar
dakiru
Indigo 100
Posts: 745
Joined: Mon Jun 22, 2009 6:51 am

Re: Blendigo 2.4.x Releases

Post by dakiru » Thu Sep 16, 2010 6:59 am

dougal2, this rocks! Great work 8)

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am
Contact:

Re: Blendigo 2.4.x Releases

Post by dag » Thu Sep 16, 2010 9:51 am

dougal2 wrote: Now for the boring questions.... which version of blendigo do you have installed? Which version(s) (if any) of python do you have installed? Which release of blender are you using (official 64bit 2.49b?) ?
Using blendigo 2.4.10 now. All I've done is upgrade blendigo.
Most likely installed blender 2.49b 32 bit in C:\Program Files\Blender Foundation\Blender then overwrote with the 64 bit files since there is no installer for it.
Python 2.6.1 64 bit.
Win 7 ultimate 64 bit.

Code: Select all

Compiled with Python version 2.6.1.
Checking for installed Python... got it!

----------------------
BLENDIGO v2.4.10
----------------------
  Platform             : post2008Server 6.1.7600  Multiprocessor Free
  os.sep               : \
  Indigo path          : C:\Program Files\Indigo Renderer\indigo.exe
  matdbPreviews        : C:\Program Files\Blender Foundation\Blender\.blender\sc
ripts\blendigopkg\matdb\previews
  assetsPath           : C:\Program Files\Blender Foundation\Blender\.blender\sc
ripts\blendigopkg\assets
  matdbDownloads       : C:\Program Files\Blender Foundation\Blender\.blender\sc
ripts\blendigopkg\matdb


Talking about particles... why won't they emit light? Group visualization. Only the source object emits light. Particles render with the same material but without light emission.

Post Reply
76 posts

Who is online

Users browsing this forum: No registered users and 1 guest