Page 1 of 1

Bump map trouble

Posted: Thu Feb 04, 2010 4:27 pm
by dag
I'm not sure if this is a blendigo issue, but I'm trying to make a wheel, and have some weird issue with the bump map.
I've made a quick mesh from scratch with the same problem.

Blender 2.49a (same with b), blendigo 2.3.1, indigo 2.2.

Blend: http://www.home.no/faenskap/wtf.blend
Bump map: http://www.home.no/faenskap/yokobump.png

What the fish is going on? Check the attachments.

Re: Bump map trouble

Posted: Thu Feb 04, 2010 11:41 pm
by Meelis
Displace is too strong, set it maybe 0.001 - 0.002 or soo (= 1 - 2 mm for font),
and displace needs mutch higher geometry, subdivide displaced area.

Re: Bump map trouble

Posted: Fri Feb 05, 2010 12:05 am
by benn
Increase the subdivision parameter for the displacement channel.

I cant remember how to do that - but hopefully Soup or Dougal will pop in here..

Re: Bump map trouble

Posted: Fri Feb 05, 2010 3:32 am
by dag
The point was to show what happens to the rest of the mesh, not the displacement.
I'm talking about the weird pattern when using only the bump map.
Every face gets a circle on it when rendered.

Here's some high geometry renders.
Blender modifiers applied.
Subd smoothing off in blendigo.

Re: Bump map trouble

Posted: Fri Feb 05, 2010 5:51 am
by Meelis
:? This pattern goes like 1 per 1 face.

What if u lower bump value <b>0.0001</b> <b>0.001</b>
Is the bump over sides or the whole tire, is there multible materials for same faces (under F9), delete those what's not assigned.

Is the object scale 1 (Ctrl+A in OB mode)

Re: Bump map trouble

Posted: Fri Feb 05, 2010 6:01 am
by Silmä
I think blenders default uv-mappping is to have full image for each quad. As you haven't uv-mapped the rest of the tire, each quad has the whole circular bump-map you've made for the side.

You'll need to unwrap the whole tire to get rid of those circles.

Here's an example

Re: Bump map trouble

Posted: Fri Feb 05, 2010 6:15 am
by dag
Ok, that's it.
I forgot that I deleted one of the materials to try with only one on the whole tire, without unwrapping the whole thing, then updated blendigo, then wasted a whole day on this, then.... :oops: