Blendigo 2.3.x test releases

Announcements, requests and support regarding the Blender Indigo export script
Locked
128 posts
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Sun Mar 14, 2010 8:04 am

I haven't yet addressed many issues in this thread. I hope that towards the end of this month I will have some time available to make another release.

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Blendigo 2.3.x test releases

Post by Borgleader » Sun Mar 14, 2010 9:04 am

Is it possible to just use an older version of the script or perhaps manually fix it?
benn hired a mercenary to kill my sig...

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Sun Mar 14, 2010 9:21 am

Borgleader wrote:Is it possible to just use an older version of the script or perhaps manually fix it?
Yes, use 2.2 stable instead.

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Blendigo 2.3.x test releases

Post by Borgleader » Sun Mar 14, 2010 10:08 am

dougal2 wrote:
Borgleader wrote:Is it possible to just use an older version of the script or perhaps manually fix it?
Yes, use 2.2 stable instead.
Alright thanks :)
benn hired a mercenary to kill my sig...

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Wed Mar 17, 2010 3:46 am

Doug Armand wrote:Error%nBroken installation of Blendigo, please reinstall
Abort
For anyone still experiencing the above error message, I would like to know what the error message printed on the console says.
The error is supposed to occur if blendigo cannot find any of its sub-module code, but if it works properly after the error message then something is not right.
(Did you guys install 2.3.x alongside a 2.2 stable?)

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Wed Mar 17, 2010 3:52 am

Doug Armand wrote:I'm sure you know this already but that irritating error:
Error%Broken installation of Blendigo, please reinstall
Abort


occurs everytime I use undo in blender, if you have a few steps to undo it fires off for each one - it's f*%king irritating :evil:
Interesting that Blender seems to reload the script window on the undo event. Sorry, that 'feature' is not my fault, but if you keep getting these errors I think your installation is broken.

EDIT: This is likely a windows UAC problem, a potential solution is to install blendigo in your home folder, and not inside 'Program Files' :idea:

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Wed Mar 17, 2010 4:32 am

All these will be fixed in next release:
StompinTom wrote:There is no toggle to switch between post-process aperature diffraction and true aperature diffraction...
StompinTom wrote:- Even when exporting without Sun/Sky enabled, Sun and Sky lightgroups appear. The IGS file has Sun and Sky lightgroup definitions everywhere, between materials, then again after materials, etc.
dag wrote:If you hit the mesh or material tab 2 times, it switches back to the window you previously were in, but the buttons stay pressed.
In that case, I shall name the first layer 'environment'
the 1st light layer will always be named 'Environment' so that the background colour has its own layer. The 'default' layer, sun, sky and all custom layers will follow after this one.
-------------------------------------

I require further information about these:
StompinTom wrote:Problems with circular aperature shape here as well.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Fri Mar 19, 2010 10:08 am

EDIT: updated to 2.3.3, see next page

User avatar
dakiru
Indigo 100
Posts: 746
Joined: Mon Jun 22, 2009 6:51 am

Re: Blendigo 2.3.x test releases

Post by dakiru » Fri Mar 19, 2010 10:28 am

[quote="dougal2"MOD EDIT: removed due to update[/quote]

Great, thank you, right in time :D

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Fri Mar 19, 2010 11:40 am

dakiru wrote:
dougal2 wrote:MOD EDIT: updated
Great, thank you, right in time :D
Thanks!

I'll try to post an example of circular aperature shape not working if I have some time...

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Fri Mar 19, 2010 11:43 am

Shit, well:

Code: Select all

----------------------
BLENDIGO v2.3.2
----------------------
  Windows-platform     : win32
  os.sep               : \
  matdbPreviews        : C:\Users\Tom\Documents\Utilities\Blender 2.49b\.blender
\scripts\blendigopkg\matdb\previews
  assetsPath           : C:\Users\Tom\Documents\Utilities\Blender 2.49b\.blender
\scripts\blendigopkg\assets
  matdbDownloads       : C:\Users\Tom\Documents\Utilities\Blender 2.49b\.blender
\scripts\blendigopkg\matdb

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Users\Tom\Documents\Utilities\Blender 2.49b\.blender\scripts\blendigo
.py", line 4435, in <module>
    readWriteSettings(0)
  File "C:\Users\Tom\Documents\Utilities\Blender 2.49b\.blender\scripts\blendigo
.py", line 3406, in readWriteSettings
    readWriteValue(d, 'aperture_pproc', IndigoUIControls.Camera.AperturePProc, w
rite, 0)
AttributeError: class Camera has no attribute 'AperturePProc'
Tips? I need to revert back to the previous version because I need to render a lot of stuff tonight.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Fri Mar 19, 2010 11:47 am

Tom,
Are you loading an existing scene ?

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Fri Mar 19, 2010 12:15 pm

dougal2 wrote:Tom,
Are you loading an existing scene ?
Yes'm. Just switching up from 2.3.1, I guess.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Fri Mar 19, 2010 12:24 pm

It is too late now for me to debug the error properly (gone midnight already :( ). I can't see any errors in the code, but I will have to do some testing with loading/saving scenes between blendigo versions; probably tomorrow or over the weekend.

If you're on a deadline and 2.3.2 is still not working, I suggest you go back to either 2.3.1 or 2.2 stable for now.

(I removed the 2.3.1 download links, but if you look carefully at the 2.3.2 link you should be able to figure out how to get it; the files are still on the site and can be downloaded).

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Fri Mar 19, 2010 12:56 pm

dougal2 wrote:It is too late now for me to debug the error properly (gone midnight already :( ). I can't see any errors in the code, but I will have to do some testing with loading/saving scenes between blendigo versions; probably tomorrow or over the weekend.

If you're on a deadline and 2.3.2 is still not working, I suggest you go back to either 2.3.1 or 2.2 stable for now.

(I removed the 2.3.1 download links, but if you look carefully at the 2.3.2 link you should be able to figure out how to get it; the files are still on the site and can be downloaded).
All good, I still had the 2.3.1 installed kicking around so I'm back in business! As always, your hard work is much appreciated!

Locked
128 posts

Who is online

Users browsing this forum: No registered users and 1 guest