Blendigo 2.3.x test releases

Announcements, requests and support regarding the Blender Indigo export script
Locked
128 posts
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Thu Feb 04, 2010 12:13 pm

FakeShamus wrote:I've been wondering if it might be easier to download the mac Blendigo as a simple drag and drop package that you put in a 'scripts' folder somewhere, instead of as an installer, then you just give people directions to set their scripts directory path in Blender. also, didn't there used to be a dialog at Blendigo start-up that asked where indigo was located, and had you browse to it? that seems like a good way to avoid the missing indigo installation problem.
It is possible, however the installer is supposed to do precisely those tedious tasks for you!

Its also possible that I provide Blendigo as its raw source files and then tell you to move this and that there, tweak this edit that and.... well, you get the idea - it's not everyone's idea of fun ;)


Seriously though, there is a standard blender scripts folder (~/.blender/scripts) and it is in fact fairly easy to drop Blendigo in there and have it working without even having to change the scripts directory setting in Blender. The problem on OSX is that this folder is hidden in Finder and not at all easy to get at for the average user.
The installer should be putting the files there (and it looks like it is), however writing the configuration file to specify the Indigo location seems to be massively unreliable.
Perhaps the best solution to this is to re-introduce the "set indigo path" prompt in Blendigo rather than trying to do it automatically. (However, then we also need some way to change that path when you upgrade or move the Indigo app).


The effect I want to aim for is "slick and reliable", so further discussions on this topic for what would suit you, dear end-users, would be appreciated :)

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Thu Feb 04, 2010 2:39 pm

- Even when exporting without Sun/Sky enabled, Sun and Sky lightgroups appear. The IGS file has Sun and Sky lightgroup definitions everywhere, between materials, then again after materials, etc.

- Bump settings are still in meters, I believe, though it says mm. Would be great to change that but let me double check that... running on battery right now and writing a paper.

- When a light or camera is selected and you try to export the scene, it tries to get an active UV Layer from the selection, which, being impossible due to the object type, causes it to crash. Selecting a mesh object or nothing then exporting works fine.

- As mentioned before, post-processed aperature diffraction and real ap.diff. should be differentiated and a toggle put in to control both. Problems with circular aperature shape here as well.

- When switching materials in the script window, the albedo channel always goes back to displaying the Color, not Texture. This doesn't seem to impact the actual exporting; it seems to render with the texture, but it's distracting and makes me nervous. Maybe a refresh problem...

- Would it be possible to deactivate bump and exponent maps if they're minimized? Right now the only way to temporarily deactivate textures is to delete their paths in the dialog.

- Still sometimes get 'material index is out of bounds' on perfectly good meshes. Everything works when I construct new meshes, but on existing meshes that are either imported or derived from imported objects (CAD drawings, mostly) it sometimes gives me problems. It could be Vray material and mesh definitions but I don't know if there is a conflict. I've tried deleting all material references and indexes and re-assigning materials and material groups to no avail.

- When I hit render all I get is a grainy image that only gets clearer at an excruciatingly slow pace... Oh whoops, not an exporter issue.

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Thu Feb 04, 2010 2:41 pm

Feature request: Possibly an all-in-one material blending option? Making three Blender materials for one blend material stops being fun after a while. No biggie, though, I'm a man and can handle my materials just fine.

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo 2.3.x test releases

Post by Jambert » Thu Feb 04, 2010 7:28 pm

dougal2 wrote: Would it be possible to deactivate bump and exponent maps if they're minimized? Right now the only way to temporarily deactivate textures is to delete their paths in the dialog.
+1, really bad for workflow

User avatar
SaphireS
Indigo 100
Posts: 134
Joined: Tue May 05, 2009 9:06 am
Location: Austria
Contact:

Re: Blendigo 2.3.x test releases

Post by SaphireS » Fri Feb 05, 2010 3:24 am

Feature request: Possibly an all-in-one material blending option? Making three Blender materials for one blend material stops being fun after a while. No biggie, though, I'm a man and can handle my materials just fine

+1
Your ad here!

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: Blendigo 2.3.x test releases

Post by dag » Fri Feb 05, 2010 12:16 pm

If you hit the mesh or material tab 2 times, it switches back to the window you previously were in, but the buttons stay pressed.

Should E really be the default white balance?

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Fri Feb 05, 2010 1:33 pm

dag wrote: Should E really be the default white balance?
White (R=100%, G=100%, B=100%) lights stay white with this setting, I believe. I think it responds to all wavelengths pretty evenly.

User avatar
Godzilla
Indigo 100
Posts: 985
Joined: Sat Jun 06, 2009 11:33 am

Re: Blendigo 2.3.x test releases

Post by Godzilla » Thu Feb 11, 2010 4:49 am

Ok, I installed the new script for access to particle support, and whenever I open Blender I get the same error message that Doug was getting..
Error%Broken installation of Blendigo, please reinstall
Abort
I've tried uninstalling and reinstalling, no luck.

When I go into scripts>render>render with Indigo, the same error..

when I make a new scene... same error.


This is the console:
Attachments
Error.gif
Error.gif (25.47 KiB) Viewed 2173 times
samlavoie.xyz

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Thu Feb 11, 2010 5:39 am

dammit, bitten by Vista's UAC again. I'll see if I can change the installer to write files to your home folder instead.

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo 2.3.x test releases

Post by StompinTom » Thu Feb 11, 2010 7:12 am

Light layers are all wonky. Blendigo defines them after every single material, instead of just once at the end of the IGS file.

Also, when using Background Color to illuminate the scene, its own light layer isn't defined so it takes whatever light layer is first, in which case you can't control it separately from that light group. Had to edit the IGS file to add another light layer to put the other lights on. That also sometimes messes with the colors, though I can't prove that right now.

Otherwise, seems OK...

User avatar
suvakas
3rd Place Winner
Posts: 2613
Joined: Mon Sep 04, 2006 11:08 pm
Location: Estonia
Contact:

Re: Blendigo 2.3.x test releases

Post by suvakas » Thu Feb 11, 2010 7:18 am

StompinTom wrote:
Also, when using Background Color to illuminate the scene, its own light layer isn't defined so it takes whatever light layer is first, in which case you can't control it separately from that light group.
It's currently not possible to define a light layer for environment. It's always exported to 1st layer.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Thu Feb 11, 2010 8:08 am

suvakas wrote:
StompinTom wrote:
Also, when using Background Color to illuminate the scene, its own light layer isn't defined so it takes whatever light layer is first, in which case you can't control it separately from that light group.
It's currently not possible to define a light layer for environment. It's always exported to 1st layer.
In that case, I shall name the first layer 'environment' :)

User avatar
aleksandera
Posts: 378
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Blendigo 2.3.x test releases

Post by aleksandera » Fri Feb 19, 2010 10:58 am

Does anyone have problems with camera and motion blur, ore is this yust me?

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo 2.3.x test releases

Post by Jambert » Fri Feb 19, 2010 8:10 pm

aleksandera wrote:Does anyone have problems with camera and motion blur, ore is this yust me?
Me too :wink:

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo 2.3.x test releases

Post by dougal2 » Sat Feb 20, 2010 1:35 am

Jambert wrote:
aleksandera wrote:Does anyone have problems with camera and motion blur, ore is this yust me?
Me too :wink:
Please elaborate ... :roll:

Locked
128 posts

Who is online

Users browsing this forum: No registered users and 1 guest