Can't get light bulb to work

Announcements, requests and support regarding the Blender Indigo export script
User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 6:15 am

(Click on it!)
Image

I seriously don't get it :(
benn hired a mercenary to kill my sig...

User avatar
Godzilla
Indigo 100
Posts: 985
Joined: Sat Jun 06, 2009 11:33 am

Re: Can't get light bulb to work

Post by Godzilla » Mon Jul 13, 2009 6:38 am

Maybe the specular is too high and it's reflecting the black background? Try making it a glossy transparent material and lowering the specular value.

Don't know if you've tried this, just an Idea.
samlavoie.xyz

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 8:50 am

What "specular" value are you talking about ?
benn hired a mercenary to kill my sig...

User avatar
Godzilla
Indigo 100
Posts: 985
Joined: Sat Jun 06, 2009 11:33 am

Re: Can't get light bulb to work

Post by Godzilla » Mon Jul 13, 2009 9:23 am

Specular=exponent and visa versa... I thought? :?
samlavoie.xyz

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 9:38 am

Godzilla wrote:Specular=exponent and visa versa... I thought? :?
I always called exponent...exponent :? also if you notice....Also, I tried glossy with an exponent/specular of 500 and it didn't fix it. So i switched it back to specular transparent (like on the screenshot).
benn hired a mercenary to kill my sig...

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Can't get light bulb to work

Post by Doug Armand » Mon Jul 13, 2009 5:01 pm

Silly question but your not using Reinhard tone mapping are you? :)
Doug

Doug Armand

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 7:37 pm

Yeah why? (I always do...)
benn hired a mercenary to kill my sig...

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Can't get light bulb to work

Post by Doug Armand » Mon Jul 13, 2009 8:00 pm

well maybe the light from the filament is making everything else go dark? if that was a real bulb the filament would be burning out. Maybe tried camera tone mapping?

Just a suggestion :wink:
Doug

Doug Armand

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 8:13 pm

Tried both Camera & Linear tonemapping and it did not have any positive effect :(
benn hired a mercenary to kill my sig...

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Can't get light bulb to work

Post by Doug Armand » Mon Jul 13, 2009 8:35 pm

If it's not confidential any chance you could post the blender file?
Doug

Doug Armand

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Re: Can't get light bulb to work

Post by Borgleader » Mon Jul 13, 2009 10:35 pm

benn hired a mercenary to kill my sig...

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Can't get light bulb to work

Post by Doug Armand » Mon Jul 13, 2009 10:52 pm

K downloaded it - quick look and can't see anything obviously wrong. Will take a closer look later
Doug

Doug Armand

User avatar
dakiru
Indigo 100
Posts: 746
Joined: Mon Jun 22, 2009 6:51 am

Re: Can't get light bulb to work

Post by dakiru » Tue Jul 14, 2009 5:30 am

Hi, Borgleader!

This is what I've got from your scene. But I had to:

-make the lamp smaller
-apply the scale
-apply all the modifiers
-after applying the modifiers remove doubles
-recalculate normals outside
-change the tungsten filament emission from 1500lm to 15000lm (because I think that the glass is too thick)
-put the lamp inside the cube (with flipped inside normals)

But still it seems to be a bit strange :?

blendfile

Edit: I was wrong with the filament emission. After change to another tonemapping than Reinhard it became nuclear :mrgreen:
Last edited by dakiru on Tue Jul 14, 2009 9:07 am, edited 1 time in total.

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Can't get light bulb to work

Post by Doug Armand » Tue Jul 14, 2009 5:35 am

OK I've had a longer play and... I haven't a clue :|

I thought it was just an exposure problem and so used camera tone and cranked the emitter material all the way up but it's still not right. The glass is picking up the colour from your back ground but it should be more transparent and affected by the emitter.

Your setup and all the materials seem ok to me, though I'm far from and expert - though thinking about it I didn't check the scale.

I think this is one for Ono or one of the other 'experts' here on this forum :(
Attachments
Lightbulb.jpg
Exposure and emitter material cranked way up
Lightbulb.jpg (81.05 KiB) Viewed 3877 times
Doug

Doug Armand

User avatar
Godzilla
Indigo 100
Posts: 985
Joined: Sat Jun 06, 2009 11:33 am

Re: Can't get light bulb to work

Post by Godzilla » Tue Jul 14, 2009 5:41 am

I tweaked the model and some of the materials for you.

Hope this was the result you were looking for :o

Image
Attachments
1.png
1.png (335.13 KiB) Viewed 3879 times
samlavoie.xyz

Post Reply
53 posts

Who is online

Users browsing this forum: No registered users and 1 guest