Blendigo for 1.1.14

Announcements, requests and support regarding the Blender Indigo export script
User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Thu Dec 11, 2008 5:02 am

The question wasn't if, but HOW ;)

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Thu Dec 11, 2008 8:04 am

I said blender's internal automated UV mapper.
benn hired a mercenary to kill my sig...

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Post by FakeShamus » Thu Dec 11, 2008 9:56 am

ok, so the problem with materials not being exported had to do with my materials being linked to the objects' (OB) data and not the meshes (ME) for everything in my scene. is there a reason that they would not be exported if that's the case? the materials showed up fine in the blendigo panel, they seem to have just been ignored at export time. I also noticed on a couple occasions I couldn't set the world scale lower than 1 - I don't know if that is a permanent problem or a random gui glitch. thanks!

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Fri Dec 12, 2008 9:26 am

Image

Look at the sofa/chair thing. Looks better now doesnt it? The question is...what type of fabric is it made out of? I have no idea :lol:
benn hired a mercenary to kill my sig...

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Fri Dec 12, 2008 10:07 am

lol
nice :D

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Fri Dec 12, 2008 10:25 am

Kram1032 wrote:lol
nice :D
There was something odd though. In the eenvironment tab. If I upped the exponent value for the world size. My uv mapping for the chair became all disgusting. So did the reflections on the windows and such. I dont know why :(

I'll try it again later when I get a clear image on the current try and see if i can reproduce the error.
benn hired a mercenary to kill my sig...

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Sat Dec 13, 2008 3:59 am

how big was it? might have something to do with the ray nudge distance and or floating point errors^^

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Sat Dec 13, 2008 6:36 am

Kram1032 wrote:how big was it? might have something to do with the ray nudge distance and or floating point errors^^
If I changed the exponent from 0 --> 3 the textures were really fucked like i cant imagine it being ray nudge.
benn hired a mercenary to kill my sig...

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Sat Dec 13, 2008 12:36 pm

you magnified things by 1000? Well, that's a pretty huge step. you'd have to multiply the ray nudge distance by 10 or 100... ;)

Just think of this: If you set scenescale 1*10³= 1000, that means that what previously was a meter (1 BU = 1m) suddenly becomes a km!

Ray Nudge distance was actually introduced, because of such strange artifacts at overly huge sizes.... AFAIK....

User avatar
Borgleader
Posts: 2149
Joined: Mon Jun 16, 2008 10:48 am

Post by Borgleader » Sat Dec 13, 2008 12:40 pm

Oh....so it was ray nudge? I'll try that then....
benn hired a mercenary to kill my sig...

User avatar
yellowzelo
Posts: 3
Joined: Thu Dec 18, 2008 10:33 pm
Location: Slovakia
Contact:

Post by yellowzelo » Wed Dec 24, 2008 9:22 am

Hi, I'm getting this error when when exporting>

INDIGO EXPORT

Traceback (most recent call last):
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 3743, in buttonEvt
exportStill(filename)
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 2889, in exportStill
export(filename, 0)
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 2871, in export
exportIndigoScene(filename, objlist, meshlist, matlist, include)
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 2671, in exportIndigoScene
exportMaterial(mat, file, exportedmatlist, includelist)
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 606, in exportMaterial
convertMaterial(mat)
File "C:\Blender Foundation\Blender\.blender\scripts\blendigo_v1114.py", line 424, in convertMaterial
mat.properties['indigo'] = d
RuntimeError: invalid element in subgroup dict template!

User avatar
5OnIt
Posts: 157
Joined: Sat Mar 03, 2007 5:11 am

Post by 5OnIt » Thu Jan 15, 2009 2:16 pm

Does anyone know why you can't set the Environment World Scale below 1.00?? It's really kind-of bumm'n me out! :cry:

User avatar
SmartDen
Developer
Posts: 999
Joined: Fri Oct 13, 2006 10:58 pm
Location: Canary Islands
Contact:

Post by SmartDen » Thu Jan 15, 2009 9:19 pm

5OnIt wrote:Does anyone know why you can't set the Environment World Scale below 1.00?? It's really kind-of bumm'n me out! :cry:
therefore set exponent of world scale lower 0.
Check normals, dude!

Image
Image

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Post by Jambert » Fri Jan 16, 2009 4:32 am

Hi all

Emission scale doesn't work, I tried different lux, lm... and it doesn't change anything :cry:

I use indigo 1.15

Edit: :oops: :oops: :oops: :oops:

It works, I changed tonemapping from Reinhard to linear and it works :wink:

User avatar
SATtva_
1st Place Winner
Posts: 179
Joined: Sat Sep 27, 2008 6:44 am
Location: Russia, Siberia
Contact:

Post by SATtva_ » Fri Jan 16, 2009 5:05 am

Jambert, I hope you don't have auto-exposure switched on, do you?

What I've noticed is that when IES profiles are used for light sources, gain has no effect on them: luminosity of each emitter is constant to ~830 lm. Don't know is that a problem of Indigo or of Blendigo though.

Post Reply
147 posts

Who is online

Users browsing this forum: No registered users and 1 guest