uv sets use?

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
12 posts • Page 1 of 1
Big Fan
Posts: 745
Joined: Tue Oct 17, 2006 9:37 am
Location: Nelson NZ

uv sets use?

Post by Big Fan » Wed Aug 27, 2008 2:15 pm

A few questions for people about using uv sets:

what type of rendering project is is that you are doing that really benefits from having uv sets?

how many people of all blendigo users definitely need sets capability?

how many sets are you using typically if you are unwrapping in several parts?

in those sets are you just doing more albedo parts or do you also have a need for a full compliment of bump, exp, disp, etc as well?

thanks

User avatar
zsouthboy
Posts: 1395
Joined: Fri Oct 13, 2006 5:12 am

Post by zsouthboy » Wed Aug 27, 2008 2:28 pm

multiple uv sets = separate maps for bump, albedo, etc.

For example, bump can be tiled over the entire object, but albedo needs to be properly unwrapped. Two different UV sets.

Big Fan
Posts: 745
Joined: Tue Oct 17, 2006 9:37 am
Location: Nelson NZ

Post by Big Fan » Wed Aug 27, 2008 2:56 pm

ok, so, if thats typical probably no one needs to unwrap parts of the mesh each with a full set of maps - that makes it easier for me to code

the reason I ask is that I have done something a bit different to smartden -ie auto creation of the reqd texture slots in blender from the script - if I was to put this up for people to play with in the meantime I wouldnt want people to be frustrated since it is intended for my Solidworks use (machinery type subjects) rather than high quality artistic stuff.
Currently it doesnt handle uv sets - will see what I can do

User avatar
palawat
Posts: 111
Joined: Sun Dec 02, 2007 11:45 pm
Location: Bangkok, TH

Post by palawat » Wed Aug 27, 2008 4:22 pm

Quote zsouthboy, I've never used more than 2 uv sets.

Then again, some people who deals with more complicated object may use more than two.
Cheers,

Q9550 2.83 GHz, Geforce 9400 GT, 4 GB ram, XP 32/Vista 64

User avatar
F.ip2
Posts: 160
Joined: Thu Aug 10, 2006 11:05 am

Post by F.ip2 » Sun Sep 14, 2008 8:02 am

1 UV coordinate set(s) found.
0 UV coordinate set(s) found.
Fatal Error: IndigoDriverExcep: SceneLoaderExcep: ObjectExcep: No such uv set 'UVTex' (In element 'model', around line 3063, column 5)

this is the error I get all the time.

I marked seams - unwrapped - loaded an image into the UV editor as well as into a texture channel inside Blender and set it to UV and Col.

I also hit convert to generate a fitting Inigo material.

In UVset: it still says Albedo - but even when I rename it to the name of the UVTex name from Blender I get the same error.

What is wrong here?
--
C l a a s E i c k e K u h n e n
Artist : Designer : Educator

Assistant Professor Industrial Design
Kendall College of Art and Design
of Ferris State University

Big Fan
Posts: 745
Joined: Tue Oct 17, 2006 9:37 am
Location: Nelson NZ

Post by Big Fan » Sun Sep 14, 2008 8:56 am

I presume you are trying blendigo 1.1.10 SW?

this blendigo version I made works differently from smartdens

UVTex wont work, the uvset names need to be 'albedo', 'bump' etc

have a look in the blendigo SW 1.1.9 thread for some clues on what to do

I HTH but if not I'll help you again

User avatar
fused
Developer
Posts: 3648
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Sun Sep 14, 2008 9:11 am

anyone knows how long smartden is going to be absent?

sorry for ot :)

Big Fan
Posts: 745
Joined: Tue Oct 17, 2006 9:37 am
Location: Nelson NZ

Post by Big Fan » Sun Sep 14, 2008 9:33 am

@fused

didnt get any messages

re smartden - no idea

User avatar
fused
Developer
Posts: 3648
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Sun Sep 14, 2008 9:39 am

@big fan:
oh, ok. i ment messages in the chatbox, kram wrote them out of sight :)

it was about the preview thing you mentioned.
i said im doing something like that in cindigo. check the -o and -haltspp commandline parameters in the manual, im using them to specify the output path and when the renderer should be closed (use indigo_console, because indigo.exe wont close itself anymore after rendering is finished).

im loading the preview in the description of the cindigo representation of the material then.

im also replacing the internal preview of the material in c4d by the one rendered with indigo.

Big Fan
Posts: 745
Joined: Tue Oct 17, 2006 9:37 am
Location: Nelson NZ

OT: integrating previews in the script UI

Post by Big Fan » Sun Sep 14, 2008 10:29 pm

@fused

thanks looking into it

my first thought when I considered how to do this was that it would be handy to have an option to have Indigo save the rendered image as 'preview.png' rather than by some sequential 123xxxxx.png.
that is it would be over written each preview use and easy to find.
could that be useful to you as well?

the advantage of the console is that it runs faster - which is handy for generating the preview however it needs to run as a minimised window from go so as not to intrude on the blender window - like we set priority = below normal
is that possible?
my know how is not so much :roll: :wink:

User avatar
fused
Developer
Posts: 3648
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Post by fused » Sun Sep 14, 2008 11:16 pm

well im storing the rendered previews similar like indigo, so i they dont get overwritten (each material keeps its rendered preview in cindigo as long its not deleted).

about the starting minimised. yes its possible:

Code: Select all

start /min /belownormal "path...\indigo_console.exe" "path...\preview\preview.igs" -o "path...\4274905.png" -haltspp 200
or so... ^^

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Sun Sep 14, 2008 11:45 pm

Code: Select all

start /min /belownormal "path...\indigo_console.exe" "path...\preview\preview.igs" -o "path...\preview.png" -haltspp 200
To get it called "preview", I think...

Post Reply
12 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 3 guests