Subdivision Smoothing in Blendigo

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
8 posts • Page 1 of 1
MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Subdivision Smoothing in Blendigo

Post by MSUdom5 » Fri Aug 01, 2008 4:28 am

I didn't see anything about this in other threads. I'm trying to understand how properly use Mesh Subdivisions and Subdivision Smoothing in Blendigo, and I'm running into a strange problem.

If I create a simple plane and tell Blendigo to Subdivide it a couple of times and turn on Smoothing, only a single polygon of the subdivided plane will show up in the render. When I turn off Smoothing, the whole plane shows up.

Is this correct behavior or a bug? If it's correct, could someone please explain to me what's going on? I expected Blendigo's Smooth Subdivide function to behave similarly to Blenders Catmull-Clark Subsurf Modifier, in which case the plane is subdivided and smoothed to almost a circular shape.

Thanks in advance for the help and explanations.

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Fri Aug 01, 2008 12:32 pm

Another question to add to my first question above: Does Blendigo automatically use instancing? For example, if I have a high-poly mesh that I duplicate, will Blendigo make the duplicate an instance of the original?
Last edited by MSUdom5 on Fri Aug 01, 2008 4:10 pm, edited 1 time in total.

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Fri Aug 01, 2008 3:57 pm

I love having my own little thread... where I'm all alone and post replies to myself. :)

Anyway, one more question. (And this time I've included an image! :wink: )

I have a mesh which I've UV mapped and applied a displacement map. It works/looks great on the original mesh, but when I Shift-D and duplicate it, I lose the displacement. I see some displacement on the copy of the mesh, but it doesn't correspond to my map. Why is this?
Attachments
im1217554821.png
im1217554821.png (401.74 KiB) Viewed 2430 times

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Fri Aug 01, 2008 4:09 pm

Nevermind. I'm an idiot. No wonder my posts are ignored... :wink:

When you duplicate a mesh, Blendigo doesn't automatically apply the same subdivision settings to the copy. You have to manually modify Subdivision settings for each copy. Didn't realize that.

However, if someone knows the answers to my first two posts, I'd really appreciate the enlightening. :)

User avatar
palawat
Posts: 111
Joined: Sun Dec 02, 2007 11:45 pm
Location: Bangkok, TH

Post by palawat » Fri Aug 01, 2008 7:37 pm

About instancing, you have to Alt+D instead of Shift+D. Duplicate Link(Alt+D) will be translated as instance via Blendigo script.

About others, I've never used Indigo's Subdivide before. My guess is that it exists to help people who use software that doesn't directly support Subdivide (ie. SketchUp). So, for me, Blender's Subdivide is my choice.

Please allow us other users some time to respond to your question. We're in different time zone. Some of us might getting some sleep (or drinks). :wink:
Cheers,

Q9550 2.83 GHz, Geforce 9400 GT, 4 GB ram, XP 32/Vista 64

User avatar
Kram1032
Posts: 6649
Joined: Tue Jan 23, 2007 3:55 am
Location: Austria near Vienna

Post by Kram1032 » Mon Aug 04, 2008 2:06 am

Alt+D will be translated as instance in Blendigo, because it'll be translated as such in Blender itself ;)

User avatar
palawat
Posts: 111
Joined: Sun Dec 02, 2007 11:45 pm
Location: Bangkok, TH

Post by palawat » Mon Aug 04, 2008 5:38 pm

Thank you, Kram, for the info. :)
Cheers,

Q9550 2.83 GHz, Geforce 9400 GT, 4 GB ram, XP 32/Vista 64

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Wed Aug 06, 2008 3:03 am

Thanks Kram and palawat for the help! Much appreciated. :)

Post Reply
8 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 4 guests