Error: not working though normals are correct

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
9 posts • Page 1 of 1
spazz
Posts: 6
Joined: Fri Sep 08, 2006 10:52 am

Error: not working though normals are correct

Post by spazz » Fri Sep 08, 2006 11:02 am

Image
The strange thing: the floor in that image is no black as you can see in the blend file.. but indigo is rendering it simply black as if it's not there.

Here is a 7z-File containing a blend:
http://psprince2.ps.funpic.de/wip/blend ... ezimmer.7z

(edit: I changed the picture you can see right now into a nightly rendered one)
Last edited by spazz on Sun Sep 10, 2006 4:24 am, edited 3 times in total.
:D Holy PolyGon! :D

User avatar
jurasek
Posts: 247
Joined: Sun Jun 25, 2006 11:23 pm
Location: Poland

Post by jurasek » Fri Sep 08, 2006 11:58 am

You have to use UV-mapping to see textures in Indigo.
Also Indigo doesn't support build-in-blender texutres (Wood, in your scene) ?

greetz,
jur

spazz
Posts: 6
Joined: Fri Sep 08, 2006 10:52 am

Post by spazz » Fri Sep 08, 2006 6:42 pm

Textures don't matter. (The shelves got a texture, too and it's not making them not beeing there.)
I flipped the normals already.. they are going to up. Normally I could see them.
And I am using Indigo_05.
:D Holy PolyGon! :D

zuegs
Posts: 380
Joined: Tue Jun 27, 2006 5:46 pm
Location: switzerland

Post by zuegs » Fri Sep 08, 2006 7:08 pm

@spazz:
try to disable "Ray Mirror" button in floor material, phong shader will do the reflection himself (use "hard" value to set sharpness).

spazz
Posts: 6
Joined: Fri Sep 08, 2006 10:52 am

Post by spazz » Fri Sep 08, 2006 8:22 pm

zuegs was right. I turned off the RayMirror in the materials and it worked! Thanks! :)
:D Holy PolyGon! :D

spazz
Posts: 6
Joined: Fri Sep 08, 2006 10:52 am

Post by spazz » Sun Sep 10, 2006 4:47 am

Another problem: After fixingthe last problem and reading the great manual :D I got another problem..
An object with correct normals doesn't emit although it's material should.
Image
It's Lambert like the very small emitting rectangle at the top of the room and it has Emit: 1.000 The only thing that differs is the color.
Here the Result:
Image
The render's <Env Type> is "SunSky".
:D Holy PolyGon! :D

User avatar
Maluminas
Posts: 148
Joined: Fri Aug 18, 2006 11:06 am
Location: Canada>Quebec>Montreal

Post by Maluminas » Sun Sep 10, 2006 7:43 am

Interesting... I had something like that once, i had two emitters in a scene but only one would work at one time. I thought nothing of it because i supposed it was an error in my XML, but now that you mention it it might be some kind of bug?

spazz
Posts: 6
Joined: Fri Sep 08, 2006 10:52 am

Post by spazz » Sun Sep 10, 2006 8:34 pm

I'm just testing a render without the small plane on the top of the room.. meaning with only one emitting mesh - and it's still not working. :(
:D Holy PolyGon! :D

zuegs
Posts: 380
Joined: Tue Jun 27, 2006 5:46 pm
Location: switzerland

Post by zuegs » Sun Sep 10, 2006 9:20 pm

@spazz,
1. ensure that "Ray Mirror" and "Ray Transp" buttons are dissabled for the emmiting material.
2. the "Amb" slider defines the blackbody temperature... as you like to use RGB color for emmiter you must set "Amb" to 0.0
3. Now you have to find the balance between the different lights (for sun-light: "Sky Gain" value in exporter / for blackbody top light: "Emit" slider / for deco light: "Emit" slider) Note that blackbody-lights and RGB-lights will not have same "Emit" value as blackbody brightness depends on temperature ("Amb"). I propose that you use RGB-light for top-light too (set "AMB" slider to 0.0) so you should get a good balance for the indoor lights, and you have just to "gain" the sun....

Post Reply
9 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest