Desperate for Motion Blur corrections!

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
13 posts • Page 1 of 1
fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Desperate for Motion Blur corrections!

Post by fbrunell » Thu Mar 28, 2013 2:13 pm

Hello,

What are the plans to correct Motion Blur? It's been quite a while that the bug around motion Blur has been submitted. (Reported Bug regarding child objects motion blur when parents are keyframed mentionned in every new version of blendigo)

Unless I'm mistaken, "Camera" motion blur used to work in a previous versions of Blendigo (long time ago) and it seems to work for other exporters. Would it be possible to implement for Blender? Either through a second check box beside the current "Motion Blur" checkbox or within the Camera Settings!

Also, I would also like to know if and when particles motion blur would be implemented?

Finally, (Just debating, not requesting), do you think that mesh deform through armature could ever be motion blured?

User avatar
OnoSendai
Developer
Posts: 6233
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Desperate for Motion Blur corrections!

Post by OnoSendai » Sun Mar 31, 2013 4:05 am

Hi fbrunell,
We will be doing a big refactor of the blendigo and Indigo code soon, during which we should fix the motion blur problems.

Deformation blur is planned to be implemented at some point later.

StompinTom
Indigo 100
Posts: 1823
Joined: Mon Sep 04, 2006 3:33 pm

Re: Desperate for Motion Blur corrections!

Post by StompinTom » Sun Mar 31, 2013 6:41 am

OnoSendai wrote:Hi fbrunell,
We will be doing a big refactor of the blendigo and Indigo code soon, during which we should fix the motion blur problems.

Deformation blur is planned to be implemented at some point later.
Oh that's exciting. Any details or timelines to share? What will be the bigger changes?

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Desperate for Motion Blur corrections!

Post by fbrunell » Tue Apr 02, 2013 9:04 am

WOW!!! deformation motion blur... You just made my day... no, my week...

Yeah, dates, dates :mrgreen:

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Desperate for Motion Blur corrections!

Post by fbrunell » Tue Oct 22, 2013 1:23 am

Hello,

It's been a while. Any update on a timeframe ?

User avatar
OnoSendai
Developer
Posts: 6233
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Re: Desperate for Motion Blur corrections!

Post by OnoSendai » Tue Oct 22, 2013 9:13 am

Hi fbrunell,
We'll take a look at deformation motion blur support again after the 3.6 stable release.
It's definitely not the highest of priorities though, so I can't promise a given time it will be done by.

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Desperate for Motion Blur corrections!

Post by fbrunell » Sat Mar 08, 2014 5:31 pm

Sorry to nag about this but can we hope to at least get motion blur on particules soon (without deform)? I'm having to default on Cycles for some renders?

User avatar
Doug Armand
Indigo 100
Posts: 1038
Joined: Fri May 16, 2008 5:49 pm
Location: London UK

Re: Desperate for Motion Blur corrections!

Post by Doug Armand » Tue Mar 11, 2014 11:09 pm

+1 for more updates to Blendigo. I am also being tempted more and more by Cycles - and I much prefer to keep using Indigo
Doug

Doug Armand

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Desperate for Motion Blur corrections!

Post by fbrunell » Wed Jun 18, 2014 12:07 pm

Hello Ono, any development on motion blur? I just noticed in the next release candidate for Blender 2.71 that Cycle will be able to perform Deformation Motion Blur. Could some of that code be reused and/or referenced within Blendigo.

Also, as I asked a while back (2 years I think), I seem to remember that camera movement could be motion blured in very old versions of Blendigo and can't seem to be able to have it working with Blendigo. Is there a parameter in the exported scene that I could change to have camera movement motion blured? That could at least help me in the mean time?

Finally, here is some of the points I would like to know if Blendigo will be able to perform soon :

1. Camera movement motion blur
2. Particules Motion Blur
3. Blendigo corrections on "child" objects translation when motion blur is activated
4. Deformation Motion Blur
5. Easy smoke rendering (that probablably has more to do with textures than Blendigo but heck, I had to ask (Looking at "Fire and Smoke Rendering from Cycle" in the Blender 2.71 : Cycles release notes)

I am totally sold to Indigo. I find the end results much sharper than Cycle but if we can't generate a scene to have it rendered, it leaves us with few options.

Thank you in advance,

User avatar
zeitmeister
2nd Place 100
Posts: 2010
Joined: Tue Apr 22, 2008 4:11 am
Location: Limburg/Lahn, Germany
Contact:

Re: Desperate for Motion Blur corrections!

Post by zeitmeister » Thu Jun 19, 2014 3:47 am

CamMB is working in Indigo for C4D... Should be nothing related to Indigo itself but on Blendigo, as well as particleMB.


Grüsse, zeiti
Cheers, David



DAVIDGUDELIUS // 3D.PORTFOLIO
·
Indigo 4.4.15 | Indigo for C4D 4.4.13.1 | C4D R23 | Mac OS X 10.13.6 | Windows 10 Professional x64

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Desperate for Motion Blur corrections!

Post by fbrunell » Fri Jun 20, 2014 3:31 pm

zeitmeister wrote:CamMB is working in Indigo for C4D... Should be nothing related to Indigo itself but on Blendigo, as well as particleMB.
Ah good, that confirms what I suspected. It got something with the way Blendigo exports the scene. But looking at the exported scene file (.igs), I can't find any reference to something that may look like "Motion Blur". I even compared the files within Notepad++ without success.

I created a file with an ICO sphere and the cam moving (obviously in different directions). I can see clearly the sphere blured (a lot) and a fixed cube totally cristal clear. Since the CAM is moving quite fast, the cube should be blurred as well.
untitled.Scene.00008.jpg
Where is this value set. And How Blendigo could have set motion blur on objects but not the camera. That would mean that motion blur can be set either on :

1. All objects on one side and the camera on the second
2. Each objects individually (which could actually be usefull in certain cases) considering the camera as an object.

It would have to do with the way Blendigo sets this parameter for each exported objects. I checked the (.obj) file and can't get any more success there...

Obviously, I'm a newby on the coding side. But I can't imagine this would be complexe to fix.

As for Particules MB, could the problem be related. Would it just be that each particules, when exported, are not set to be motion blured...

Am I completely beside the track here?

User avatar
yonosoy
Posts: 683
Joined: Sat Dec 01, 2012 9:45 pm
Location: Spain

Re: Desperate for Motion Blur corrections!

Post by yonosoy » Fri Jun 20, 2014 4:13 pm

Hi.
In the IGS file there is no a concrete option with a boolean (true/false) to activate,...
It all depends in the exportation. For the objects, a list with every keyframe is created inside the model section, like this:

Code: Select all

	<model2>
		<uid>9</uid>
		<name>Cubo</name>
		<geometry_uid>8</geometry_uid>
		<scale>1</scale>
		<rotation>
			<matrix>
				1 0 0 0 1 0 0 0 1 
			</matrix>
		</rotation>
		<keyframe>
			<time>0</time>
			<pos>-571.1999482120643 124.76726894811736 97.3160736174481</pos>
			<rotation_quaternion>
				<axis>0 0 1</axis>
				<angle>0</angle>
			</rotation_quaternion>
		</keyframe>
..........................
Then, indigo generates an integrated curve over the movement (all the keyframes involved in the setup) and this will be calculated.

For the cam the same:

Code: Select all

	<camera>
		<uid>3</uid>
		<name>Camera</name>
		<aperture_radius>0.0011249797503644935</aperture_radius>
		<focus_distance>2000</focus_distance>
		<sensor_width>0.036000000000000004</sensor_width>
		<lens_sensor_dist>0.036000000000000004</lens_sensor_dist>
		<exposure_duration>20</exposure_duration>
		<lens_shift_up_distance>0</lens_shift_up_distance>
		<lens_shift_right_distance>0</lens_shift_right_distance>
	<autofocus/>
		<aperture_shape>
			<generated>
				<num_blades>18</num_blades>
				<blade_offset>0.4</blade_offset>
				<blade_curvature_radius>3</blade_curvature_radius>
				<start_angle>0.002</start_angle>
			</generated>
		</aperture_shape>
		<keyframe>
			<time>0</time>
			<pos>582.4836892184867 -606.3498801189469 47.120066989253075</pos>
			<rotation_quaternion>
				<axis>-0.035612880777051846 -0.013432560515664476 -0.9992753819847422</axis>
				<angle>0.7218445419145326</angle>
			</rotation_quaternion>
		</keyframe>
..............................
Maybe the tag of motion blur in the cam was forgoted in your setup... take a look.

Edit: just noticed that seems that your test is from blendigo, good new then...
Attachments
camera_motion_blur_test_C4D.jpg
"... the hamster don't see the wheel, and this wasn't said before." (yoS eidaN "el Olvidao")
"... nor 0.2 galaxys, nor 0.8 little chikens ..."

User avatar
aleksandera
Posts: 380
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Desperate for Motion Blur corrections!

Post by aleksandera » Sun Jul 24, 2016 5:47 am


Post Reply
13 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest