What governs the black screen of death?

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
12 posts • Page 1 of 1
User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

What governs the black screen of death?

Post by matsta » Mon Jan 29, 2007 8:57 am

tsup guys!

i just started with exporting to indigo today. i must say that some of the renders in the galleries do excite me. all my files and scripts were extracted correctly and everything is in the right place file wise.

i create a new scene in blender (i am moderatly experienced with blender) containing suzzane and a cube on a plane. the cube is spec 0 (ie matte) and the monkey is set transparent with subsurf 2 applied and set smooth. my light is a sun (as in tutorial) and all my settings are exactly the same as in the main ttorial (which i founf n the indigo site). but sometimes my render ill render for like 20 minutes and come up with nothing but black... but others. will render the cube and monkey but the plane will be pure black (no shading)

does anyone have any idea as to what could eb happening? i can post images if needs be? what governs weather or not the image renders... im boggled.

thanks
mat

Kachu
Posts: 54
Joined: Tue Sep 19, 2006 9:12 am

Post by Kachu » Mon Jan 29, 2007 4:09 pm

What version of Indigo and What exporter?
In most of the blender exporters there is a tab where you select the 'Env Type' it should be set to Physical Sky.

Env Types; (This could be talked about somewhere(and post if something is wrong))
- Physical Sky is the sun like in the tutorial
- Background color is illuminated by the background color
- Texture map is for .exr HDR illuminated scenes (search the forum for exr to see what it does)

On .63beta4 its under the environment tab.
Everyone else is doing it so : Core 2 duo E6600, 2 gb ram, Nvidia 8800 640 GTS and 250 gb hd

User avatar
Zom-B
1st Place 100
Posts: 4650
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Post by Zom-B » Mon Jan 29, 2007 8:18 pm

Welcome to Indigo Dude :)

In Indigo the Models just get illuminated probably on the side the normals faces out, check them.
polygonmanufaktur.de

BWETIK
Posts: 23
Joined: Tue Jan 23, 2007 7:29 pm

black

Post by BWETIK » Mon Jan 29, 2007 8:35 pm

pure black plane is maybe problem with material, if you have a ray transparency or ray mirror activated, it can showing like black..
And maybe its something another :wink:

User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

Post by matsta » Tue Jan 30, 2007 3:31 am

thanks guys got the problem sorted ;) man this forum is way to friedly :)

User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

Post by matsta » Tue Jan 30, 2007 3:34 am

thanks guys this forum is way to friendly ;)

User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

Post by matsta » Wed Jan 31, 2007 2:57 am

ok guys.... still no luck. everything u advized i did.flipped normals. change mirror settings. stuff like that. still nothing. here is a screenin of what im dealing with. i have no idea wtf is going on. i did the office scene test render last nite with 3 machines running and that went good. so dont know wat the prob is... any ideas?

Image

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Wed Jan 31, 2007 4:13 am

coul you post the xml-code?

User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

Post by matsta » Wed Jan 31, 2007 5:18 am

manitwo wrote:coul you post the xml-code?
<scene>
<renderer_settings>
<width>1280</width>
<height>1024</height>
<metropolis>true</metropolis>
<large_mutation_prob>0.1</large_mutation_prob>
<max_change>0.02</max_change>
<max_num_consec_rejections>100</max_num_consec_rejections>
<bidirectional>false</bidirectional>
<russian_roulette_live_prob>0.7</russian_roulette_live_prob>
<max_depth>1000</max_depth>
<strata_width>14</strata_width>
<logging>false</logging>
<save_untonemapped_exr>false</save_untonemapped_exr>
<save_tonemapped_exr>false</save_tonemapped_exr>
</renderer_settings>

<tonemapping>
<!--
<linear>
<scale>1.0</scale>
</linear>
-->
<reinhard>
<pre_scale>1.000000</pre_scale>
<post_scale>1.000000</post_scale>
<burn>0.800</burn>
</reinhard>
</tonemapping>

<material>
<name>Default</name>
<diffuse>
<colour>1 1 1</colour>
</diffuse>
</material>
<material>
<name>Material</name>
<diffuse>
<colour>0.058 0.365 0.009</colour>
</diffuse>
</material>

<material>
<name>Material.001</name>
<specular>
<normal_reflectance>0.000</normal_reflectance>
<ior>2.634</ior>
<transparent>true</transparent>
<cauchy_b_coeff>0.000</cauchy_b_coeff>
<rgb_absorptivity>0.000 0.000 0.000</rgb_absorptivity>
</specular>
</material>

<skylight>
<sundir>0.227688 -0.684177 0.692863</sundir>
<turbidity>2.000000</turbidity>
<sky_gain>0.005000</sky_gain>
</skylight>

<camera>
<pos>4.150859 -1.529263 2.289482</pos>
<up>-0.365636 0.295516 0.882599</up>
<forwards>-0.811632 0.362927 -0.457753</forwards>
<aperture_radius>0.001000</aperture_radius>
<focus_distance>2.000000</focus_distance>
<aspect_ratio>1.25</aspect_ratio>
<sensor_width>0.035000</sensor_width>
<lens_sensor_dist>0.038281</lens_sensor_dist>
<white_balance>E</white_balance>
</camera>

not sure if that is what u want? im new at this

mat

User avatar
matsta
Posts: 730
Joined: Mon Jan 29, 2007 7:50 am
Location: 127.0.0.1

Post by matsta » Wed Jan 31, 2007 5:19 am

i have found a solution. but its very unsatisfactory and that is to us the top of a cube instead of a plane. that seems to work fine. not to sure what the difference is

lol its probably soemthing seriously simpl and im just to noob to figure it out

mat

User avatar
Kosmokrator
Posts: 1141
Joined: Sat Jul 29, 2006 11:52 am
Location: Greece-Athens

Post by Kosmokrator » Wed Jan 31, 2007 11:34 am

i thik this material is totaly black and difuse.....

<material>
<name>Material.001</name>
<specular>
<normal_reflectance>0.000</normal_reflectance>
<ior>2.634</ior>
<transparent>true</transparent>
<cauchy_b_coeff>0.000</cauchy_b_coeff>
<rgb_absorptivity>0.000 0.000 0.000</rgb_absorptivity>
</specular>
</material>

thats the reason........
1)Core i7 965XE stock CLOCK ,PSU:CHIEFTEC 850W
M/B ASUS P6T DELUXE,WATERCOOLING ZALMAN RESERATOR 2
MEMORY:6GB CORRSAIR @1600,Ati HD 4870x2,
MONITOR:LG 1950SQ,CASE:THERMALTAKE SOPRANO

User avatar
manitwo
Posts: 1029
Joined: Wed Jul 05, 2006 4:50 am
Location: Tirol - Austria

Post by manitwo » Wed Jan 31, 2007 2:48 pm

matsta wrote:not sure if that is what u want?
yes exactly.

kosmo is right ... Material.001 is really weird (i guess that's the ground-mat, or?) - try a diffuse mat like:

Code: Select all

    <material>
        <name>Material.001</name>
        <diffuse>
            <colour>0.3 0.6 0.8</colour>
        </diffuse>
    </material>

Post Reply
12 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest