Blendigo (for Blender 2.6x) 3.2.3.1

Announcements, requests and support regarding the Blender Indigo export script
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by dougal2 » Sat Dec 24, 2011 3:24 am

fbrunell wrote:Also, unless they are already there and I can't find them, what are the target, if any, to integrate other Indigo parameters in Blendigo :
- Tone Mapping
- Light Layers Temperature values
- Apperture Diffraction
Tonemapping and Aperture diffraction are settings you can find in the Camera settings panel. (ie. you can configure tonemapping and AP per-camera).

AFAIK though exporting light layer temperatures is not possible, so you won't find these settings anywhere in Blendigo.

fbrunell
Posts: 77
Joined: Wed Jan 06, 2010 3:05 pm
Location: Quebec, Canada

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by fbrunell » Sat Dec 24, 2011 8:13 am

Ah, found them, thanks...

Is the supersampling parameter somewhere that I haven't found?

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by dougal2 » Sat Dec 24, 2011 8:47 am

I think you'll have to choose 'custom' for the filter setting in the render settings.

neckname
Posts: 1
Joined: Sun Jan 01, 2012 5:00 am

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by neckname » Sun Jan 01, 2012 5:06 am

Hi. I just updated the export-script from 3.2-something to 3.2.3.1 and now I get the following error:

Traceback (most recent call last):
File "/home/luda/.blender/2.60/scripts/addons/indigo/core/__init__.py", line 149, in render
if self.is_animation:
AttributeError: 'RENDERENGINE_indigo' object has no attribute 'is_animation'

location:<unknown location>:-1

location:<unknown location>:-1

I'm just trying to render a static scene, no animations, just a single picture.

Anyone got any ideas why this might happen?

User avatar
solarray
1st Place Winner
Posts: 110
Joined: Mon Apr 20, 2009 3:22 am
Contact:

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by solarray » Fri Jan 06, 2012 4:10 am

Are curve modifiers applied corectly to mesh objects while exporting? Anything known ? I can upload a test file... could also be a blender bug.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by dougal2 » Fri Jan 06, 2012 4:15 am

neckname wrote:Hi. I just updated the export-script from 3.2-something to 3.2.3.1 and now I get the following error:

Traceback (most recent call last):
File "/home/luda/.blender/2.60/scripts/addons/indigo/core/__init__.py", line 149, in render
if self.is_animation:
AttributeError: 'RENDERENGINE_indigo' object has no attribute 'is_animation'

location:<unknown location>:-1

location:<unknown location>:-1

I'm just trying to render a static scene, no animations, just a single picture.

Anyone got any ideas why this might happen?
Read the first post, you need blender 2.61

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by dougal2 » Fri Jan 06, 2012 4:16 am

solarray wrote:Are curve modifiers applied corectly to mesh objects while exporting? Anything known ? I can upload a test file... could also be a blender bug.
Blender is responsible for deriving the tessellated meshes for curve objects, however, a test scene would be useful to double check where the problem is.

User avatar
solarray
1st Place Winner
Posts: 110
Joined: Mon Apr 20, 2009 3:22 am
Contact:

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by solarray » Fri Jan 06, 2012 4:36 am

Ok found the problem, but its more a user issue :)

FakeShamus
Posts: 509
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by FakeShamus » Sun Jan 08, 2012 4:25 am

I have a request about albedo - it seems that any basic-color materials with albedo (phong, diffuse, etc.) get exported with gamma 1.0, which makes everything look very washed-out compared to the color you're picking in Blendigo. switching gamma to 2.2 gives the expected color in Indigo.
maybe include a gamma selection option for albedo, like there is for textures?

StompinTom
Indigo 100
Posts: 1821
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by StompinTom » Sun Jan 08, 2012 5:25 am

Does this only work with the official 2.61 version? For some reason a patched Graphicall build doesn't recognize the Blendigo installation...

EDIT: Would it be possible to add a small tab in the Render Settings panel that just lists the version number, author, Indigo version it works with, etc.? It would just help for quick reference :)

StompinTom
Indigo 100
Posts: 1821
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.6x) 3.2.3.1

Post by StompinTom » Tue Jan 17, 2012 12:24 pm

Hi Doug,

Rendering animations seems to fail. It exports all the scenes, as well as a render queue file (*.igq) but this fails to render... Might be an Indigo issue, I will post accordingly. Indigo crashes upon trying to open that file.

Post Reply
26 posts

Who is online

Users browsing this forum: Semrush [Bot] and 3 guests