Blendigo (for Blender 2.5x) 3.2.0.0

Announcements, requests and support regarding the Blender Indigo export script
StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by StompinTom » Sat Nov 05, 2011 2:46 am

dougal2 wrote:
StompinTom wrote:Also, the exporting process still seems suspiciously slow, as if it's still exporting a bunch of geometry...

26.415 seconds with a proxy attached to a low-poly object.
2.590 seconds with only the low-poly object.
35.941 seconds with only the high-poly object (no linking).

Seems a little strange, as I would expect the exporting of the proxy object to be just as fast, or even faster, than exporting the low-poly stand-in since it's just linking an external file...

Also, the old problem of Indigo giving 'Error while building scene: ModelLoadingStremHandlerExcep: Triangle material_index is out of bounds. (material index=4).' is still there when you have an unused material attached to an object.
The apparent slow down when using a proxy is that Blendigo is actually loading the high-res igmesh in order to try and discover its material assignments. As you've also found, this method seems to not work properly yet anyway - so I'll have another look at it for the next release.
Ah ok. I figured it would just take the material assignments from the stand-in object and assign them based on material indices or something...

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by FakeShamus » Sat Nov 05, 2011 4:20 am

...Blendigo is actually loading the high-res igmesh in order to try and discover its material assignments.
yeah, this actually seems like something the user should be responsible for instead of Blendigo loading the mesh to check - making sure your hi-res object has the correct materials assigned when it's exported should be pretty much a given if you're advanced enough to use the proxy feature in the first place.

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by StompinTom » Sat Nov 05, 2011 9:05 am

Particle export also seems much slower... I haven`t compared the times exactly, but it seems a LOT longer to export the same amount of particles. I will do some tests.

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by FakeShamus » Mon Nov 07, 2011 4:01 am

can I also request, as part of the the proxy feature, to allow for other external mesh formats? I export a lot of stuff from zbrush as .obj (much faster than blender import and export) and the proxy should be able to link directly to an external .obj - it's supported by indigo. I just tried this and I get an error saying that the mesh is not a valid igmesh. thx

edit:
also, just exported a hi-res igmesh and it's about 1.5 times larger than the obj version I exported from zbrush, so it would help me memory-wise too.

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by Jambert » Mon Nov 07, 2011 11:03 pm

Autostart doen't work here

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by dougal2 » Mon Nov 07, 2011 11:23 pm

Jambert wrote:Autostart doen't work here
Please check the console for errors, your path setting in the render panels, and whether you have the correct version of indigo installed.

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by Jambert » Tue Nov 08, 2011 12:41 am

sorry, I don't know why I had to re-enter path? was good but did'nt work... now it works

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by FakeShamus » Tue Nov 08, 2011 12:50 am

Not sure if this is a Blendigo or Indigo problem (both?) but if I select camera tone mapping in blendigo and don't enter a response curve preset, Indigo crashes as soon as soon as I try to start the render.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by dougal2 » Tue Nov 08, 2011 2:39 am

FakeShamus wrote:Not sure if this is a Blendigo or Indigo problem (both?) but if I select camera tone mapping in blendigo and don't enter a response curve preset, Indigo crashes as soon as soon as I try to start the render.
Thanks, this sounds like a missing default value in Blendigo.

User avatar
Headroom
Indigo 100
Posts: 987
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by Headroom » Wed Nov 09, 2011 2:34 am

Export works fine so far but Indigo does not autostart. It does not seem to find the app even though
I reentered the path to Indigo. The console output shows that it seems to be always looking for the console version in a path that does not exist, regardless of what I put into the "Path to Indigo" field:


11/8/11 9:25:58.511 AM [0x0-0x1ed1ed0].org.blenderfoundation.blender: OSError: [Errno 2] No such file or directory: '/Applications/Indigo 3.2.0/Indigo.app/Contents/MacOS/../MacOS/Indigo_console -v'

I can stat Indigo and it renders fine once I manually navigate to the exported .igs file and open it.

Same in Blender 2.59 and 2.6a (script and export work fine so far in Blender 2.6a)

- Blendigo 3.2.0 for Blender 2.5x
- Indigo 3.2.0

iMac OSX Lion 10.7.2

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by dougal2 » Wed Nov 09, 2011 2:57 am

Headroom wrote:Export works fine so far but Indigo does not autostart. It does not seem to find the app even though
I reentered the path to Indigo. The console output shows that it seems to be always looking for the console version in a path that does not exist, regardless of what I put into the "Path to Indigo" field:


11/8/11 9:25:58.511 AM [0x0-0x1ed1ed0].org.blenderfoundation.blender: OSError: [Errno 2] No such file or directory: '/Applications/Indigo 3.2.0/Indigo.app/Contents/MacOS/../MacOS/Indigo_console -v'

I can stat Indigo and it renders fine once I manually navigate to the exported .igs file and open it.

Same in Blender 2.59 and 2.6a (script and export work fine so far in Blender 2.6a)

- Blendigo 3.2.0 for Blender 2.5x
- Indigo 3.2.0

iMac OSX Lion 10.7.2
OK, this fails because indigo_console hasn't been found in order to perform the version compatibility check. I'll check with the Glare guys for the correct location of indigo_console on OSX.

User avatar
Headroom
Indigo 100
Posts: 987
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by Headroom » Wed Nov 09, 2011 3:08 am

I usually place the downloads into a dedicated folder within the Applications directory. That way I can keep several versions of Indigo concurrently.
It's "Indigo 3.2.0" this time, so nothing particular about it. The Indigo.app package is located in that directoryWithin the package the "indigo_console" executable is in the same directory as the "indigo" executable, same as in previous versions.

Thanks for the help!

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by FakeShamus » Wed Nov 09, 2011 4:19 am

I think there are some other file path problems for OSX with nk data - in Blendigo for 2.49, you can just enter "cr.nk" (for example) and Indigo finds it no problem. now I keep getting errors that Indigo can't the nk files. even if I browse to the folder and enter the full path.

User avatar
dag
Posts: 189
Joined: Tue Feb 02, 2010 2:28 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by dag » Wed Nov 09, 2011 12:09 pm

Couldn't nk files be done like film responses with a preset/file switch?
There's also no checkbox for nkdata so you have to remove the path to disable it.

pvbeeber
Indigo 100
Posts: 23
Joined: Sat Apr 11, 2009 4:48 am

Re: Blendigo (for Blender 2.5x) 3.2.0.0

Post by pvbeeber » Thu Nov 10, 2011 8:17 am

Glad to see that basic motion blur support has been added. Any idea when particle instance motion blur will be re-implemented?

Post Reply
47 posts

Who is online

Users browsing this forum: No registered users and 7 guests