Blendigo (for Blender 2.58) 3.0.10.1

Announcements, requests and support regarding the Blender Indigo export script
Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by Silmä » Thu Jun 30, 2011 5:57 am

Tried to install the new exporter, doesn't work.

Blendigo shows up in the addons menu with correct version number (3.0.10.1), but I'm not able to enable it by clicking the checkbox (it just stays gray).

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by StompinTom » Thu Jun 30, 2011 9:16 am

drBouvierLeduc wrote:@StompinTom : Superb example !... And you call that "simple" ?
Well, there's something I must be doing wrong, no matter what I do, my particles simply abort the export.
I'm using the same technique as you describe though : dupligroups with particles.
Hmmm... make sure you're at frame 1? If you don't mind, post a simple .blend file and I can take a look, if you want!

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by dougal2 » Thu Jun 30, 2011 10:40 am

Silmä wrote:Tried to install the new exporter, doesn't work.

Blendigo shows up in the addons menu with correct version number (3.0.10.1), but I'm not able to enable it by clicking the checkbox (it just stays gray).
But the 3.0.10 version worked? Make sure you completely replaced the addons/indigo folder with the new one - it could be failing to enable due to having mixed versions.
The blender console (Help menu) should show the exact reason for failure, can you post the console output here ?

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by Silmä » Thu Jun 30, 2011 1:31 pm

Here's screenshot of the module after trying to click the checkbox. The second error message after the break came after I tried to click again.
Attachments
error.jpg

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by drBouvierLeduc » Thu Jun 30, 2011 8:13 pm

StompinTom wrote: Hmmm... make sure you're at frame 1? If you don't mind, post a simple .blend file and I can take a look, if you want!
So I erased everything in the scene except the plane with particles, and now it's working... There's something fishy...
I'm at frame 1 by the way. I guess I'll have to invetigate furthermore.

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by drBouvierLeduc » Thu Jun 30, 2011 10:34 pm

I think I found the source of my problem, the solution was simple, yet not that obvious : in order for particle + dupligroup to work, the original group must be on a visible layer (not necessarily visible by the camera, but present somewhere on the scene).
Now I'm a happy camper !

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by dougal2 » Fri Jul 01, 2011 12:16 am

Silmä wrote:Here's screenshot of the module after trying to click the checkbox. The second error message after the break came after I tried to click again.
I think you may well have to upgrade to Blender 2.58.

I know I stated 2.5x in the thread title, but I'll try to be more specific in the future.

Silmä
2nd Place Winner
Posts: 147
Joined: Fri Jun 26, 2009 7:46 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by Silmä » Fri Jul 01, 2011 12:56 am

Great! Now it's working.

Lost my user preferences (that were changed to mimic Blender 2.49) in the process, but still great.

Zlaty Lev
Posts: 16
Joined: Fri Sep 03, 2010 4:15 am

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by Zlaty Lev » Fri Jul 01, 2011 3:25 am

External material still do not work!

If you open a file from blender 2.49b you have to assign all indigo materials new.
Is there a way to fix this? It takes a lot of work to assign all materials new.

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by Jambert » Fri Jul 01, 2011 3:26 am

Hi Doug, do you know if external material will be supported soon?

thx

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by dougal2 » Fri Jul 01, 2011 3:49 am

Jambert wrote:Hi Doug, do you know if external material will be supported soon?

thx
Yes, it is on my list of things TODO.

@Zlaty: unfortunately due to the major changes in the internals of Blender from 2.4x->2.5x an automatic conversion of old data is not really possible at this time.

User avatar
Jambert
Indigo 100
Posts: 545
Joined: Wed Jul 30, 2008 10:08 pm
Location: France, Lyon

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by Jambert » Fri Jul 01, 2011 4:21 am

thx for reply,
I know it isn't the good place to ask but I still have no answer to this question. In indigo v3, external material doesn't exist. Would be realy nice if it does, do you know if it's in a TODO?

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by StompinTom » Fri Jul 01, 2011 4:37 am

dougal2 wrote:
Jambert wrote:Hi Doug, do you know if external material will be supported soon?

thx
Yes, it is on my list of things TODO.
Jambert wrote:thx for reply,
I know it isn't the good place to ask but I still have no answer to this question. In indigo v3, external material doesn't exist. Would be realy nice if it does, do you know if it's in a TODO?
*facepalm*

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by drBouvierLeduc » Fri Jul 01, 2011 4:44 am

Here's a quick question for blendigo masters regarding UV sets :
I have a mesh with two UV sets, say UVTex-A and UVTex-B.
I want use a material wich is a blend of 2 materials, with a blend map.
Now that blend map must use the second UV set, UVTex-B.
Is it possible, and how ?
I tried to set the "UV Texture Index" to 1 instead of 0, but it doesn't work.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.58) 3.0.10.1

Post by dougal2 » Fri Jul 01, 2011 5:05 am

drBouvierLeduc wrote:Here's a quick question for blendigo masters regarding UV sets :
I have a mesh with two UV sets, say UVTex-A and UVTex-B.
I want use a material wich is a blend of 2 materials, with a blend map.
Now that blend map must use the second UV set, UVTex-B.
Is it possible, and how ?
I tried to set the "UV Texture Index" to 1 instead of 0, but it doesn't work.
the change to using uv texture index instead of a proper uv set reference kinda happened at the last minute before release - I'm planning to re-instate a more intuitive setup for this.

Post Reply
99 posts

Who is online

Users browsing this forum: Google [Bot] and 1 guest