Blendigo (for Blender 2.58) 3.0.10.1

Announcements, requests and support regarding the Blender Indigo export script
Post Reply
99 posts
User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Blendigo (for Blender 2.58) 3.0.10.1

Post by dougal2 » Wed Jun 29, 2011 5:29 am

3.0.10.1

DOWNLOADS

ALL PLATFORMS: http://www.indigorenderer.com/dist/expo ... 0.10.1.zip

NOTE: This exporter REQUIRES Blender version 2.58a

Changes in this release:

* Use relocatable path for preset CRFs
* Change "auto start" default to On
* Remove display interval
* Add sunlight to pre-export light checks
* Fix crash exporting objects with no material assigned (will use default clay mat)
* Improve error handling during scene export
* Implemented Exit Portals properly, as a Mesh option, no longer a material
* Implemented IES settings export
* Added emission scale settings
* Add Material ID render setting; removed Hybrid
* Corrected D55 whitepoint labelling

INSTALLATION

Unzip the archive. Move the indigo folder from blendigo-2.5-3.0.10/sources into your Blender addons folder.
You should end up with <blender scripts>/addons/indigo/

Run Blender 2.5, go into User Preferences/Addons, and find the Render section. Locate the Blendigo entry
and enable the addon by clicking the little checkbox on the right.

Save your User Settings now to make Blendigo activate every time you start Blender 2.5.

Non-windows users will have to also fill in the "Path to Indigo" setting in the "Indigo Render Engine Settings"
panel. (Windows does this automatically from the information provided by the installer). Note that you should
specify the actual Indigo binary file for this setting.

YOUR FEEDBACK IS ALWAYS APPRECIATED

As with the current efforts to get Indigo 3.0 as complete and user-friendly as possible,
please please keep reporting any issues you find with Blendigo - it is your feedback as
users and artists alone that push Blendigo forward into being the software that works for you.

I have a note of the other things still TODO; I'll try to get another update together soon (within 2 weeks)

SerNick
Posts: 10
Joined: Wed Jun 29, 2011 6:03 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1 [Page 5]

Post by SerNick » Wed Jun 29, 2011 6:09 am

I've got error:
Not all arguments converted during string formating.

No matter what i render... simple scene or something that works on previous version.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10.1 [Page 5]

Post by dougal2 » Wed Jun 29, 2011 7:02 am

SerNick wrote:I've got error:
Not all arguments converted during string formating.

No matter what i render... simple scene or something that works on previous version.
I need some more information to be able to work out what's happening:
- Blender version ?
- Blendigo version ?
- OS ?
- Ideally the full trace from the console window would help a lot.
- Any specific non-default settings you were using ?
- Can you post a .blend file which shows the problem reliably ?

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by StompinTom » Wed Jun 29, 2011 7:20 am

Will test tonight! Thanks a lot for your hard work, Doug!

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by drBouvierLeduc » Wed Jun 29, 2011 8:06 am

Hi Dougal, thanks for the update.

I have the same error message than Sernick.
I'm using a scene that worked fine with the previous iteration of blendigo, but now I have this error message :

Code: Select all

[Indigo 2011-Jun-28 21:56:33] INFO: Export render settings
[Indigo 2011-Jun-28 21:58:33] ERROR: not all arguments converted during string formatting
So I figured maybe there was a problem with the path to indigo, so I changed from a relative path (//../../../../../../../../opt/indigo/indigo) to an absolute path (/opt/indigo/indigo)
Now the export goes a little bit further, but in the end, it's the same error message :

Code: Select all

Indigo export started ...
[Indigo 2011-Jun-28 21:58:00] Writing to /home/charles/Documents/temporaire/blender/maison_cap_schanck_08.Scene.00019.igs
[Indigo 2011-Jun-28 21:58:00] INFO: Export render settings
[Indigo 2011-Jun-28 21:58:00] ERROR: not all arguments converted during string formatting
ubuntu 10.04 64-bit
Blendigo 3.0.10.1
Indigo 3.0.10 linux 64-bit

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by dougal2 » Wed Jun 29, 2011 9:36 am

Grrr! This happened because of the longer version number... please re-download the exporter and try again, should be fixed now!

User avatar
Polinalkrimizei
Posts: 632
Joined: Sat May 02, 2009 6:59 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by Polinalkrimizei » Wed Jun 29, 2011 9:56 am

Hi, I'm having the same problem.

Win 7 64 bit, Blendigo 3.0.10.1 (just downloaded it another time and reinstalled it), indigo 3.0.10 64bit

That scene used to work before and now it doesn't. Even if I move all geometry to another layer...
Attachments
test.jpg

User avatar
Headroom
Indigo 100
Posts: 987
Joined: Wed Aug 08, 2007 1:07 pm
Location: Spartanburg, SC, USA

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by Headroom » Wed Jun 29, 2011 10:11 am

It's not working on OSX either. Rendering the default cube I get the same error message about not all arguments being converted during string formating.

Using Blender 2.58 though.
iMac 2.93 GHz Quad Core i7. 12 GB memory
ATI Radeon HD 5750M 1024 MB
OS X 10.10.3 Yosemite
Blender 2.72, Blendigo 3.8.25, Indigo 3.8.26

Trippy Lighting LLC - Colorful LED lighting systems
High Power RGB LED driver - Blog

SerNick
Posts: 10
Joined: Wed Jun 29, 2011 6:03 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by SerNick » Wed Jun 29, 2011 10:18 am

No.. stilll not working for me.

Next little bug i found in version 3.0.10:
small change in ExternalMaterial.py should fix problem with export of external materials:

from: def build_xml_element(self, context):
to: def build_xml_element(self, context, scene=None):
in line 36.

User avatar
dougal2
Developer
Posts: 2532
Joined: Wed Nov 15, 2006 8:17 am
Location: South London

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by dougal2 » Wed Jun 29, 2011 10:43 am

Really sorry everyone, my upload script managed to package and upload the exact same code as before!
I've done it by hand this time, and the .zip on the server is definitely the correct one now.
:oops:

SerNick
Posts: 10
Joined: Wed Jun 29, 2011 6:03 am

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by SerNick » Wed Jun 29, 2011 11:13 am

Yes, now it's work :)

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by drBouvierLeduc » Thu Jun 30, 2011 12:58 am

That strange bug due to longer version number is indeed fixed (how a longer version number can screw up the export process is a total mystery to me, btw...)

I found an issue regarding particles : the "disable from rendering" option in the modifier panel seems to be ignored (the little camera icon, next to the eye icon). So any particle system on the scene will mess up the export, even if disabled from rendering.

Code: Select all

...
[Indigo 2011-Jun-29 14:13:27] Exporting meshes: 69%
[Indigo 2011-Jun-29 14:13:28] Exporting meshes: 85%
[Indigo 2011-Jun-29 14:13:28] ERROR: Error: Object does not have duplis.
Here is the problem in detail :
I have a plane with a particle modifier, render type for particles is set to "object".
The plane is then covered with several instances of that object.
Particles being not (yet ?) handled by blendigo, I have to convert them to real meshes via the modifier panel.
(That conversion can be painfully long even with a rather small number of particles, but well, that's blender's problem).
After the conversion, the particle modifier is still attached to the plane.
So, the "render" option being ignored, the only way to export the scene is to completely remove that particle system, which will be lost next time you restart blender (being not used by any mesh anymore).

I'm trying to export a decently good looking grass, but at the moment, it's quite a painfull experience !...
Is particle export on the to-do list b.t.w ?

StompinTom
Indigo 100
Posts: 1820
Joined: Mon Sep 04, 2006 3:33 pm

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by StompinTom » Thu Jun 30, 2011 2:40 am

drBouvierLeduc wrote:That strange bug due to longer version number is indeed fixed (how a longer version number can screw up the export process is a total mystery to me, btw...)

I found an issue regarding particles : the "disable from rendering" option in the modifier panel seems to be ignored (the little camera icon, next to the eye icon). So any particle system on the scene will mess up the export, even if disabled from rendering.

Code: Select all

...
[Indigo 2011-Jun-29 14:13:27] Exporting meshes: 69%
[Indigo 2011-Jun-29 14:13:28] Exporting meshes: 85%
[Indigo 2011-Jun-29 14:13:28] ERROR: Error: Object does not have duplis.
Here is the problem in detail :
I have a plane with a particle modifier, render type for particles is set to "object".
The plane is then covered with several instances of that object.
Particles being not (yet ?) handled by blendigo, I have to convert them to real meshes via the modifier panel.
(That conversion can be painfully long even with a rather small number of particles, but well, that's blender's problem).
After the conversion, the particle modifier is still attached to the plane.
So, the "render" option being ignored, the only way to export the scene is to completely remove that particle system, which will be lost next time you restart blender (being not used by any mesh anymore).

I'm trying to export a decently good looking grass, but at the moment, it's quite a painfull experience !...
Is particle export on the to-do list b.t.w ?
Particles work fine with Blendigo! This quick example has 2-3 particle systems that distribute 8-10 different foliage models using DupliGroups.
Attachments
grass-test1_s.jpg

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by CTZn » Thu Jun 30, 2011 3:39 am

That's wild, tom !
obsolete asset

User avatar
drBouvierLeduc
Posts: 412
Joined: Wed Oct 11, 2006 2:32 am
Location: france

Re: Blendigo (for Blender 2.5x) 3.0.10.1

Post by drBouvierLeduc » Thu Jun 30, 2011 5:12 am

@StompinTom : Superb example !... And you call that "simple" ?
Well, there's something I must be doing wrong, no matter what I do, my particles simply abort the export.
I'm using the same technique as you describe though : dupligroups with particles.

Post Reply
99 posts

Who is online

Users browsing this forum: No registered users and 1 guest