Indigo 0.7F exporter here! Features added/Comments welcome!

Announcements, requests and support regarding the Blender Indigo export script
zuegs
Posts: 380
Joined: Tue Jun 27, 2006 5:46 pm
Location: switzerland

Post by zuegs » Tue Jan 16, 2007 9:31 pm

Hi Wedge,

just as i saw your post in other forum... the "<gain>" tag for textures is no more valid for v0.7t1 !
Please see Onos ChangeLog for v0.7t1:
* removed gain from texture elements, using a, b, c polynomial coefficients instead
all textures (albedo and bump) use the <b> tag for gain. Final color/bump is calculated by polynomial from "pix" pixelcolor in image:
col = pix^2*a + pix*b + c (not absolutely sure if this is right)
So <b> is the linear scale, <c> is an offset (defaults to zero), don't know when using <a> :wink:

Wedge
Posts: 441
Joined: Sun Jan 14, 2007 11:33 am
Location: East Coast, USA

Post by Wedge » Tue Jan 16, 2007 10:18 pm

Thanks for bringing this to my attention. I have overlooked this and its the only thing I have left on my todo list. I'll have a look into the example posted by Nick, your example, and into the testscene and manual to see what else I can find.

Update: Opps, it appears my todo list has the blend material on it, which appears different than the gain thing. But I'll have a look at both.

< embarrassed > I also updated that post I made explaining that you brought this to my attention and to ignore my information. < / embarassed >

Update: Also, I feel it is my duty to tell you that Kosmo said the screwdrivers are made in indigo 06. :) I'm not sure if you are aware. :P

Thanks again!
Content contained in my posts is for informational purposes only and is used at your own risk.

User avatar
afecelis
Posts: 748
Joined: Tue Aug 01, 2006 4:14 am
Location: Colombia
Contact:

Post by afecelis » Wed Jan 17, 2007 1:33 am

ahhhhhhh! that explains this!:
Image
cool! 8)
AMD Ryzen 7 1800 @3.6ghz, 32GB ddr4 3200 mhz Ram, 2X Nvidia Gtx 1070 8GB, Win10/Elementary OS 5.0 Juno (ubuntu 18.04), Blender/Sketchup/Modo/Cinema4d

User avatar
OnoSendai
Developer
Posts: 6226
Joined: Sat May 20, 2006 6:16 pm
Location: Wellington, NZ
Contact:

Post by OnoSendai » Wed Jan 17, 2007 1:41 am

Read the updated manual in the 07 test 1 thread for some info on the a, b, c stuff.

User avatar
afecelis
Posts: 748
Joined: Tue Aug 01, 2006 4:14 am
Location: Colombia
Contact:

Post by afecelis » Wed Jan 17, 2007 1:48 am

great Ono, thanks! You mean your updated pdf, right?
I also got this other error:
Image
which I guess is U3dreal's rotation matrices question. But what causes it? I didn´t have any rotated geometry in blender!

ps. Sorry for hijacking the thread a bit. :oops:
AMD Ryzen 7 1800 @3.6ghz, 32GB ddr4 3200 mhz Ram, 2X Nvidia Gtx 1070 8GB, Win10/Elementary OS 5.0 Juno (ubuntu 18.04), Blender/Sketchup/Modo/Cinema4d

User avatar
Pinko
Posts: 58
Joined: Wed Aug 09, 2006 11:06 pm
Location: Italy

Post by Pinko » Wed Jan 17, 2007 3:10 am

it's possible put in this post the correct .py file for export 07...
Tnx in advance
Pinko. :cry:

User avatar
afecelis
Posts: 748
Joined: Tue Aug 01, 2006 4:14 am
Location: Colombia
Contact:

Post by afecelis » Wed Jan 17, 2007 3:40 am

well, there's no such thing as a "correct" python script yet since this is Wedge's work in progress and we're practically beta-testing the code here to report bugs and problems. Still, he has updated the script 9 times since he started it out and has reported each of the improvements he has done to it. You'll always find the latest version available on page 1 of this thread :wink:
AMD Ryzen 7 1800 @3.6ghz, 32GB ddr4 3200 mhz Ram, 2X Nvidia Gtx 1070 8GB, Win10/Elementary OS 5.0 Juno (ubuntu 18.04), Blender/Sketchup/Modo/Cinema4d

User avatar
DaveC
Posts: 596
Joined: Mon Sep 11, 2006 12:20 am
Location: The Tottenham, London, UK
Contact:

Post by DaveC » Wed Jan 17, 2007 6:36 am

Ok. What's the deal here? The first time I copied the script into a text file, it worked. It exported. Now, I copy the same part of the first entry (which has been update, I know) and paste it into exactly the same file (over the top of the old text, obviously) and I get an error!

Code: Select all

  File "<string>", line 47
    Takes module, class, list, dictionary, or string. """

IndentationError: expected an indented block
Am I doing something wrong or is it the script that is in error?
The hardest part of BEING yourself is FINDING yourself in the first place...
http://thebigdavec.googlepages.com

Wedge
Posts: 441
Joined: Sun Jan 14, 2007 11:33 am
Location: East Coast, USA

Post by Wedge » Wed Jan 17, 2007 6:40 am

zuegs wrote:@Mute:
ensure every objects scale is equal for all 3 directions X,Y,Z - all uneqal scaling should be applied to the mesh (not the object) - use Ctrl-A to apply objects asymmetric transformations to the underlying mesh in your case
hope it help, regards, zuegs
Afecelis, the roation matrix fix has been added from zeugs since the early stages. I am posting his quote from the front page when he included more info about that error. Maybe this will help you? Thanks again Zuegs..

Thanks Nick I am reading the 07 manual more fully now.

<gain> tags removed

The SSS crash I found was indeed with SSS and sun. SSS with the rectangle meshlight/blackbody at least gets past the fatal error when starting indigo and starts to render the scene. So Nick has also said this in the thread titled: "absorption and scattering coefficients for liquids" in the Indigo renderer general section, it is a bug he knows about.

I am now in the process of updating the code at the front page and moving all relevant directions to the first post. Will be done very shortly, I'll update this message.

Update: Code updated, directions for new SSS in front page with code, yanking all other directions from earlier posts to make it clearer.
Last edited by Wedge on Thu Jan 25, 2007 1:44 pm, edited 2 times in total.
Content contained in my posts is for informational purposes only and is used at your own risk.

User avatar
DaveC
Posts: 596
Joined: Mon Sep 11, 2006 12:20 am
Location: The Tottenham, London, UK
Contact:

Post by DaveC » Wed Jan 17, 2007 6:43 am

Wedge, I would like to volunteer to host your script for others to download in a zip file. If you email your updates to me at dodgydavec at googlemail dot com I will upload it in a zip file and provide a link.
The hardest part of BEING yourself is FINDING yourself in the first place...
http://thebigdavec.googlepages.com

Wedge
Posts: 441
Joined: Sun Jan 14, 2007 11:33 am
Location: East Coast, USA

Post by Wedge » Wed Jan 17, 2007 7:26 am

DaveC, it is best to copy/paste the entire scrip to avoid whitespace errors.

Thanks for the offer to host but right now I'd like to keep it like it is. (since I have been updating it very often) Hopefully, when U3dreal/other devs get ready with 07 we can merge it together for the download.

The script is GPL all of its terms apply. :) I don't want to take anything away from that so feel free to do whatever as long as its within the license. :)

I, however, will stick to updating in the front on the post.

I rewrote SSS in this update. Update 2: Moved all directions to first page to keep confusion down.
Last edited by Wedge on Thu Jan 25, 2007 1:49 pm, edited 3 times in total.
Content contained in my posts is for informational purposes only and is used at your own risk.

User avatar
DaveC
Posts: 596
Joined: Mon Sep 11, 2006 12:20 am
Location: The Tottenham, London, UK
Contact:

Post by DaveC » Thu Jan 18, 2007 11:43 am

I am, as of now, having absolutely no luck whatsoever getting the exporter to do SSS materials. I make the sss (for example milk.med) and the material (ball.milk) as instructed. The resulting xml doesn't even have a medium tag in it anywhere. I need some step by step instructions. Can anybody help?

EDIT:
Scratch that, I didn't have RayTrans for the medium switched on.
How do you set how much the light is absorbed in the medium?
The hardest part of BEING yourself is FINDING yourself in the first place...
http://thebigdavec.googlepages.com

User avatar
afecelis
Posts: 748
Joined: Tue Aug 01, 2006 4:14 am
Location: Colombia
Contact:

Post by afecelis » Thu Jan 18, 2007 2:09 pm

@Radiance: check page 1 of this thread. Code is updated there. Copy and paste it into a text editor. :wink: Save as .py
AMD Ryzen 7 1800 @3.6ghz, 32GB ddr4 3200 mhz Ram, 2X Nvidia Gtx 1070 8GB, Win10/Elementary OS 5.0 Juno (ubuntu 18.04), Blender/Sketchup/Modo/Cinema4d

Wedge
Posts: 441
Joined: Sun Jan 14, 2007 11:33 am
Location: East Coast, USA

Post by Wedge » Thu Jan 18, 2007 7:05 pm

Radiance, I wouldn't use this exporter for anything other than tests.

SSS is in partly, but probably not right and it is also confusing. It is likely not going to work as expected and is still in the process of a rewrite.

In the material post by Afecelis I have posted some ideas on how to think about implementing it in a clearer way. I will likely try rewriting it but I'd prefer to get some other people's ideas about how they think it can/should be done.

Update: But as far as I know, all of the other added features are working good. I recently did a bigger render of a ball with a reflection using the normal smooth. Looks nice! So the exporter appears to be in good shape if you only use diffuse or phong materials. It will output some mediums/SSS if you follow directions...and maybe good enough for you to manually edit the xml? I don't know for sure...you will have to test for yourself.
Content contained in my posts is for informational purposes only and is used at your own risk.

User avatar
jurasek
Posts: 247
Joined: Sun Jun 25, 2006 11:23 pm
Location: Poland

Post by jurasek » Fri Jan 19, 2007 2:31 am

How to control bump value in texture if there is no <gain></gain> tag anymore?

greetz,
jur

Post Reply
223 posts

Who is online

Users browsing this forum: No registered users and 5 guests