[Linux only] Indigoo

General questions about Indigo, the scene format, rendering etc...
lego
Posts: 99
Joined: Sat Oct 14, 2006 7:29 am

Post by lego » Thu Nov 30, 2006 3:39 am

The open('logmaster.txt','r') line opens the file for reading, correct?

correct :)



velinje do you have this problem only when using my script? or just when using indigo with wine?

a problem that may arise is that the delay between master and slave launch is too short if compared to large scenes loading time. maybe this is what is causing your problem!

it's very easily solvable

Code: Select all

	
        ...
        time.sleep(5)

	while check==0:
		if os.system(master_id)==0:

       ...
try to increase the sleep time in this line
(like time.sleep(30) )

the socket/tcp error sometimes arises when you stop and immediatly start indigo. you have to wait a bit and it solves itself

Velinje
Posts: 4
Joined: Sat Nov 11, 2006 8:27 pm

Post by Velinje » Thu Nov 30, 2006 12:52 pm

Thanks Lego for the fast response. I have tried to change the "time.sleep()" without success. I installed wine only to try out your script, and that is the only thing I've used it for so far. Going to try out Indigo through wine without the script now I guess.

How can I check if the "open('logmaster.txt','r')" works correct? Cannot retain anything through the command window.

At first when I got the black screen with the comp still calculation mutations, I thought it was somthing going on with user permissions or corrupt files.. but apparently not..

Anyone know how the cashe_tree files works?.. Any help link? Well I deleted them and rendered again... :) Still no success.

Velinje
Posts: 4
Joined: Sat Nov 11, 2006 8:27 pm

Post by Velinje » Sun Dec 03, 2006 7:33 am

I started Indigo through Wine, without the script and the scene caused no trouble at all. So I'm really starting to wonder what's wrong, since the script seemed to work at the beginning. :S

User avatar
kalamadeasidhe
Posts: 15
Joined: Sat Nov 25, 2006 4:09 am

Post by kalamadeasidhe » Mon Dec 04, 2006 8:26 pm

So I finished a working tcl script for the slaves. If you want to use it, I posted it on another thread:
http://www.indigorenderer.com/joomla/fo ... =6945#6945

User avatar
YaroslavL
Posts: 34
Joined: Wed Dec 27, 2006 7:20 am
Location: Ukraine
Contact:

Post by YaroslavL » Wed Dec 27, 2006 8:14 am

thanks, but what about rendering directly from blender.
like yafray or blend2pov?
________________
Yaroslav Lebidko
"3D XATA"
Photorealistic computer projection & design
of architecture constructions, interiors, furniture.
Ternopil, Ukraine
e-mail: ideja@3dxata.te.ua
web: www.3DXATA.com.ua

raducoc
Posts: 14
Joined: Sun Jan 14, 2007 2:10 pm

Post by raducoc » Mon Jan 15, 2007 4:36 am

Has managed somebody to make the latest 0.7 beta to work under Linux? Personally I cant figureout how to make Indigo to work. everytime when Im launching Indigo (wine indigo.exe) Im getting the following error message:

Fatal Error:
SceneLoaderExcep: failed to load XML doc from path "D:\programming\modules\testscenes\phong_test.xml": Failed to open file Line 0, column 0.

P.S. I edited the inifile.txt changing "D:\programming\modules\testscenes\phong_test.xml" with my new location and now Im getting this:

"Failed to open file Line 0, column 0".

Any clues what this error want to say?

User avatar
kalamadeasidhe
Posts: 15
Joined: Sat Nov 25, 2006 4:09 am

Post by kalamadeasidhe » Mon Jan 15, 2007 6:14 am

Have you tried giving it the path of a scene instead of just the defaults?

raducoc wrote:Has managed somebody to make the latest 0.7 beta to work under Linux? Personally I cant figureout how to make Indigo to work. everytime when Im launching Indigo (wine indigo.exe) Im getting the following error message:

Fatal Error:
SceneLoaderExcep: failed to load XML doc from path "D:\programming\modules\testscenes\phong_test.xml": Failed to open file Line 0, column 0.

P.S. I edited the inifile.txt changing "D:\programming\modules\testscenes\phong_test.xml" with my new location and now Im getting this:

"Failed to open file Line 0, column 0".

Any clues what this error want to say?

raducoc
Posts: 14
Joined: Sun Jan 14, 2007 2:10 pm

Post by raducoc » Mon Jan 15, 2007 1:43 pm

kalamadeasidhe wrote:Have you tried giving it the path of a scene instead of just the defaults?
Yes. This one:
wine indigo.exe -t 2 dragon1.zip

but Im getting the following error message:

SceneLoaderExcep: failed to load XML doc from path "dragon1.zip": Error document empty. Line 0, column 0.

For more detail see this: http://blenderartists.org/forum/showthr ... post790358

User avatar
kalamadeasidhe
Posts: 15
Joined: Sat Nov 25, 2006 4:09 am

Post by kalamadeasidhe » Mon Jan 15, 2007 3:56 pm

That's because that is a zip file not an xml file. Try just making something in blender/3ds and rendering that real quick. What does it say for you then?
raducoc wrote:
kalamadeasidhe wrote:Have you tried giving it the path of a scene instead of just the defaults?
Yes. This one:
wine indigo.exe -t 2 dragon1.zip

but Im getting the following error message:

SceneLoaderExcep: failed to load XML doc from path "dragon1.zip": Error document empty. Line 0, column 0.

For more detail see this: http://blenderartists.org/forum/showthr ... post790358

Post Reply
24 posts

Who is online

Users browsing this forum: No registered users and 4 guests