Coming Soon: ISLPreviewer

General questions about Indigo, the scene format, rendering etc...
OBI_Ron
Posts: 75
Joined: Sun Aug 13, 2006 2:36 am

Post by OBI_Ron » Fri Jan 30, 2009 3:53 pm

Very well then, I shall push on. Until such time as I can afford an upgrade.

I appreciate your help!!

User avatar
5OnIt
Posts: 157
Joined: Sat Mar 03, 2007 5:11 am

Post by 5OnIt » Sun Feb 01, 2009 9:32 am

It works on my system, although Indigo freezes up every so often after hitting the "Render Preview" button. I feel what is needed and sorely lacking are some tutorials! OK, it works... but now what??

OBI_Ron
Posts: 75
Joined: Sun Aug 13, 2006 2:36 am

Post by OBI_Ron » Sun Feb 01, 2009 9:40 am

Some material coming soon from me - not really a tutorial, just some information from poking around. I hope to expand it into tutorials eventually, but for now, it will just be information - most of which will be common knowledge to the majority of people, but new material for me and others like me.

OBI_Ron
Posts: 75
Joined: Sun Aug 13, 2006 2:36 am

Post by OBI_Ron » Mon Feb 02, 2009 4:59 am

MSUdom5,

I have the program working on a win machine, but I have one question - every screenshot I have seen has 3 tabs - Albedo, Bump and Displace. When I run the program, all I see is Albedo. How do I get the other tabs?

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Mon Feb 02, 2009 2:51 pm

They haven't been implemented yet. :)

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Mon Feb 02, 2009 8:37 pm

Hey MSUdom5,

I'm getting the same problem as OBI_Ron but I don't have any problems with my video card. I'm running a GeForce 8500 and I can change the texture and see the changes on Suzanne. I also set the Indigo path to the correct one and even tried to hand edit the config file. I'm running Fedora 9. Could it be the version of java that I'm running?

java version "1.6.0"
OpenJDK Runtime Environment (build 1.6.0-b09)
OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)

Thanks
OBI_Ron wrote:Hello Everyone,

I must be missing something. I am running on Ubuntu 8.04. The program starts fine. I load the suzane mesh, and click update preview, and nothing happens. If I click Preview...Render Preview, I get :

Problem launching indigo.

I have set the Indigo path to point to the correct directory, and Indigo starts fine manually. I have launched the ISLPreviewer from a terminal, and there are no error showing.

Can anybody offer a clue?

Thanks in advance!
Grimm

MSUdom5
Posts: 159
Joined: Sun Jul 20, 2008 6:04 am
Location: Mississippi, USA
Contact:

Post by MSUdom5 » Tue Feb 03, 2009 4:21 am

Grimm, not sure what's going on. ISL Previewer creates a simple preview texture, launches indigo and loads the preview scene. The "Problem launching indigo" message means that java wasn't able to launch the indigo executable. It could have something to do with your version of Java, but I'm not sure. I only tested under Sun Java. (Not a huge fan of OpenJDK.) I did most of my development in Fedora 9 using eclipse, so the OS definitely isn't the problem.

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Tue Feb 03, 2009 4:51 pm

Sounds good, thanks. I will install Sun Java and see if it makes any difference.
Grimm

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Wed Feb 04, 2009 7:20 am

I tried the Sun Java, but it didn't work either. :( So I went looking for another option. It looks like Indigo has some kind of problem with the preview_squaretile.jpg file. When I tried to load the preview igs into Indigo I get the following error:

Code: Select all

Warning: failed to decode texture '/home/jason/Download/ISLPreviewer_v0.1/preview/textures/preview_squaretile.jpg'.
Error: IndigoDriverExcep: SceneLoaderExcep: Failed to load texture '/home/jason/Download/ISLPreviewer_v0.1/preview/textures/preview_squaretile.jpg' (In element 'albedo_texture', around line 69, column 13): ImFormatExcep: Error while reading JPEG file: Bogus message code %d
Stopped.
I tried to modify the file and re-save it in Gimp but it didn't make any difference. I can load the file into Gimp and other image programs, but Indigo does not like it. This is with the linux version 1.1.16, I also tried 1.1.15 and 1.0.9. Well 1.0.9 had other errors so I wasn't able to tell if the image file would have been a problem or not.

1.1.15 had another error altogether:

Code: Select all

IndigoDriverExcep: SceneLoaderExcep: Failed to load texture '/home/jason/Download/ISLPreviewer_v0.1/preview/textures/preview_map.float' (In element 'spherical', around line 20, column 9): ImFormatExcep: Error reading .float file: could not open '/home/jason/download/islpreviewer_v0.1/preview/textures/preview_map.float' for reading.
Very strange??
Grimm

User avatar
Grimm
Posts: 119
Joined: Sun Dec 09, 2007 7:38 pm
Location: Fairbanks, Alaska, USA

Post by Grimm » Sun Feb 08, 2009 11:26 am

This looks like it's a problem with the new version of Indigo. At least for the first error, still not sure about the second error.
Grimm

Post Reply
85 posts

Who is online

Users browsing this forum: Majestic-12 [Bot] and 4 guests