Question about edge artifacts and some test results

General questions about Indigo, the scene format, rendering etc...
User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Question about edge artifacts and some test results

Post by CoolColJ » Mon Jun 25, 2007 9:51 pm

See the attached pic - note the edges of the box - will these artifacts go away with more rendering time? If not what's up with the artifacts?

So far rendered in 30mins on my P4 Northwood 3.14ghtz machine. Models imported with Cindigo from C4D R10. Scene is lit by Indigo sky and sun directly above the box. Box is basicly a cube with one side cut out, exported model with no normal smoothing. All diffuse materials

settings

"metropolis" "true"
"large_mutation_prob" "0.4"
"max_change" "0.03"
"max_num_consec_rejections" "500"
"max_depth" "1000"
"bidirectional" "false"
"hybrid" "true"
Attachments
2BallsBox_30minRender.JPG
30min render of models exported from C4D with cindigo
2BallsBox_30minRender.JPG (20.58 KiB) Viewed 2559 times

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 10:04 pm

also some results of a test I've been experimenting with some parameters with this scene and a few others

I found that max_change of 0.03 to 0.02 to be better than the default of 0.01 - resolves the noise quicker and with more detail

large_mutation_prob with low values of like 0.01 to 0.001 slows down the render, but the scene resolves quicker!

bidrectional mode really slows things down.... but sometimes clears up the noise in interior scenes quicker :?:

anyway some tests of the above scene - all rendered in 3.5 mins

in order of fastest - lowest noise etc - even the jpeg sizes agree with this order! More noise = bigger jpeg size :lol:

"metropolis" "true"
"large_mutation_prob" "0.01"
"max_change" "0.03"
"max_num_consec_rejections" "500"
"max_depth" "1000"
"bidirectional" "false"
"hybrid" "true"
Image


"metropolis" "true"
"large_mutation_prob" "0.4"
"max_change" "0.03"
"max_num_consec_rejections" "500"
"max_depth" "1000"
"bidirectional" "false"
"hybrid" "true"
Image

"metropolis" "true"
"large_mutation_prob" "0.01"
"max_change" "0.03"
"max_num_consec_rejections" "500"
"max_depth" "1000"
"bidirectional" "true"
"hybrid" "true"
Image


"metropolis" "true"
"large_mutation_prob" "0.4"
"max_change" "0.03"
"max_num_consec_rejections" "500"
"max_depth" "1000"
"bidirectional" "true"
"hybrid" "true"
Image
Last edited by CoolColJ on Mon Jun 25, 2007 10:18 pm, edited 1 time in total.

okazaky
Posts: 57
Joined: Thu Aug 31, 2006 5:30 am

Post by okazaky » Mon Jun 25, 2007 10:11 pm

Yep, I know that issue.
I think it's a MLT problem because I don't get such artifacts by using PT/BDIR PT.
Moreover I think that the MLT modes are not as accuarate and fast as the PT modes. But it's only a thought ;)

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 10:52 pm

well I did a 30min render in Path tracing mode only and same thing.....

it did reach higher sample count numbers so does seem to be faster in this scene :o

attached
Attachments
im1182766762.JPG
im1182766762.JPG (40.05 KiB) Viewed 2527 times

okazaky
Posts: 57
Joined: Thu Aug 31, 2006 5:30 am

Post by okazaky » Mon Jun 25, 2007 10:56 pm

Hm, are the walls made of one mesh or is every wall a single geometry?

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 10:56 pm

although I have a feeling Bi-directional mode may fix this as the above test renders with BD mode don't seem to have this artifact

stay tuned - rendering now.... with BD and in path tracing mode

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 10:57 pm

okazaky wrote:Hm, are the walls made of one mesh or is every wall a single geometry?
one mesh as far as I know, used the Cindigo object export tag

SimonLarsen
Posts: 289
Joined: Wed Apr 18, 2007 1:52 am
Location: Odense, Denmark

Post by SimonLarsen » Mon Jun 25, 2007 11:10 pm

CoolColJ wrote:
okazaky wrote:Hm, are the walls made of one mesh or is every wall a single geometry?
one mesh as far as I know, used the Cindigo object export tag
You should check it.
I think it is light coming in from the cracks between the walls.

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Post by CTZn » Mon Jun 25, 2007 11:22 pm

What's the color of the box ? If it's too white, light bounces are strong.
obsolete asset

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 11:36 pm

it's just a grey box

anyway it doesn't show when bi-directional mode is turned on! :shock:
in either path tracing, MLT or MLT-Hybrid. But its ure slows the render down

just a 15min render to test in Path traced Bi-directional mode

so is this a glitch, a bug or something else? :)
Attachments
im1182768918.JPG
im1182768918.JPG (69.21 KiB) Viewed 2498 times

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Mon Jun 25, 2007 11:47 pm

now with MLT hybrid bidirectional - no artifacts as well, but man this took longer! Needed 20mins for the same sample level as above
Attachments
im1182770895.JPG
im1182770895.JPG (66.86 KiB) Viewed 2494 times

User avatar
OnoSendai
Developer
Posts: 6179
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Post by OnoSendai » Mon Jun 25, 2007 11:54 pm

I think it's an artifact due to ray origin nudging, the current nudge distance is 0.1 mm, so If your scene is too small, you may see artifacts around the edge of the box. You can fix the artifact by enlarging the scene, or making the walls double-sided, i.e. solid objects.

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Tue Jun 26, 2007 12:30 am

OnoSendai wrote:I think it's an artifact due to ray origin nudging, the current nudge distance is 0.1 mm, so If your scene is too small, you may see artifacts around the edge of the box. You can fix the artifact by enlarging the scene, or making the walls double-sided, i.e. solid objects.
Well the Cinidigo export scaling parameter is set to 0.01 by default

I've been using a 0.1 value, and it seems this is too small then
when I use a scaling of 1.0 - no more artifacts in render :)

8 min render in MLT Hybrid mode (no bi-directional) - much faster rendering for the same sample level as the above 2, but seems noisier than the 2nd render though
Attachments
im1182773947.JPG
im1182773947.JPG (70.48 KiB) Viewed 2479 times

User avatar
deltaepsylon
Posts: 417
Joined: Tue Jan 09, 2007 11:50 pm

Post by deltaepsylon » Tue Jun 26, 2007 1:25 am

I say use blender! :lol: JK, use whatever you feel most comfortable with

User avatar
CoolColJ
Posts: 1734
Joined: Mon Jun 25, 2007 1:47 pm

Post by CoolColJ » Tue Jun 26, 2007 1:31 am

deltaepsylon wrote:I say use blender! :lol: JK, use whatever you feel most comfortable with
I have blender here as well, but it's completely Alien to me!! :?
C4D is so much easier to use. I wish I could get the 4 view mode of C4D in blender, and file open dialog in blender is aggravating

I admit blender exporter is probbaly better developed right now...

Post Reply
25 posts

Who is online

Users browsing this forum: Google [Bot] and 2 guests