water is not rendering in my laptop

Feature requests, bug reports and related discussion
Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

water is not rendering in my laptop

Post by Darshan » Tue Apr 08, 2014 6:53 pm

i am using indigo 3.6 with sketchup 2013 pro. When i tried to render the water as mentioned in this tutorial
"http://www.indigorenderer.com/documenta ... l-sketchup"
After doing all the exact adjustments. when i hit render within few seconds indigo crashes by saying " indigo.exe has stopped working"
What to do...??? I think it is problem of displacement map... :?:

User avatar
bubs
2nd Place Winner
Posts: 611
Joined: Fri Jul 22, 2011 8:46 pm
Location: UK

Re: water is not rendering in my laptop

Post by bubs » Tue Apr 08, 2014 8:18 pm

Are you using the most up to date Skindigo plugin?

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Tue Apr 08, 2014 10:03 pm

i am using this
SkIndigo 3.6.25.3 Released 11 Nov 2013
SketchUp Exporter to Indigo 3.6.25.3
Author: Whaat

User avatar
bubs
2nd Place Winner
Posts: 611
Joined: Fri Jul 22, 2011 8:46 pm
Location: UK

Re: water is not rendering in my laptop

Post by bubs » Tue Apr 08, 2014 10:46 pm

try 3.6.25.5 see if that works... The most recent updates were specifically for newer versions of SketchUp

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Tue Apr 08, 2014 11:22 pm

tried....not working... :cry:
shader scripts and aperture diffraction are not running properly in my laptop from beginning...
i am using indigo 3.6 with sketchup 2013 pro on win 7 ultimate....
6 gb ram, 2 gb nvidia geforce graphics and intel core i3 2.4 ghz processor

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Wed Apr 09, 2014 2:26 am

any help.??????? :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:

User avatar
Zom-B
1st Place 100
Posts: 4636
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: water is not rendering in my laptop

Post by Zom-B » Wed Apr 09, 2014 2:39 am

Check your RAM usage during Indigo start. There is a good chance that the displacement takes to much RAM, in that case reduce the subdiv settings for the water...
polygonmanufaktur.de

User avatar
yonosoy
Posts: 484
Joined: Sat Dec 01, 2012 9:45 pm
Location: Spain

Re: water is not rendering in my laptop

Post by yonosoy » Wed Apr 09, 2014 3:18 am

PLease, DARSHAN, again. (funny, the same sequence).
Or is the RAM, check it. Or do this (just to confirm, could be important...) :

This works in linux 64 and works in windows 32 some time ago (months since this).
Also check what version of the program is running in console mode, info overlay and the most simple Help>About.
Press F1 and tell us what core is running. PLEASE:

If is the 3.6.12 do this:
1) Download Indigo Renderer 3.6.12. You only need to substitute the file ISLstdlib.txt with the one from this version.
2) Probably you need to uninstall the 3.6.26, install the 3.6.12, save the file ISLstdlib.txt in a safe place. Uninstall 3.6.12 and reinstall 3.6.26. Then substitute the file.
2.*) More easy but not sure... The linux version is unzipeable, Found a program to decompress and substitute.
2.**) Before do this confirm that only the code is failing... Could you do a single test with the sun and AD. Works?
"... the hamster don't see the wheel, and this wasn't said before." (yoS eidaN "el Olvidao")
"... nor 0.2 galaxys, nor 0.8 little chikens ..."

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Wed Apr 09, 2014 3:20 am

how to reduce in this...????

def eval() real :
fbm(posOS() * 2.0, 2) * 0.02

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Wed Apr 09, 2014 4:08 am

yonosoy wrote:PLease, DARSHAN, again. (funny, the same sequence).
Or is the RAM, check it. Or do this (just to confirm, could be important...) :

This works in linux 64 and works in windows 32 some time ago (months since this).
Also check what version of the program is running in console mode, info overlay and the most simple Help>About.
Press F1 and tell us what core is running. PLEASE:

If is the 3.6.12 do this:
1) Download Indigo Renderer 3.6.12. You only need to substitute the file ISLstdlib.txt with the one from this version.
2) Probably you need to uninstall the 3.6.26, install the 3.6.12, save the file ISLstdlib.txt in a safe place. Uninstall 3.6.12 and reinstall 3.6.26. Then substitute the file.
2.*) More easy but not sure... The linux version is unzipeable, Found a program to decompress and substitute.
2.**) Before do this confirm that only the code is failing... Could you do a single test with the sun and AD. Works?

noo it is my 3rd time reinstall :( ..
all reinstalls are failing for shaders... :cry:
i am thinking to give a try for indigo 3.8 beta... :|
thanks yonosoy for reply... it is not working... :(

User avatar
yonosoy
Posts: 484
Joined: Sat Dec 01, 2012 9:45 pm
Location: Spain

Re: water is not rendering in my laptop

Post by yonosoy » Wed Apr 09, 2014 4:12 am

:P thanks, Darshan. Please, press F1 and confirm that for windows 32 is OK. What build say there?
"... the hamster don't see the wheel, and this wasn't said before." (yoS eidaN "el Olvidao")
"... nor 0.2 galaxys, nor 0.8 little chikens ..."

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Wed Apr 09, 2014 4:23 am

Indigo Renderer v3.6.26, Windows 32-bit build.

User avatar
yonosoy
Posts: 484
Joined: Sat Dec 01, 2012 9:45 pm
Location: Spain

Re: water is not rendering in my laptop

Post by yonosoy » Wed Apr 09, 2014 4:33 am

Then is OK for windows 32! From 3.6.12 to 3.6.something has the same trouble. Give a chance to an update.
Good luck! :P
P.D. for a fbm noise in the expression
fbm(posOS() * 2.0, 2) * 0.02
the first 2.0 is the scale, the 2 is the octaves number of the noise (higher values gives a more accentuted expresiions, for water 2 or 3 is OK) and the final 0.02 that is multiplyng the expresiion gives a meaning of depth or high of the displacement or bump or ...
"... the hamster don't see the wheel, and this wasn't said before." (yoS eidaN "el Olvidao")
"... nor 0.2 galaxys, nor 0.8 little chikens ..."

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Wed Apr 09, 2014 4:43 am

thank u yonosoy.... :)
my internet download crossed the limit... so my subscription got a speed brake... my download speed is only 20 kbps.. :(
ill keep it for download @ night.. till morning it may be completed

Darshan
Posts: 28
Joined: Wed Jan 22, 2014 7:04 pm
Location: india

Re: water is not rendering in my laptop

Post by Darshan » Thu Apr 10, 2014 3:35 am

good news>>> shaders are running in 3.8.1 beta
bad news>>>> shaders are not working properly... when i added the displace shader for the water as shown in "how to make pool tutorial" it rendered like this very badly... :cry: :cry: :cry:
Attachments
default3.jpg
water is looking like metal...
displace shader used is

def eval() real :
fbm(posOS() * 2.0, 2) * 0.02

Post Reply
23 posts

Who is online

Users browsing this forum: No registered users and 1 guest