geometry disappearing when using displacement

Feature requests, bug reports and related discussion
Post Reply
3 posts • Page 1 of 1
FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

geometry disappearing when using displacement

Post by FakeShamus » Sat Jan 25, 2014 4:57 am

hi, I have noticed strange behavior when using subdivision and displacement on some objects. I think it might have to do with subdividing a mesh that has very long (un-square) poly's - the tree trunk in the attached jpegs had a lot of edges around it's circumference, but very few going up the length of the trunk, so the faces were very long and thin. in the render you can see there was a section "deleted" from the trunk. the deleted geometry would move around kind of at random though and I couldn't pin down a pattern to it (you can see it's s slightly different effect in the second image).

the other weird thing is, it seems to affect the geometry of other objects close to the subdivided object. the red and green base object in the image was not subdivided or displaced at all, but it also has sections deleted (or at least masked, as you can see better in the version with the dark background). the solution was to remove subdivision/displacement from the tree trunk object and everything rendered as expected, but the source of the problem really baffled me for a while.

anyone have some insight to why this might happen like it does? it almost looks like a rectangular shape is clipping all the geometry and maybe that it is camera-view dependent as well? very strange...
Attachments
disp geometry bug.JPG
disp geometry bug 2.JPG

User avatar
CTZn
Posts: 7240
Joined: Thu Nov 16, 2006 4:34 pm
Location: Paris, France

Re: geometry disappearing when using displacement

Post by CTZn » Wed Jan 29, 2014 2:27 am

it might be a modeling problem, where the faces are doubled and sewed along some edge loop; by subdivizing, the sewed parts get smoother and shorter as should sewed faces; my two cents.

e: try to subdivide and smooth first hand in your 3d app in order to make sure that the behaviour is not happening that way too. If it does that means that the geometry needs cleaning.
obsolete asset

FakeShamus
Posts: 508
Joined: Wed May 02, 2007 11:34 am

Re: geometry disappearing when using displacement

Post by FakeShamus » Wed Jan 29, 2014 3:36 am

yeah, it was definitely related to the geometry of the tree trunk object. I added some more edge loops and the subdiv seems to work fine.

the weird thing for me was that it seemed to be affecting other geometry in the scene - I was hoping to shed some light on that.

Post Reply
3 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest