Proxy Material problem

Come here for help & support.
Post Reply
11 posts • Page 1 of 1
User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Proxy Material problem

Post by aleksandera » Tue May 06, 2014 10:52 am

I'm having this idea to export some "fat" mesh out of ZBrush (around 300 mb OBJ file) and than bring it in to Indigo with help of a proxy mesh. The problem I get with this is that such OBJ file doesn't have a proper material link.
What exactly would I have to change - overwrite with a text editor to make this work?

Thank you :)

User avatar
Zom-B
1st Place 100
Posts: 4697
Joined: Tue Jul 04, 2006 4:18 pm
Location: ´'`\_(ò_Ó)_/´'`
Contact:

Re: Proxy Material problem

Post by Zom-B » Tue May 06, 2014 7:18 pm

The carpet I use in most ArchViz scenes has even 500MB :P

What 3D app are you working in mate? I'm in C4D and my workflow for the carpet is to open the OBJ in C4D once and apply Indigo materials etc. then save it as a C4D file and link it in other Projects using a so called Xref.

This is a very common way to work with Proxy objects and not bound to a special Renderer but based on the functionality of your 3D app...
polygonmanufaktur.de

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Proxy Material problem

Post by aleksandera » Tue May 06, 2014 8:13 pm

Well my machine is seven years old:
Intel(R) Core(TM) Quad CPU Q6600 @ 2.4oGHz (4 CPUs), 8GIG RAM, GeForce GTX 660 Ti..
I use Blender. Would rather not try to load that much of geometry in there :D
The point is I'm trying to create some 3d caricatures, and decimating the mesh, setting up normal maps
every time I try to check the resemblance under unbiased light is a bit time consuming. I thought
I cud speed up the process by exporting at least the head mesh with a proxy :mrgreen:

Thank you Zom-B
Attachments
JLB.postpro.jpg

FakeShamus
Posts: 510
Joined: Wed May 02, 2007 11:34 am

Re: Proxy Material problem

Post by FakeShamus » Wed May 07, 2014 12:56 am

I do this often with Zbrush and Blender. Open up the obj and the mtl files in a text editor and change the material name (Zbrush writes "default" by default) to whatever name you gave in Blender. Save them and it should work.

User avatar
Oscar J
1st Place Winner
Posts: 2197
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Proxy Material problem

Post by Oscar J » Wed May 07, 2014 1:47 am

Great character!

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Proxy Material problem

Post by aleksandera » Wed May 07, 2014 2:50 am

FakeShamus, Thank you! I just did this. Working perfectly! :D
The problem I have now is, I can't use external materials. Would this work
the same way with them too?

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Proxy Material problem

Post by aleksandera » Wed May 07, 2014 2:50 am

Oscar J wrote:Great character!
Thank you Oscar J :D

FakeShamus
Posts: 510
Joined: Wed May 02, 2007 11:34 am

Re: Proxy Material problem

Post by FakeShamus » Wed May 07, 2014 2:53 am

I think it should, but the material name within the igm file also needs to match that of the obj. (which is good practice anyway, making all the material names match exactly, across the board.)

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Proxy Material problem

Post by aleksandera » Wed May 07, 2014 3:30 am

FakeShamus wrote:I think it should, but the material name within the igm file also needs to match that of the obj. (which is good practice anyway, making all the material names match exactly, across the board.)
Hm, somehow I can't get this working. But it's not that much important since I can
assign another material in Indigo..

Thank you again FakeShamus! :D

FakeShamus
Posts: 510
Joined: Wed May 02, 2007 11:34 am

Re: Proxy Material problem

Post by FakeShamus » Wed May 07, 2014 3:47 am

weird, it works for me. does the external material name show up properly? (see attached)
I have had instances where that material name does not load correctly in blendigo, for some reason.
and then the external obj has that exact same material name, too, right?
Attachments
ext material proxy.jpg

User avatar
aleksandera
Posts: 379
Joined: Fri Sep 15, 2006 10:49 pm
Location: Slovenia

Re: Proxy Material problem

Post by aleksandera » Wed May 07, 2014 4:24 am

Yes, this is exactly what is happening to me right now. Can't figure out, how to do this right :? :(

Post Reply
11 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest