Indigo SDK 3.2.13

A private discussion forum for users of the Indigo Renderer SDK. Send a private message to OnoSendai if you want access.
Post Reply
8 posts • Page 1 of 1
User avatar
fused
Developer
Posts: 3555
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Indigo SDK 3.2.13

Post by fused » Wed Apr 25, 2012 11:30 pm

Link to SDK build:
Windows - http://www.indigorenderer.com/dist/priv ... _3.2.13.7z
OS X - http://www.indigorenderer.com/dist/priv ... 3.2.13.dmg

Password as per usual. Email me or Nick if you don't have it.


This new SDK also supports IndigoRT. It will load either the indigo_rt_sdk.dll or the indigo_sdk.dll.
If both are present, it will load the indigo_sdk.dll.


SDK Changelog:

(This can be found in documentation/sdk_changelog.txt. There are also all the other changes, listed in changelog.txt)

3.2.10
* IndigoContext now loads indigo_sdk.so (and indigo_rt_sdk.so) on mac.
* Changed IndigoContext to look for the Indigo Renderer SDK then the Indigo RT SDK. returns INDIGO_ERROR_LIBRARY_NOT_FOUND if none was found.

3.2.8
* Added check in finalise(): Check that the number of materials specified for the model is the same as required by the geometry (mesh).
* Removed /GL (link time optimisation flag) from indigo SDK lib build.
* Enabled CUDA and OpenCL for 32-bit SDK dll.

User avatar
rgigante
Posts: 326
Joined: Wed Jun 28, 2006 6:46 am
Location: Italy

Re: Indigo SDK 3.2.13

Post by rgigante » Thu Apr 26, 2012 4:03 am

Thanks Yves!

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: Indigo SDK 3.2.13

Post by subpixel » Sat Apr 28, 2012 11:42 pm

Thank you for realese of new SDK.
However it didn't solve problem I was reffering here: http://www.indigorenderer.com/forum/vie ... 73#p114573

It seems some subtle error introduced in SDK 3.2.6 (since SDK 3.0.21 works well - with only some compatibility changes). It may be related to hardware or some software drivers, since it works well for DCM and me, yet Enslaver or JavaDevil encounter crashes. See this topic: http://www.indigorenderer.com/forum/vie ... 57#p114557 and following. I'll add it to trac as soon as possible.
Sorry, but I'm unable to describe it any better.

Thank you,

User avatar
OnoSendai
Developer
Posts: 6179
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo SDK 3.2.13

Post by OnoSendai » Mon Apr 30, 2012 11:55 pm

Hi subpixel,
One thing to check - please make sure you're catching IndigoExceptions that may be thrown from finalise() in SceneNodeRoot.
This wasn't documented, sorry about that.

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: Indigo SDK 3.2.13

Post by subpixel » Mon Apr 30, 2012 11:59 pm

Hi,

Thanks for pointer, I haven't been looking for exceptions, however crash takes place after scene gets finalized and renderer is initialized with scene or is there some threads dispatched already before startRendering() ? Thanks,

User avatar
OnoSendai
Developer
Posts: 6179
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: Indigo SDK 3.2.13

Post by OnoSendai » Tue May 01, 2012 12:03 am

Hi subpixel,
Renderer::initialiseWithScene() spawns a thread. startRendering() spawns the rendering threads.

User avatar
fused
Developer
Posts: 3555
Joined: Fri Sep 22, 2006 7:19 am
Location: Berlin, Germany
3D Software: Cinema 4D

Re: Indigo SDK 3.2.13

Post by fused » Wed May 02, 2012 12:26 am

ENSLAVER wrote:
ENSLAVER wrote:
Javadevil wrote:I re-installed the latest SDK and max plugin ( 64bit versions )
Set up the simplest of scenes, two boxes one with and emitter material the other simple grey.
3dsmax just freezes up, and the RAM gets eaten up.

Indigo studio runs fine.

System OS Windows 7 64bit, 16Gb RAM.

I also have this issue with the newest version.

Seems to be back to this issue now ^ - nothing renders, memory eaten up until 100% ram usage.

I had this issue with Indigo for Cinema 4D. I forgot to update the indigo sdk .lib.

When you update the SDK you need to rebuild your application, otherwise stuff might go incredibly wrong.

User avatar
subpixel
Developer
Posts: 237
Joined: Sun Mar 28, 2010 9:09 am

Re: Indigo SDK 3.2.13

Post by subpixel » Thu May 03, 2012 3:04 am

Hi fused,

Thanks for your suggestion, it might be the case the first time. I've also added code checking for exceptions around finalise().
Yet still there seems to be an error with scene export on some machines. Again, I'm unable to replicate it, I had offending max scenes, which export correctly on my system, whereas Enslaver's exported scenes suffer from UID erroneous numbering (some nodes use duplicate UIDs). Just to clarify direct rendering works properly.
Enslaver's and mine configurations seem the same apart CPU his AMD vs. mine Intel. However previous SDK's seem to produce same error.
I could provide exported scenes, I just can't see how do this here.

Also is it needed to call finalise on scene root before export (tried both).

Thanks,

Post Reply
8 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 1 guest