problem with bump mapping

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
Post Reply
7 posts • Page 1 of 1
cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

problem with bump mapping

Post by cocash » Wed Mar 16, 2016 8:18 am

Hi all, I have a problem with bumb mapping within skindigo. When I set up bump map for active mesh, in material editor preview I can see the aplied bump. But when I try to render the scene, I get strange result (see the picture)...it is a long time since I did the bump map, so maybe I forgot some studip simple thing :)
Attachments
skindigo 2.jpg
result?
skindigo 1.jpg
bum map visible in material editor

User avatar
thesquirell
Posts: 392
Joined: Fri Aug 29, 2014 3:49 am
Location: Novi Sad, Serbia

Re: problem with bump mapping

Post by thesquirell » Wed Mar 16, 2016 3:13 pm

Not using SketchUp, but just a wild guesses: shading groups, uv maps....

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: problem with bump mapping

Post by cocash » Thu Mar 17, 2016 12:27 am

I am not sure. It happened to me with the SU 15 and latest version os SkIndigo, with older version it worked.
Can I find up-to-date manual for UV mapping in Skindigo somewhere? I tried to search the forum but without luck:( Thank you in advance!

User avatar
galinette
1st Place Winner
Posts: 923
Joined: Sat Jan 09, 2010 1:39 am
Location: Nantes, France
Contact:

Re: problem with bump mapping

Post by galinette » Thu Mar 17, 2016 7:18 pm

Just set your bump image as material texture in SketchUp. As soon as there is a texture, SketchUp will generate UV coordinates.
Eclat-Digital Research
http://www.eclat-digital.com

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: problem with bump mapping

Post by Pibuz » Thu Mar 17, 2016 11:19 pm

+1 Galinette.

Cocash: apply the bump texture as the diffuse SketchUp material texture AND the same texture as the bump map texture in SkIndigo (like you already did).
Then, in the SkIndigo mat panel, change the Albedo scrolldown input from "sketchup" to "None" and set a RGB value (which will be used instead of the sketchup texture).

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: problem with bump mapping

Post by cocash » Mon Mar 28, 2016 10:43 am

Pibuz, thank you for your explanation. I tried to do it as you described, but without success. I also tried to search the forum again being sure I have already read about this problem in some topic...and finally found it!
I followed this great manual:
http://www.indigorenderer.com/forum/vie ... 19&t=13109
it used to work for me but it changed after installation of SU14 and new SkIndigo
Since then, I have been always getting these strange results described also in this thread:
http://www.indigorenderer.com/forum/vie ... 37&t=13595

And the "diagonal artifact" you could see in my first post is the same like there:
http://www.indigorenderer.com/forum/dow ... &mode=view
I am going to do more test scenes hoping to find a solution.

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: problem with bump mapping

Post by Pibuz » Wed Mar 30, 2016 5:57 am

Cocash, using bump maps is a very basic task: I'd like to help you out: it can't be this difficult. :D
Please: post an image of the material you're trying to recreate!

Post Reply
7 posts • Page 1 of 1

Who is online

Users browsing this forum: No registered users and 2 guests