SkIndigo 3.8.25.2 (beta)

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

SkIndigo 3.8.25.2 (beta)

Post by OnoSendai » Wed Jan 14, 2015 12:56 am

Changelog:
Fixed texture colour changes not being exported.
Changed default material exponent to 100. (was 1000)
Added automatic path fix-up for linked IGMS.
Fix for some external objs not being assigned materials properly.
Fix for 'undefined method `downcase' for nil:NilClass' error when texture filename is empty.
Fix for material preview not working properly with backslash characters in name.
Added some file type filters for open file dialogs in SketchUp 2014+

Minimum required Indigo version is 3.8.11.

RBZ: (Works on all platforms)
http://downloads.indigorenderer.com/dis ... 8.25.2.rbz
RBZ Installation instructions: http://www.indigorenderer.com/documenta ... o-rbz-file

Windows Installer:
http://downloads.indigorenderer.com/dis ... taller.exe



If anyone gets a 'reference to deleted Entity' error message, please stop, write down what steps you just took, and send me the .skp scene! (support@indigorenderer.com)


EDIT: updated build with 'Added automatic path fix-up for linked IGMS.'

EDIT: updated build with 'Fix for some external objs not being assigned materials properly.'

EDIT: updated build with 'Fix for 'undefined method `downcase' for nil:NilClass' error when texture filename is empty.'

EDIT: updated build with 'Fix for material preview not working properly with backslash characters in name.'

EDIT: updated build with 'Added some file type filters for open file dialogs in SketchUp 2014+'

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.8.25.2 (beta)

Post by Pibuz » Wed Jan 14, 2015 11:56 pm

Seems wonderful! Thanks!!!

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: SkIndigo 3.8.25.2 (beta)

Post by OnoSendai » Thu Jan 15, 2015 1:00 am

If anyone runs into any bugs/issues with this build let me know!

Enrico
Posts: 15
Joined: Wed Jul 20, 2011 7:29 am

Re: SkIndigo 3.8.25.2 (beta)

Post by Enrico » Thu Jan 15, 2015 3:00 am

Perfect!!!

User avatar
bubs
2nd Place Winner
Posts: 614
Joined: Fri Jul 22, 2011 8:46 pm
Location: UK

Re: SkIndigo 3.8.25.2 (beta)

Post by bubs » Fri Jan 16, 2015 1:54 am

Ono I have a scene that keeps crashing after about 20mins... but with no error report. Can I dropbox you the .pigs to have a look?

User avatar
OnoSendai
Developer
Posts: 6180
Joined: Sat May 20, 2006 6:16 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: SkIndigo 3.8.25.2 (beta)

Post by OnoSendai » Fri Jan 16, 2015 1:58 am

bubs wrote:Ono I have a scene that keeps crashing after about 20mins... but with no error report. Can I dropbox you the .pigs to have a look?
Yes please!

User avatar
bubs
2nd Place Winner
Posts: 614
Joined: Fri Jul 22, 2011 8:46 pm
Location: UK

Re: SkIndigo 3.8.25.2 (beta)

Post by bubs » Fri Jan 16, 2015 2:00 am

Cool, will do! Thanks in advance.

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.8.25.2 (beta)

Post by snorky » Wed Jan 21, 2015 8:22 am

default.jpg
the same problem as previous version...
help :)

skp file + obj
https://drive.google.com/file/d/0B85NcO ... sp=sharing

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.8.25.2 (beta)

Post by snorky » Sat Jan 24, 2015 7:04 pm

any news? :D

Enrico
Posts: 15
Joined: Wed Jul 20, 2011 7:29 am

Re: SkIndigo 3.8.25.2 (beta)

Post by Enrico » Tue Jan 27, 2015 1:18 pm

Hi Ono! I have a problem with "foreground alpha" option...the render start without problems but after more seconds the object slowly disappears and the background invades the scene!
I attach an image...
Attachments
Car 02.jpg
After more seconds
Car 01.jpg
At the start

Enrico
Posts: 15
Joined: Wed Jul 20, 2011 7:29 am

Re: SkIndigo 3.8.25.2 (beta)

Post by Enrico » Tue Jan 27, 2015 3:04 pm

After some tests I realized that the problem occurs with the option "vignetting" disabled!!!

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.8.25.2 (beta)

Post by snorky » Sun Mar 01, 2015 12:29 pm

OnoSendai wrote:EDIT: updated build with 'Fix for some external objs not being assigned materials properly.''
don't work...
scattered object's material set to default

EDIT....

sorry! ...works

I remove any default material on component (front face and back face too)
Did you want that it works in this way?

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.8.25.2 (beta)

Post by Pibuz » Sun Mar 01, 2015 10:49 pm

Hi Snorky! ...What do you mean? You have to unassign the defailt sketchup material from the dummy component for the instance to work?

- - -

Ciao Max! Che vuoi dire? Bisogna rimuovere il materiale default di sketchUp dal componente dummy per far sì che l'instancing funzioni a dovere?

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: SkIndigo 3.8.25.2 (beta)

Post by snorky » Mon Mar 02, 2015 6:19 am

Pibuz wrote:Hi Snorky! ...What do you mean? You have to unassign the defailt sketchup material from the dummy component for the instance to work?

- - -

Ciao Max! Che vuoi dire? Bisogna rimuovere il materiale default di sketchUp dal componente dummy per far sì che l'instancing funzioni a dovere?
yes... works for me if dummy model has not a default material (front and rear face too)

(hahaha, Pibuz translate for me if my english is bad, thanks)

EDIT:

sorry, after more test, ...no default material only on front face.. (rear face color irrelevant)

EDIT: now works... :/
Last edited by snorky on Sat May 02, 2015 7:43 am, edited 1 time in total.

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: SkIndigo 3.8.25.2 (beta)

Post by Pibuz » Wed Mar 11, 2015 3:26 am

Ok, roughly testing.

Small issue: I have made a material and ran the preview. When I change the material's parameters and I run the preview again, the small icon gets updated but when I click to enlarge it I get the old preview. Deleting the old png from the roaming folder doesn't solve the issue..

EDIT: this does NOT seem to happen with all materials, just with one in particular, whose thumbnail is generated automatically as if Indigo is trying to save the preview again and again...

Post Reply
49 posts

Who is online

Users browsing this forum: No registered users and 1 guest