Object scattering with linked external meshes?

Announcements, requests and support regarding SkIndigo - the Sketchup / Indigo exporter.
User avatar
Aflac
Posts: 14
Joined: Wed Feb 18, 2009 10:41 am
Location: Everett, WA
Contact:

Object scattering with linked external meshes?

Post by Aflac » Fri Dec 19, 2014 11:06 am

I'm trying to achieve a scatter effect for a proxy model which is linking to an external igmesh, but it only scatters the proxy model and does not replace them with the linked mesh. Is there a way to achieve this currently?

User avatar
Aflac
Posts: 14
Joined: Wed Feb 18, 2009 10:41 am
Location: Everett, WA
Contact:

Re: Object scattering with linked external meshes?

Post by Aflac » Fri Dec 19, 2014 11:07 am

And just for reference: the proxy model is updating correctly by itself so there is no problem with the file link.

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Object scattering with linked external meshes?

Post by Pibuz » Tue Dec 23, 2014 3:19 am

I've had some other issues working with those.. Gonna re-test soon. I'll let you guys know.

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: Object scattering with linked external meshes?

Post by snorky » Sat Dec 27, 2014 12:33 pm

Aflac wrote:I'm trying to achieve a scatter effect for a proxy model which is linking to an external igmesh, but it only scatters the proxy model and does not replace them with the linked mesh. Is there a way to achieve this currently?
with external .obj works...

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: Object scattering with linked external meshes?

Post by cocash » Tue Feb 24, 2015 9:58 am

Hi all,
I have the same problem with linked obj trees by Xfrog. As you can see in the Indigo screenshot, there are many proxies which were not replaced by external meshes. And the strange thing for me is, that original proxy is replaced by linked model. Am I doing something wrong?
Attachments
sk_scatter.jpg
SU screenshot
in_scatter_cr.jpg
Indigo screenshot, only one (original) proxy was replaced...

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: Object scattering with linked external meshes?

Post by cocash » Sun Mar 01, 2015 12:43 am

I have been trying to find a solution for described problem. So I made a new group linked to external .obj model and tried to scatter it. The result I got was image full of scattered object, but with wrong textures - you can see it in the picture, that bark texture is wrongfully mapped on needles and branches. And the original model is OK, as it was in previous case. Does anybody know, how to solve it? :(
Attachments
test scatter2.jpg
indigo screenshot

User avatar
Oscar J
1st Place Winner
Posts: 2173
Joined: Sat Mar 31, 2012 3:47 am
Location: Gothenburg, Sweden
3D Software: Blender

Re: Object scattering with linked external meshes?

Post by Oscar J » Sun Mar 01, 2015 12:52 am

Wish I could help, though I'm not a SU user. Looks like an interesting scene though!

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: Object scattering with linked external meshes?

Post by cocash » Sun Mar 01, 2015 10:07 am

Thanks Oscar! This is only simple scene created to illustrate where is the problem. I hope somebody will know the solution.

User avatar
snorky
Indigo 100
Posts: 323
Joined: Fri Apr 17, 2009 8:54 pm
Location: Parma, Italy

Re: Object scattering with linked external meshes?

Post by snorky » Sun Mar 01, 2015 8:50 pm

cocash wrote:Thanks Oscar! This is only simple scene created to illustrate where is the problem. I hope somebody will know the solution.
http://www.indigorenderer.com/forum/vie ... 17&t=13424
:D

User avatar
Antonis777
Posts: 95
Joined: Mon Jan 09, 2012 3:11 am

Re: Object scattering with linked external meshes?

Post by Antonis777 » Mon Mar 02, 2015 3:51 am

cocash wrote:I have been trying to find a solution for described problem. So I made a new group linked to external .obj model and tried to scatter it. The result I got was image full of scattered object, but with wrong textures - you can see it in the picture, that bark texture is wrongfully mapped on needles and branches. And the original model is OK, as it was in previous case. Does anybody know, how to solve it? :(
How did you scattered it? Did you use skindigo scatter editor, or just dummies?

User avatar
Antonis777
Posts: 95
Joined: Mon Jan 09, 2012 3:11 am

Re: Object scattering with linked external meshes?

Post by Antonis777 » Mon Mar 02, 2015 4:02 am

Scatter editor.jpg
Dummies.jpg
These are the results I got. Wrong textures with scatter editor.

cocash
Posts: 20
Joined: Wed Oct 30, 2013 12:36 am
Location: Czech republic,

Re: Object scattering with linked external meshes?

Post by cocash » Mon Mar 02, 2015 4:55 am

Hi Snorky,
thanks for the link. I have tried to do it as you advised but with no success. Are you really sure it is working? It seems to me, that scattering tool exports only two materials of external obj (or some order of materials, I am not sure). Let me show it:
There are two models in my test scene:
Dwarf pine (Pinus mugo), containig two materials (needles and bark, no default material)
Alder buckthorn shrub (Frangula alnus), containig five materials (bark, trunk, leaf1, leaf2, leaf3, no default material)
When I scatter dwarf pine, everything seems ok. When I scatter alder shrub, first it looks good, but there is something wrong with the color of leaves. When you take a look in the detailed picture, you can see that textures are (again) wrongfully placed (twig texture instead of leaves, leaf texture instead of bark).

Antonis777:
Yes, I am doing it with the scatter editor.
Attachments
scatter test pine.jpg
dwarf pine scatter, good result
scatter test alder.jpg
alder scatter, seems good but what is wrong with the colour of leaves?
scatter test alder_closelook.jpg
alder scatter, detailed view, wrongfully placed textures, leaves instead of bark, etc...

User avatar
mriedel
Posts: 14
Joined: Sat Apr 18, 2015 9:35 am
Location: Minnesota, USA
Contact:

Re: Object scattering with linked external meshes?

Post by mriedel » Sat Apr 18, 2015 12:53 pm

I am having the same issue as Snorky. Dummy components referencing external meshes render properly, but when scattered, the same dummy components have no textures. (See attached picture.) In the link above, the suggestion was to replace the default texture on the component with something (anything?) else. I tried this, to no avail.

Has anyone found a solution? Could someone share a file that worked correctly?

Thanks,
Marc
Attachments
test.jpg
----
The Riedelian Law of Productivity: Every task will take twice as long as expected -- even if the Riedelian Law of Productivity is taken into account.

User avatar
Lal-O
2nd Place Winner
Posts: 300
Joined: Wed Sep 23, 2015 7:09 am
Location: México
3D Software: SketchUp
Contact:

Re: Object scattering with linked external meshes?

Post by Lal-O » Thu Nov 26, 2015 3:37 am

.....I just don't even know how to use the scatter editor :D

User avatar
Pibuz
1st Place 100
Posts: 2645
Joined: Tue Dec 11, 2007 7:58 am
Location: Padua, Italy
3D Software: SketchUp

Re: Object scattering with linked external meshes?

Post by Pibuz » Thu Nov 26, 2015 3:46 am

It's very simple.
I'm writing a tut about it: if you're interested, you can check my blog in a few days if you can understand Italian language (don't be scared: I attach LOADS of images :lol: )

Post Reply
16 posts

Who is online

Users browsing this forum: No registered users and 3 guests